Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Denial of Service in strongSwan
Aktuelle Meldungen Distributionen
Name: Denial of Service in strongSwan
ID: USN-3397-1
Distribution: Ubuntu
Plattformen: Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 17.04
Datum: Mo, 21. August 2017, 16:32
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11185

Originalnachricht


--===============7565632973125890540==
Content-Type: multipart/signed; micalg="pgp-sha256";
protocol="application/pgp-signature";
boundary="=-ACX7agUOA8MTsXv9+efN"


--=-ACX7agUOA8MTsXv9+efN
Content-Type: text/plain; charset="UTF-8
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-3397-1
August 21, 2017

strongswan vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 17.04
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

strongSwan could be made to crash or hang if it received specially
crafted network traffic.

Software Description:
- strongswan: IPsec VPN solution

Details:

It was discovered that strongSwan incorrectly handled verifying
specific RSA signatures. A remote attacker could use this issue
to cause strongSwan to crash, resulting in a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 17.04:
  libstrongswan                   5.5.1-1ubuntu3.2
  strongswan                      5.5.1-1ubuntu3.2

Ubuntu 16.04 LTS:
  libstrongswan                   5.3.5-1ubuntu3.4
  strongswan                      5.3.5-1ubuntu3.4

Ubuntu 14.04 LTS:
  libstrongswan                   5.1.2-0ubuntu2.7
  strongswan                      5.1.2-0ubuntu2.7

In general, a standard system update will make all the necessary
changes.

References:
  https://www.ubuntu.com/usn/usn-3397-1
  CVE-2017-11185

Package Information:
  https://launchpad.net/ubuntu/+source/strongswan/5.5.1-1ubuntu3.2
  https://launchpad.net/ubuntu/+source/strongswan/5.3.5-1ubuntu3.4
  https://launchpad.net/ubuntu/+source/strongswan/5.1.2-0ubuntu2.7

--ÚCX7agUOA8MTsXv9+efN
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAABCAAGBQJZmtdBAAoJEEW851uECx9pVB8P/R1Slozk5N07BOPkDecUdQVG
ikaxxQ6Psrb5+Odo6Nfatheq2XHJ32zhfNtIK6QrL/SMigAy080R9k72GLUFwivf
TRvr7nulYBTzrSGRJIqnz8PPDsE+SKTXlzh+5hEGxE/Lp64sC8Qf0UbcYJY2AK50
X6JZ8kcw2OfYIM7UGGwnNGOLeRVWQ1hh01eFVmiESZTXh0b9ntO0PoE22aidVtKB
UWTcqDjo5njbcvwNcng4nI+y2AsV3ZWiOgGIpHJ1mLe2bvXGJRrjkqCBIjKOEwjG
IFFErYhx6yRW8kd49fTjREHxK/VkOIour9dNOhot3+PzdO8rg2JeZzHWf0tDL9lH
oTpPu8dPZ4jSdY8tc6+HMKfV3m5z+raEkNrI3WXBQHp8VdzQqVV8VCp2ODKrqg8V
QDmky6LumQuXWfViHBjs2ju8C1hv6D2Fcu2TmUM2iy8UOZJRayEZEO2MdA+32hTI
Mvm5jDyOsZrdlX40rDTCiyWzMlxMZ/hs2CoTZjj4NBjDWDqa8W1wxumzjilc3s3j
P2cuufH6eM/h3O9TZeLRE2E7J1rX5ksKQeyQEoMef6/3Sm7bKz6vnlBPS0QCHPFG
UwFvWNsmP7Hv2mTX6AspnwWAV7Kls7+Evzx+cAxL32KH9MDzYo5YAJU4kX4tU7z7
X6+SxOVlGllhEqfUEZOZ
=Yua/
-----END PGP SIGNATURE-----

--=-ACX7agUOA8MTsXv9+efN--



--===============7565632973125890540==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

--===============7565632973125890540==--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung