Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in freerdp
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in freerdp
ID: SUSE-SU-2017:2234-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Desktop 12-SP2, SUSE Linux Enterprise Software Development Kit 12-SP2, SUSE Linux Enterprise Workstation Extension 12-SP2, SUSE Linux Enterprise Desktop 12-SP3, SUSE Linux Enterprise Workstation Extension 12-SP3, SUSE Linux Enterprise Software Development Kit 12-SP3
Datum: Di, 22. August 2017, 23:19
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2839
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2838
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2835
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2834
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2836
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-2837

Originalnachricht

   SUSE Security Update: Security update for freerdp
______________________________________________________________________________

Announcement ID: SUSE-SU-2017:2234-1
Rating: important
References: #1050699 #1050704 #1050708 #1050711 #1050712
#1050714
Cross-References: CVE-2017-2834 CVE-2017-2835 CVE-2017-2836
CVE-2017-2837 CVE-2017-2838 CVE-2017-2839

Affected Products:
SUSE Linux Enterprise Workstation Extension 12-SP3
SUSE Linux Enterprise Workstation Extension 12-SP2
SUSE Linux Enterprise Software Development Kit 12-SP3
SUSE Linux Enterprise Software Development Kit 12-SP2
SUSE Linux Enterprise Desktop 12-SP3
SUSE Linux Enterprise Desktop 12-SP2
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.

Description:

This update for freerdp fixes the following issues:

- CVE-2017-2834: Out-of-bounds write in license_recv() (bsc#1050714)

- CVE-2017-2835: Out-of-bounds write in rdp_recv_tpkt_pdu (bsc#1050712)

- CVE-2017-2836: Rdp Client Read Server Proprietary Certificate Denial
of Service (bsc#1050699)

- CVE-2017-2837: Client GCC Read Server Security Data DoS (bsc#1050704)

- CVE-2017-2838: Client License Read Product Info Denial of Service
Vulnerability (bsc#1050708)

- CVE-2017-2839: Client License Read Challenge Packet Denial of Service
(bsc#1050711)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Workstation Extension 12-SP3:

zypper in -t patch SUSE-SLE-WE-12-SP3-2017-1365=1

- SUSE Linux Enterprise Workstation Extension 12-SP2:

zypper in -t patch SUSE-SLE-WE-12-SP2-2017-1365=1

- SUSE Linux Enterprise Software Development Kit 12-SP3:

zypper in -t patch SUSE-SLE-SDK-12-SP3-2017-1365=1

- SUSE Linux Enterprise Software Development Kit 12-SP2:

zypper in -t patch SUSE-SLE-SDK-12-SP2-2017-1365=1

- SUSE Linux Enterprise Desktop 12-SP3:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2017-1365=1

- SUSE Linux Enterprise Desktop 12-SP2:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2017-1365=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Workstation Extension 12-SP3 (x86_64):

freerdp-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-debugsource-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2

- SUSE Linux Enterprise Workstation Extension 12-SP2 (x86_64):

freerdp-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-debugsource-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2

- SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le
s390x x86_64):

freerdp-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-debugsource-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-devel-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2

- SUSE Linux Enterprise Software Development Kit 12-SP2 (aarch64 ppc64le
s390x x86_64):

freerdp-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-debugsource-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-devel-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2

- SUSE Linux Enterprise Desktop 12-SP3 (x86_64):

freerdp-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-debugsource-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2

- SUSE Linux Enterprise Desktop 12-SP2 (x86_64):

freerdp-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2
freerdp-debugsource-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-2.0.0~git.1463131968.4e66df7-12.3.2
libfreerdp2-debuginfo-2.0.0~git.1463131968.4e66df7-12.3.2


References:

https://www.suse.com/security/cve/CVE-2017-2834.html
https://www.suse.com/security/cve/CVE-2017-2835.html
https://www.suse.com/security/cve/CVE-2017-2836.html
https://www.suse.com/security/cve/CVE-2017-2837.html
https://www.suse.com/security/cve/CVE-2017-2838.html
https://www.suse.com/security/cve/CVE-2017-2839.html
https://bugzilla.suse.com/1050699
https://bugzilla.suse.com/1050704
https://bugzilla.suse.com/1050708
https://bugzilla.suse.com/1050711
https://bugzilla.suse.com/1050712
https://bugzilla.suse.com/1050714

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung