Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in PHP
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in PHP
ID: 201709-21
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: So, 24. September 2017, 23:07
Referenzen: https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-11628
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12932
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-11362

Originalnachricht

--nextPart1671579.kM8crp7zrJ
Content-Transfer-Encoding: 7Bit
Content-Type: text/plain; charset="us-ascii"

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201709-21
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: PHP: Multiple vulnerabilities
Date: September 24, 2017
Bugs: #624054, #626460, #629452
ID: 201709-21

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PHP, the worst of which
could result in the execution of arbitrary code.

Background
==========

PHP is an open source general-purpose scripting language that is
especially suited for web development.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-lang/php < 5.6.31:5.6 *>= 5.6.31:5.6
< 7.0.23:7.0 *>= 7.0.23:7.0

Description
===========

Multiple vulnerabilities have been discovered in PHP. Please review the
referenced CVE identifiers for details.

Impact
======

A remote attacker could execute arbitrary code with the privileges of
the process or cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PHP 5.6.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-5.6.31"

All PHP 7.0.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/php-7.0.23"

References
==========

[ 1 ] CVE-2017-11362
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-11362
[ 2 ] CVE-2017-11628
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-11628
[ 3 ] CVE-2017-12932
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12932

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201709-21

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
--nextPart1671579.kM8crp7zrJ
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part.
Content-Transfer-Encoding: 7Bit

-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEEiDRK3jyVBE/RkymqpRQw84X1dt0FAlnIAN0ACgkQpRQw84X1
dt3NQAgAh2djHyq7WTQnZRitRw65wA7DwwpZRlX+PBcNlHpCeFMww9oLTNns4zvq
aJlGFL7hSAq8EHSy71AgLwC/v4a3Z9XYv32IkAw52MVauQ5ZrpV1rg7tK1tqtuUo
512ySX0D3d4EulVKUBxodb1qZ7s/DP4iR8UWUyiS2RIZLeCY/TRSui9NZdqtyeNs
UOL2tOikYjYgo5mfM2c8tYZ5eefEfiqbhTnyI8wtWrHRm48Ibvwp39nM5T2fYRxI
G8UAF3MLpAB0CrEuUdvbwtbcW0WZrbxjKSZQIAX/euQRy2vMMWqgn/cWsHWAMNRq
YhRrQNemRTI2H/S296NC/rBN36TV2Q==
=XK8U
-----END PGP SIGNATURE-----

--nextPart1671579.kM8crp7zrJ--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung