Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in Dnsmasq
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in Dnsmasq
ID: openSUSE-SU-2017:2633-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 42.2, SUSE openSUSE Leap 42.3
Datum: Di, 3. Oktober 2017, 09:43
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14492
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14491
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14494
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14496
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14495
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14493

Originalnachricht

   openSUSE Security Update: Security update for dnsmasq
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:2633-1
Rating: important
References: #1060354 #1060355 #1060360 #1060361 #1060362
#1060364
Cross-References: CVE-2017-14491 CVE-2017-14492 CVE-2017-14493
CVE-2017-14494 CVE-2017-14495 CVE-2017-14496

Affected Products:
openSUSE Leap 42.3
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.

Description:

This update for dnsmasq fixes the following security issues:

- CVE-2017-14491: 2 byte heap based overflow. [bsc#1060354]
- CVE-2017-14492: heap based overflow. [bsc#1060355]
- CVE-2017-14493: stack based overflow. [bsc#1060360]
- CVE-2017-14494: DHCP - info leak. [bsc#1060361]
- CVE-2017-14495: DNS - OOM DoS. [bsc#1060362]
- CVE-2017-14496: DNS - DoS Integer underflow. [bsc#1060364]

This update was imported from the SUSE:SLE-12-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2017-1116=1

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-1116=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.3 (i586 x86_64):

dnsmasq-2.78-13.1
dnsmasq-debuginfo-2.78-13.1
dnsmasq-debugsource-2.78-13.1
dnsmasq-utils-2.78-13.1
dnsmasq-utils-debuginfo-2.78-13.1

- openSUSE Leap 42.2 (i586 x86_64):

dnsmasq-2.78-10.6.1
dnsmasq-debuginfo-2.78-10.6.1
dnsmasq-debugsource-2.78-10.6.1
dnsmasq-utils-2.78-10.6.1
dnsmasq-utils-debuginfo-2.78-10.6.1


References:

https://www.suse.com/security/cve/CVE-2017-14491.html
https://www.suse.com/security/cve/CVE-2017-14492.html
https://www.suse.com/security/cve/CVE-2017-14493.html
https://www.suse.com/security/cve/CVE-2017-14494.html
https://www.suse.com/security/cve/CVE-2017-14495.html
https://www.suse.com/security/cve/CVE-2017-14496.html
https://bugzilla.suse.com/1060354
https://bugzilla.suse.com/1060355
https://bugzilla.suse.com/1060360
https://bugzilla.suse.com/1060361
https://bugzilla.suse.com/1060362
https://bugzilla.suse.com/1060364

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung