Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in mozilla-nss und Mozilla Firefox
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in mozilla-nss und Mozilla Firefox
ID: SUSE-SU-2017:2872-2
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Software Development Kit 11-SP4, SUSE Linux Enterprise Server 11-SP4, SUSE Linux Enterprise Server 11-SP3-LTSS
Datum: Mo, 13. November 2017, 22:15
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7805
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7823
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7825
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7814
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7819
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7793
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7818
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7824
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7810

Originalnachricht

   SUSE Security Update: Security update for MozillaFirefox, mozilla-nss
______________________________________________________________________________

Announcement ID: SUSE-SU-2017:2872-2
Rating: important
References: #1060445 #1061005
Cross-References: CVE-2017-7793 CVE-2017-7805 CVE-2017-7810
CVE-2017-7814 CVE-2017-7818 CVE-2017-7819
CVE-2017-7823 CVE-2017-7824 CVE-2017-7825

Affected Products:
SUSE Linux Enterprise Software Development Kit 11-SP4
SUSE Linux Enterprise Server 11-SP4
SUSE Linux Enterprise Server 11-SP3-LTSS
______________________________________________________________________________

An update that fixes 9 vulnerabilities is now available.

Description:



This update for MozillaFirefox and mozilla-nss fixes the following issues:

Mozilla Firefox was updated to ESR 52.4 (bsc#1060445)

* MFSA 2017-22/CVE-2017-7825: OS X fonts render some Tibetan and Arabic
unicode characters as spaces
* MFSA 2017-22/CVE-2017-7805: Use-after-free in TLS 1.2 generating
handshake hashes
* MFSA 2017-22/CVE-2017-7819: Use-after-free while resizing images in
design mode
* MFSA 2017-22/CVE-2017-7818: Use-after-free during ARIA array manipulation
* MFSA 2017-22/CVE-2017-7793: Use-after-free with Fetch API
* MFSA 2017-22/CVE-2017-7824: Buffer overflow when drawing and validating
elements with ANGLE
* MFSA 2017-22/CVE-2017-7810: Memory safety bugs fixed in Firefox 56 and
Firefox ESR 52.4
* MFSA 2017-22/CVE-2017-7823: CSP sandbox directive did not create a
unique origin
* MFSA 2017-22/CVE-2017-7814: Blob and data URLs bypass phishing and
malware protection warnings

Mozilla Network Security Services (Mozilla NSS) received a security fix:

* MFSA 2017-22/CVE-2017-7805: Use-after-free in TLS 1.2 generating
handshake hashes (bsc#1061005, bsc#1060445)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11-SP4:

zypper in -t patch sdksp4-firefox-201710-13330=1

- SUSE Linux Enterprise Server 11-SP4:

zypper in -t patch slessp4-firefox-201710-13330=1

- SUSE Linux Enterprise Server 11-SP3-LTSS:

zypper in -t patch slessp3-firefox-201710-13330=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11-SP4 (x86_64):

MozillaFirefox-devel-52.4.0esr-72.13.2
mozilla-nss-devel-3.29.5-47.6.1

- SUSE Linux Enterprise Server 11-SP4 (s390x):

MozillaFirefox-52.4.0esr-72.13.2
MozillaFirefox-translations-52.4.0esr-72.13.2
libfreebl3-3.29.5-47.6.1
libfreebl3-32bit-3.29.5-47.6.1
libsoftokn3-3.29.5-47.6.1
libsoftokn3-32bit-3.29.5-47.6.1
mozilla-nss-3.29.5-47.6.1
mozilla-nss-32bit-3.29.5-47.6.1
mozilla-nss-tools-3.29.5-47.6.1

- SUSE Linux Enterprise Server 11-SP3-LTSS (x86_64):

MozillaFirefox-52.4.0esr-72.13.2
MozillaFirefox-translations-52.4.0esr-72.13.2
libfreebl3-3.29.5-47.6.1
libfreebl3-32bit-3.29.5-47.6.1
libsoftokn3-3.29.5-47.6.1
libsoftokn3-32bit-3.29.5-47.6.1
mozilla-nss-3.29.5-47.6.1
mozilla-nss-32bit-3.29.5-47.6.1
mozilla-nss-tools-3.29.5-47.6.1


References:

https://www.suse.com/security/cve/CVE-2017-7793.html
https://www.suse.com/security/cve/CVE-2017-7805.html
https://www.suse.com/security/cve/CVE-2017-7810.html
https://www.suse.com/security/cve/CVE-2017-7814.html
https://www.suse.com/security/cve/CVE-2017-7818.html
https://www.suse.com/security/cve/CVE-2017-7819.html
https://www.suse.com/security/cve/CVE-2017-7823.html
https://www.suse.com/security/cve/CVE-2017-7824.html
https://www.suse.com/security/cve/CVE-2017-7825.html
https://bugzilla.suse.com/1060445
https://bugzilla.suse.com/1061005

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Twitter
Neue Nachrichten
Werbung