Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in Ruby
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in Ruby
ID: USN-3515-1
Distribution: Ubuntu
Plattformen: Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 17.04, Ubuntu 17.10
Datum: Fr, 5. Januar 2018, 09:11
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-17405
Applikationen: Ruby

Originalnachricht


--===============3937085418720410843==
Content-Type: multipart/signed; micalg="pgp-sha256";
protocol="application/pgp-signature";
boundary="=-PFQq2tBsXXtonrmegQRH"


--=-PFQq2tBsXXtonrmegQRH
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: base64

==========================================================================
Ubuntu Security Notice USN-3515-1
January 04, 2018

ruby1.9.1, ruby2.0, ruby2.3 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 17.10
- Ubuntu 17.04
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

Ruby could be made to execute arbitrary commands if opened a specially
crafted file.

Software Description:
- ruby2.3: Interpreter of object-oriented scripting language Ruby
- ruby1.9.1: Object-oriented scripting language
- ruby2.0: Object-oriented scripting language

Details:

It was discovered that Ruby allows FTP command injection.
An attacker could use this to cause arbitrary command execution.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 17.10:
  libruby2.3                      2.3.3-1ubuntu1.1
  ruby2.3                         2.3.3-1ubuntu1.1

Ubuntu 17.04:
  libruby2.3                      2.3.3-1ubuntu0.3
  ruby2.3                         2.3.3-1ubuntu0.3

Ubuntu 16.04 LTS:
  libruby2.3                      2.3.1-2~16.04.4
  ruby2.3                         2.3.1-2~16.04.4

Ubuntu 14.04 LTS:
  libruby1.9.1                    1.9.3.484-2ubuntu1.6
  libruby2.0                      2.0.0.484-1ubuntu2.5
  ruby1.9.1                       1.9.3.484-2ubuntu1.6
  ruby1.9.3                       1.9.3.484-2ubuntu1.6
  ruby2.0                         2.0.0.484-1ubuntu2.5

In general, a standard system update will make all the necessary
changes.

References:
  https://www.ubuntu.com/usn/usn-3515-1
  CVE-2017-17405

Package Information:
  https://launchpad.net/ubuntu/+source/ruby2.3/2.3.3-1ubuntu1.1
  https://launchpad.net/ubuntu/+source/ruby2.3/2.3.3-1ubuntu0.3
  https://launchpad.net/ubuntu/+source/ruby2.3/2.3.1-2~16.04.4
  https://launchpad.net/ubuntu/+source/ruby1.9.1/1.9.3.484-2ubuntu1.6
  https://launchpad.net/ubuntu/+source/ruby2.0/2.0.0.484-1ubuntu2.5
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung