Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in PHP
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in PHP
ID: USN-3566-1
Distribution: Ubuntu
Plattformen: Ubuntu 14.04 LTS
Datum: Di, 13. Februar 2018, 07:40
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5712
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16642
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-12933

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--===============4955629689845922081==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="EvVqHu0RTXChSvBYW2YPcqATBtiVSFjJC"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--EvVqHu0RTXChSvBYW2YPcqATBtiVSFjJC
Content-Type: multipart/mixed;
boundary="wPiOE7WGDrfDln7DV5JveBlH8uFuhB1ja";
protected-headers="v1"
From: Marc Deslauriers <marc.deslauriers@canonical.com>
Reply-To: Ubuntu Security <security@ubuntu.com>
To: "ubuntu-security-announce@lists.ubuntu.com"
<ubuntu-security-announce@lists.ubuntu.com>
Message-ID: <aa89a0f2-5525-fe64-320c-421f777d7ce6@canonical.com>
Subject: [USN-3566-1] PHP vulnerabilities

--wPiOE7WGDrfDln7DV5JveBlH8uFuhB1ja
Content-Type: text/plain; charset=utf-8
Content-Language: en-C
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-3566-1
February 12, 2018

php5 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 14.04 LTS

Summary:

Several security issues were fixed in PHP.

Software Description:
- php5: HTML-embedded scripting language interpreter

Details:

It was discovered that PHP incorrectly handled the PHAR 404 error page. A
remote attacker could possibly use this issue to conduct cross-site
scripting (XSS) attacks. (CVE-2018-5712)

It was discovered that PHP incorrectly handled memory when unserializing
certain data. A remote attacker could use this issue to cause PHP to crash,
resulting in a denial of service, or possibly execute arbitrary code.
(CVE-2017-12933)

It was discovered that PHP incorrectly handled 'front of' and 'back
of'
date directives. A remote attacker could possibly use this issue to obtain
sensitive information. (CVE-2017-16642)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 14.04 LTS:
libapache2-mod-php5 5.5.9+dfsg-1ubuntu4.23
php5-cgi 5.5.9+dfsg-1ubuntu4.23
php5-cli 5.5.9+dfsg-1ubuntu4.23
php5-fpm 5.5.9+dfsg-1ubuntu4.23

In general, a standard system update will make all the necessary changes.

References:
https://www.ubuntu.com/usn/usn-3566-1
CVE-2017-12933, CVE-2017-16642, CVE-2018-5712

Package Information:
https://launchpad.net/ubuntu/+source/php5/5.5.9+dfsg-1ubuntu4.23



--wPiOE7WGDrfDln7DV5JveBlH8uFuhB1ja--

--EvVqHu0RTXChSvBYW2YPcqATBtiVSFjJC
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIcBAEBCgAGBQJagcHQAAoJEGVp2FWnRL6TZq4P/2Tv+eSr/8fsx2aicvxmM9I9
1XG5cwBd0XOsyTpcC9DYg5euvR5Kr3yjzSlf8WwBbEa/OHPdHr1+RHHBJz1nbFUk
1nGw4bXwyOdGx4bJQSq5bEiPNCOVeE4kwTUmMQwIAHzfAt9ETeqpEFucYc/2z6N5
TPQWHT6OKduHAbC5HVv3WR/fJNsuyFsWQaU4A6WAiWEDLiHqkkv+8+/Zz9DJg8Wq
2dNNQGrjFsZo/7n76mV3zDf1vhC9TrXEFDsE4cqmGp4krGPy2ozg+dlC+XH3MAGj
NLtxP4v9SiZYxhU82JQoNobBCxuITPk+6USl5qU5jkdrOWoz2vThyaMfkXxrxHXL
fKuBXouS7H65KMupkcsPBND5loIj1Q8NWRX39CYYlaRg9tIsmC78/FwwFtK0Iz+Y
vIcfOkwlXmaZuXR5hzVSG7xAx1k0QFYc1+9LpxSQjqyWTvGFDJYc0X3UfZbem+/e
vK+s6rO8FtHR2sOFp4HCznu6XgEilsfHLwbs9xQtl/mU/jLT4ko7xG3PlcMBddrb
0vPhj3JTw9hWlRyVG/nWV8kf4Kc8SvUxcwgP8ccdRXfREI2++Sw2ODy6W0rC7TW1
OQwtxDgYe16jmLJKyU7MWfLJsBIzPuLY/kV1hV7CAjt+BUviDNhXMCteVB3EwECq
QpwW0NEKLhJXPMFv32Yl
=ajAR
-----END PGP SIGNATURE-----

--EvVqHu0RTXChSvBYW2YPcqATBtiVSFjJC--


--===============4955629689845922081==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK

--===============4955629689845922081==--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung