Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in GNU C library
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in GNU C library
ID: SUSE-SU-2018:0565-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Software Development Kit 11-SP4, SUSE Linux Enterprise Server 11-SP4, SUSE Linux Enterprise Debuginfo 11-SP3, SUSE Linux Enterprise Debuginfo 11-SP4, SUSE Linux Enterprise Server 11-SP3-LTSS, SUSE Linux Enterprise Point of Sale 11-SP3
Datum: Do, 1. März 2018, 00:15
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-8804
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-6485
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1000001
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-6551
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-12132
Applikationen: GNU C library

Originalnachricht

   SUSE Security Update: Security update for glibc
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:0565-1
Rating: important
References: #1037930 #1051791 #1074293 #1079036 #978209

Cross-References: CVE-2017-12132 CVE-2017-8804 CVE-2018-1000001
CVE-2018-6485 CVE-2018-6551
Affected Products:
SUSE Linux Enterprise Software Development Kit 11-SP4
SUSE Linux Enterprise Server 11-SP4
SUSE Linux Enterprise Server 11-SP3-LTSS
SUSE Linux Enterprise Point of Sale 11-SP3
SUSE Linux Enterprise Debuginfo 11-SP4
SUSE Linux Enterprise Debuginfo 11-SP3
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:



This update for glibc fixes the following issues:

Security issues:

- CVE-2017-8804: Fix memory leak after deserialization failure in
xdr_bytes, xdr_string (bsc#1037930)
- CVE-2017-12132: Reduce EDNS payload size to 1200 bytes (bsc#1051791)
- CVE-2018-6485,CVE-2018-6551: Fix integer overflows in internal memalign
and malloc functions (bsc#1079036)
- CVE-2018-1000001: Avoid underflow of malloced area in realpath
(bsc#1074293)

Also a non security issue was fixed:

- Do not fail if one of the two responses to AF_UNSPEC fails (bsc#978209)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11-SP4:

zypper in -t patch sdksp4-glibc-13494=1

- SUSE Linux Enterprise Server 11-SP4:

zypper in -t patch slessp4-glibc-13494=1

- SUSE Linux Enterprise Server 11-SP3-LTSS:

zypper in -t patch slessp3-glibc-13494=1

- SUSE Linux Enterprise Point of Sale 11-SP3:

zypper in -t patch sleposp3-glibc-13494=1

- SUSE Linux Enterprise Debuginfo 11-SP4:

zypper in -t patch dbgsp4-glibc-13494=1

- SUSE Linux Enterprise Debuginfo 11-SP3:

zypper in -t patch dbgsp3-glibc-13494=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 x86_64):

glibc-html-2.11.3-17.110.6.2
glibc-info-2.11.3-17.110.6.2

- SUSE Linux Enterprise Server 11-SP4 (i586 i686 ia64 ppc64 s390x x86_64):

glibc-2.11.3-17.110.6.2
glibc-devel-2.11.3-17.110.6.2

- SUSE Linux Enterprise Server 11-SP4 (i586 ia64 ppc64 s390x x86_64):

glibc-html-2.11.3-17.110.6.2
glibc-i18ndata-2.11.3-17.110.6.2
glibc-info-2.11.3-17.110.6.2
glibc-locale-2.11.3-17.110.6.2
glibc-profile-2.11.3-17.110.6.2
nscd-2.11.3-17.110.6.2

- SUSE Linux Enterprise Server 11-SP4 (ppc64 s390x x86_64):

glibc-32bit-2.11.3-17.110.6.2
glibc-devel-32bit-2.11.3-17.110.6.2
glibc-locale-32bit-2.11.3-17.110.6.2
glibc-profile-32bit-2.11.3-17.110.6.2

- SUSE Linux Enterprise Server 11-SP4 (ia64):

glibc-locale-x86-2.11.3-17.110.6.2
glibc-profile-x86-2.11.3-17.110.6.2
glibc-x86-2.11.3-17.110.6.2

- SUSE Linux Enterprise Server 11-SP3-LTSS (i586 i686 s390x x86_64):

glibc-2.11.3-17.110.6.2
glibc-devel-2.11.3-17.110.6.2

- SUSE Linux Enterprise Server 11-SP3-LTSS (i586 s390x x86_64):

glibc-html-2.11.3-17.110.6.2
glibc-i18ndata-2.11.3-17.110.6.2
glibc-info-2.11.3-17.110.6.2
glibc-locale-2.11.3-17.110.6.2
glibc-profile-2.11.3-17.110.6.2
nscd-2.11.3-17.110.6.2

- SUSE Linux Enterprise Server 11-SP3-LTSS (s390x x86_64):

glibc-32bit-2.11.3-17.110.6.2
glibc-devel-32bit-2.11.3-17.110.6.2
glibc-locale-32bit-2.11.3-17.110.6.2
glibc-profile-32bit-2.11.3-17.110.6.2

- SUSE Linux Enterprise Point of Sale 11-SP3 (i586 i686):

glibc-2.11.3-17.110.6.2
glibc-devel-2.11.3-17.110.6.2

- SUSE Linux Enterprise Point of Sale 11-SP3 (i586):

glibc-html-2.11.3-17.110.6.2
glibc-i18ndata-2.11.3-17.110.6.2
glibc-info-2.11.3-17.110.6.2
glibc-locale-2.11.3-17.110.6.2
glibc-profile-2.11.3-17.110.6.2
nscd-2.11.3-17.110.6.2

- SUSE Linux Enterprise Debuginfo 11-SP4 (i586 i686 ia64 ppc64 s390x
x86_64):

glibc-debuginfo-2.11.3-17.110.6.2
glibc-debugsource-2.11.3-17.110.6.2

- SUSE Linux Enterprise Debuginfo 11-SP4 (ppc64 s390x x86_64):

glibc-debuginfo-32bit-2.11.3-17.110.6.2

- SUSE Linux Enterprise Debuginfo 11-SP4 (ia64):

glibc-debuginfo-x86-2.11.3-17.110.6.2

- SUSE Linux Enterprise Debuginfo 11-SP3 (i586 i686 s390x x86_64):

glibc-debuginfo-2.11.3-17.110.6.2
glibc-debugsource-2.11.3-17.110.6.2

- SUSE Linux Enterprise Debuginfo 11-SP3 (s390x x86_64):

glibc-debuginfo-32bit-2.11.3-17.110.6.2


References:

https://www.suse.com/security/cve/CVE-2017-12132.html
https://www.suse.com/security/cve/CVE-2017-8804.html
https://www.suse.com/security/cve/CVE-2018-1000001.html
https://www.suse.com/security/cve/CVE-2018-6485.html
https://www.suse.com/security/cve/CVE-2018-6551.html
https://bugzilla.suse.com/1037930
https://bugzilla.suse.com/1051791
https://bugzilla.suse.com/1074293
https://bugzilla.suse.com/1079036
https://bugzilla.suse.com/978209

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung