Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in patch
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in patch
ID: USN-3624-1
Distribution: Ubuntu
Plattformen: Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 17.10
Datum: Di, 10. April 2018, 22:32
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-10713
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-6951
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1000156
Applikationen: patch

Originalnachricht


--===============8808504695503281786==
Content-Type: multipart/signed; micalg="pgp-sha256";
protocol="application/pgp-signature";
boundary="=-OwNzEFRAjnCF8uQ5bMYa"


--=-OwNzEFRAjnCF8uQ5bMYa
Content-Type: text/plain; charset="UTF-8
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-3624-1
April 10, 2018

patch vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 17.10
- Ubuntu 16.04 LTS
- Ubuntu 14.04 LTS

Summary:

Several security issues were fixed in Patch.

Software Description:
- patch: Apply a diff file to an original

Details:

It was discovered that Patch incorrectly handled certain files. An
attacker could possibly use this to cause a denial of service.
(CVE-2016-10713)

It was discovered that Patch incorrectly handled certain input
validation. An attacker could possibly use this to execute arbitrary
code. (CVE-2018-1000156)

It was discovered that Patch incorrectly handled certain inputs. An
attacker could possibly use this to cause a denial of service.
(CVE-2018-6951)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 17.10:
patch 2.7.5-1ubuntu0.2

Ubuntu 16.04 LTS:
patch 2.7.5-1ubuntu0.16.04.1

Ubuntu 14.04 LTS:
patch 2.7.1-4ubuntu2.4

In general, a standard system update will make all the necessary
changes.

References:
https://usn.ubuntu.com/usn/usn-3624-1
CVE-2016-10713, CVE-2018-1000156, CVE-2018-6951

Package Information:
https://launchpad.net/ubuntu/+source/patch/2.7.5-1ubuntu0.2
https://launchpad.net/ubuntu/+source/patch/2.7.5-1ubuntu0.16.04.1
https://launchpad.net/ubuntu/+source/patch/2.7.1-4ubuntu2.4
--=-OwNzEFRAjnCF8uQ5bMYa
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAABCAAGBQJazP3CAAoJEEW851uECx9phyAQAJVZpmjImOB4r1bVTD/X5XqY
sUFsCW7QFpdySwWBTp07lj2Z++/Cb9mYhwt7xCTDTDtXcVynzWBLp+wSEw3OMCgV
/zi43jqd4ARoyePNLLPuSI8DLvrqARqEhVxAcqNChRVCRE6BRmFx/M7mDicJ1zrI
b2kcpAV7EoOMSQg61r/eCSHEwKiqK441qHVZRTHmujSqIQjkN8p6BZ/HJEQPMFz4
vQqIj84DoTt9mPRfTultMVukXogwkIZzCmHGiWFAZWNf8otN28mdSP9FwsBKk7ek
M1oZlJG7G48SQ7zMkd7FliurAEKh1OyaBuDDteK2h3AEnsEnkaOkhy9P+feg8CPv
5MGm1ZDBtpYNkqM5a4AreG2R/DED8sUJcUxTMTJZqMvOVACxMX5KQo5yNHB6meW0
4z66q23wqihXWrXsjbzyPGgD5sw70qmf06hEzACUW/13O5l3ipBAJAVB5YfwzcVw
ozb9/cqiakTEEQ1OoN3HM4lf4wPLZnizEadt+hGX/ZsrN05m2jGxdEUImhDdXbch
S3M7B+SyVW+kQU1lwk6WCKjNfDT3TrC4eVUarj8kVl317PVgGz4qhKRbQZ2k+j9g
HRnjQKGpFGEd2ope2keveC5JzW1eS4SA8htoZ6/ILtQyh/M20qNxRFjzUPrLYInv
4ZsV7SxvLIdou89UUXaz
=ddUR
-----END PGP SIGNATURE-----

--=-OwNzEFRAjnCF8uQ5bMYa--



--===============8808504695503281786==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK

--===============8808504695503281786==--
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung