Login


 
Newsletter
Werbung
Sicherheit: Mehrere Probleme in clamav
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in clamav
ID: DTSA-21-1
Distribution: Debian Testing
Plattformen: Debian testing
Datum: Sa, 5. November 2005, 17:00
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3239
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3303
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3500
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3501

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Testing Security Advisory DTSA-21-1 November 3rd, 2005
secure-testing-team@lists.alioth.debian.org Micah Anderson
http://secure-testing-master.debian.net/
- --------------------------------------------------------------------------

Package : clamav
Vulnerability : Denial of service vulnerabilities and buffer overflow
Problem-Scope : remote
Debian-specific: No
CVE ID : CVE-2005-3239 CVE-2005-3500 CVE-2005-3501 CVE-2005-3303


Multiple security holes were found in clamav:

CVE-2005-3239

The OLE2 unpacker allows remote attackers to cause a denial of service
by sending a DOC file with an invalid property tree, triggering
an infinite recursion.

CVE-2005-3500

The tnef_attachment function in Clam AntiVirus before 0.87.1
allows remote attackers to cause a denial of service, through
an infinate loop and memory exhaustion, by crafting a CAB file
with a value that causes ClamAV to repeatedly scan the same block

CVE-2005-3501

The cabd_find function in of the libmspack library in Clam AntiVirus
before 0.87.1 allows remote attackers to cause a denial of service
via a crafted CAB file that causes cabd_find to be called with a zero
length.

CVE-2005-3303

The FSB unpacker in Clam AntiVirus 0.80 through 0.87 allows
remote attackers to cause memory corruption and execute arbitrary
code via a crafted FSG 1.33 file.

For the testing distribution (etch) this is fixed in version
0.87.1-0etch.1

For the unstable distribution (sid) this is fixed in version
0.87.1

This upgrade is recommended if you use clamav.

The Debian testing security team does not track security issues for the
stable (sarge) and oldstable (woody) distributions. If stable is vulnerable,
the Debian security team will make an announcement once a fix is ready.

Upgrade Instructions
- --------------------

To use the Debian testing security archive, add the following lines to
your /etc/apt/sources.list:

deb http://secure-testing.debian.net/debian-secure-testingetch/security-updates main contrib non-free
deb-src http://secure-testing.debian.net/debian-secure-testingetch/security-updates main contrib non-free

The archive signing key can be downloaded from
http://secure-testing-master.debian.net/ziyi-2005-7.asc

To install the update, run this command as root:

apt-get update && apt-get upgrade

For further information about the Debian testing security team, please refer
to http://secure-testing-master.debian.net/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDbNN79n4qXRzy1ioRArOWAKCHfT0RX/+fACeFtDPUW8TuE5GO6QCdF/UB
P7cA6zjHoRJcNNmp4Mt63FM=
=Th/z
-----END PGP SIGNATURE-----

_______________________________________________
secure-testing-announce mailing list
secure-testing-announce@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/secure-testing-announce
Pro-Linux
Frohe Weihnachten Fest!
Neue Nachrichten
Werbung