Login
Newsletter
Werbung

Sicherheit: Fehlende Rückgabewertprüfung in mremap im Kernel (2.2.22, Alpha)
Aktuelle Meldungen Distributionen
Name: Fehlende Rückgabewertprüfung in mremap im Kernel (2.2.22, Alpha)
ID: DSA-454-1
Distribution: Debian
Plattformen: Debian woody
Datum: Mi, 3. März 2004, 12:00
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0077
Applikationen: Linux, Linux

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

--------------------------------------------------------------------------
Debian Security Advisory DSA 454-1 security@debian.org
http://www.debian.org/security/ Martin Schulze
March 2nd, 2004 http://www.debian.org/security/faq
--------------------------------------------------------------------------

Package : kernel-source-2.2.22, kernel-image-2.2.22-alpha
Vulnerability : failing function and TLB flush
Problem-Type : local
Debian-specific: no
CVE ID : CAN-2004-0077

Paul Starzetz and Wojciech Purczynski of isec.pl discovered a critical
security vulnerability in the memory management code of Linux inside
the mremap(2) system call. Due to flushing the TLB (Translation
Lookaside Buffer, an address cache) too early it is possible for an
attacker to trigger a local root exploit.

The attack vectors for 2.4.x and 2.2.x kernels are exclusive for the
respective kernel series, though. We formerly believed that the
exploitable vulnerability in 2.4.x does not exist in 2.2.x which is
still true. However, it turned out that a second (sort of)
vulnerability is indeed exploitable in 2.2.x, but not in 2.4.x, with a
different exploit, of course.

For the stable distribution (woody) this problem has been fixed in
the following versions and architectures:

kernel-source-2.2.22 source 2.2.22-1woody1
kernel-image-2.2.22-alpha alpha 2.2.22-2

For the unstable distribution (sid) this problem will be fixed soon
for the architectures that still ship a 2.2.x kernel package.

We recommend that you upgrade your Linux kernel package.


Upgrade Instructions
--------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
--------------------------------

Source archives:

kernel-source-2.2.22_2.2.22-1woody1.dsc
Size/MD5 checksum: 661 2f5744d0e7d68932d8910d15583ed820
kernel-source-2.2.22_2.2.22-1woody1.diff.gz
Size/MD5 checksum: 146548 51478245f5608894bbb59223172f9cb3
kernel-source-2.2.22_2.2.22.orig.tar.gz
Size/MD5 checksum: 19313552 af9832dc10026cf03b2682f296ccd051

kernel-image-2.2.22-alpha_2.2.22-2.dsc
Size/MD5 checksum: 870 ac538b47a782ae11686e2c5d0c3bb6f5
kernel-image-2.2.22-alpha_2.2.22-2.tar.gz
Size/MD5 checksum: 7451 6107bb5e1e7ae0aa4e3f9417fced0717

Architecture independent components:

kernel-doc-2.2.22_2.2.22-1woody1_all.deb
Size/MD5 checksum: 1162368 805cf7d09f69b14ebcb392038de5a6b1
kernel-source-2.2.22_2.2.22-1woody1_all.deb
Size/MD5 checksum: 15759754 55d31894b93cb9633caaa6a0eddbf998

Alpha architecture:

kernel-headers-2.2.22_2.2.22-2_alpha.deb
Size/MD5 checksum: 1871248 c762109e412ef7d3e31bebb868e668ce
kernel-image-2.2.22-generic_2.2.22-2_alpha.deb
Size/MD5 checksum: 2782898 99c876bdab97812cb5ebdfdb1c88d224
kernel-image-2.2.22-jensen_2.2.22-2_alpha.deb
Size/MD5 checksum: 2299174 ac17d87dbb6558c83b723fb97808f721
kernel-image-2.2.22-nautilus_2.2.22-2_alpha.deb
Size/MD5 checksum: 2537032 9a3194224faccec6081ee06d9926be09
kernel-image-2.2.22-smp_2.2.22-2_alpha.deb
Size/MD5 checksum: 2878172 6ad070e82c301504d845692688012fed


These files will probably be moved into the stable distribution on
its next revision.

--------------------------------------------------------------------------------
-
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-securitydists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFARK13W5ql+IAeqTIRAgi4AKCLii5C1bB8vjmDhmcKV5MfO8AWxQCeKDLT
KdtPIHHXS/jG4oSJLCsdBV0=
=lBkU
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-security-announce-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung