Login
Newsletter
Werbung

Sicherheit: Denial of Service in cxf
Aktuelle Meldungen Distributionen
Name: Denial of Service in cxf
ID: FEDORA-2013-14159
Distribution: Fedora
Plattformen: Fedora 18
Datum: So, 11. August 2013, 10:33
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-2160
Applikationen: cxf

Originalnachricht

Name        : cxf
Product : Fedora 18
Version : 2.6.9
Release : 1.fc18
URL : http://cxf.apache.org/
Summary : Apache CXF
Description :
Apache CXF is an open-source services framework that aids in
the development of services using front-end programming APIs,
like JAX-WS and JAX-RS.

-------------------------------------------------------------------------------
-
Update Information:

Upgrade of CXF to 2.6.9, fixes CVE-2013-2160.
-------------------------------------------------------------------------------
-
ChangeLog:

* Thu Aug 1 2013 Marek Goldmann <mgoldman@redhat.com> - 1:2.6.9-1
- Upstream release 2.6.9
* Mon Mar 4 2013 Marek Goldmann <mgoldman@redhat.com> - 1:2.6.6-1
- Upstream release 2.6.6, RHBZ#909247
* Wed Feb 13 2013 Fedora Release Engineering
<rel-eng@lists.fedoraproject.org> - 1:2.6.3-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Wed Feb 6 2013 Java SIG <java-devel@lists.fedoraproject.org> -
1:2.6.3-5
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
- Replace maven BuildRequires with maven-local
* Wed Dec 12 2012 Marek Goldmann <mgoldman@redhat.com> - 1:2.6.3-4
- Prefer the servlet 3.0 API over anything else
* Tue Dec 11 2012 Marek Goldmann <mgoldman@redhat.com> - 1:2.6.3-3
- Added proper requires with epoch
* Mon Dec 10 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> -
1:2.6.3-2
- Added epoch after downgrade
* Tue Nov 13 2012 Marek Goldmann <mgoldman@redhat.com> - 2.6.3-1
- Upstream release 2.6.3
* Tue Nov 13 2012 Marek Goldmann <mgoldman@redhat.com> - 2.4.9-3
- Replaced patches with pom macros
- Enbled modules: rt/security, javascript
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #929197 - CVE-2013-2160 cxf, jbossws-cxf, apache-cxf: Multiple
denial of service flaws in the StAX parser
https://bugzilla.redhat.com/show_bug.cgi?id=929197
-------------------------------------------------------------------------------
-

This update can be installed with the "yum" update program. Use
su -c 'yum update cxf' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list
package-announce@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/package-announce
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung