Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in libksba
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in libksba
ID: DSA-3078-1
Distribution: Debian
Plattformen: Debian sid, Debian wheezy
Datum: Do, 27. November 2014, 18:24
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9087
Applikationen: The GNU Privacy Guard

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-3078-1 security@debian.org
http://www.debian.org/security/ Salvatore Bonaccorso
November 27, 2014 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : libksba
CVE ID : CVE-2014-9087
Debian Bug : 770972

An integer underflow flaw, leading to a heap-based buffer overflow, was
found in the ksba_oid_to_str() function of libksba, an X.509 and CMS
(PKCS#7) library. By using special crafted S/MIME messages or ECC based
OpenPGP data, it is possible to create a buffer overflow, which could
cause an application using libksba to crash (denial of service), or
potentially, execute arbitrary code.

For the stable distribution (wheezy), this problem has been fixed in
version 1.2.0-2+deb7u1.

For the upcoming stable distribution (jessie), this problem has been
fixed in version 1.3.2-1.

For the unstable distribution (sid), this problem has been fixed in
version 1.3.2-1.

We recommend that you upgrade your libksba packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJUd1cWAAoJEAVMuPMTQ89E0DgP+wZuiRwFrvDTIhXixr36iq2g
k7oVYfh4Cdsqthar98IJAf+JaZGRRwm35z0KnnW11op/bnD4kh7OjI/7o9Pj9e12
agEjapLRmtq//pZn8Ps8xWWNBJL/GPhC0nSws2HkuDdomR0L6nuogrBiYfkoZ1W/
XFCOSAe2mzg3b9dKcBZrgZKIH0G1Yip6ZioIPj+dcIGXT9iyohQqp66XDGQ9RDg/
clZbMmKDyR+f/LecZTBTWBCc1z51c2TGLHz4sz3mYqyFurXsFBupRuu8un4t1UNE
DAWH6yNdC05T4rMlnmT0NAXoZk+gzJhSZflKRS3s+3qSQtXe6cN/387V05174Ivb
XJMDbLaBqV3KI+X/bVBFfH/o0AUCPVo6KT5srwy/JqZzjfbkdZJxwbp7oZIliiZj
UPIUNRCZffxFiKQ9IK5YxCS6E/apWCTAblMw2OHccNXvNa6tTaPUIBHEhJogkFtP
sVDoWe7WmdhL8jR6yH1MjTLsnCNeLFE+yZ03GJA8C/1yA42eFwjaayfwJcVH1mNX
L5HXw01DnWOfXfSSr4ADdS37+Rl+w8ppTughuIn3vEEU6/Yox22uljcyVvqdY2C5
4lm3j+Of2OzT6Gc+uPd/NIPiQd4KzyZ8S/33chizIeimOOg2Ir+M13XD7Ai2Nc6K
eF7t3vsbKfFEvSCgNgLs
=M8ZO
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-security-announce-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Archive: https://lists.debian.org/E1Xu2M1-0005fI-3j@master.debian.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung