Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 19. Dez 2018 14:16

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 14 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: kernel-2.4.5 & module
BeitragVerfasst: 19. Jun 2001 13:22 
Offline

Registriert: 16. Aug 1999 13:06
Beiträge: 165
beim booten 2.4.5er Kernels wird eth0 nicht geladen.
ich bekomme immer die nachricht , dass das modul nicht gefunden wird.
nun ist meine karte aber nicht ls modul, sondern fest eingebunden!!!
die modutils habe ich auf 2.4.6 upgedatet, iptables hat auch einen update erfahren ---> 1.2.2 incl. security_patch.
Was fehlt noch?
hier ein auszug aus der /var/log/boot.msg
#
Running /etc/init.d/boot.local
insmod: /lib/modules/2.4.5/kernel/net/ipv4/netfilter/iptable_nat.o: insmod iptable_nat failed
modprobe: Can't locate module ip_tables
insmod: /lib/modules/2.4.5/kernel/net/ipv4/netfilter/iptable_nat.o: insmod iptable_nat failed
iptables v1.2.2: can't initialize iptables table `nat': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
modprobe: Can't locate module ide-scsi
(...)
Initialization of HiSax failed!
Check /var/log/messages and /var/log/warn.
Check that the values in '/etc/rc.config.d/*' are correct:
I4L_TYPE: 27
I4L_MEMBASE: 0
I4L_IRQ: 5
I4L_IO: 0
I4L_IO0: 0
I4L_IO1: 0
I4L_PROTOCOL: 2
I4L_MODUL_OPTIONS:
(...)
Setting up network device eth0
modprobe: modprobe: Can't locate module eth0
SIOCSIFADDR: No such device
modprobe: modprobe: Can't locate module eth0
eth0: unknown interface: No such device
modprobe: modprobe: Can't locate module eth0
SIOCSIFBRDADDR: No such device
modprobe: modprobe: Can't locate module eth0
eth0: unknown interface: No such device
modprobe: modprobe: Can't locate module eth0
SIOCSIFNETMASK: No such device
modprobe: modprobe: Can't locate module eth0
eth0: unknown interface: No such device
(...)
Master Resource Control: runlevel 5 has been reached
Failed services in runlevel 5: i4l_hardware network
#
Es scheint ein problem mit den modulen zu geben.
das mit hisax verstehe ich überhaupt nicht, den ich bin ja im netz und das ide laufwerk wird auch als scsi angenommen (es funzt).
weiss jemand rat?
gruss,
hendrik


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 19. Jun 2001 16:12 
Was steht denn in deiner /etc/modules.conf in der Zeile mit eth0 ? Gib uns einfach die Ausgabe von
cat /etc/modules.conf | eth0
bei mir kommt z.B. :
alias eth0 8139too
dann hätte ich noch gerne, dass du nach dem letzten Wort der Ausgabe des obigen Befehls suchst, also im Beispiel
locate 8139too
Bei mir liefert dies
/lib/modules/2.4.4-4GB/kernel/drivers/net/8139too.o
/lib/modules/2.4.4/kernel/drivers/net/8139too.o
/usr/src/linux-2.4.4/Documentation/networking/8139too.txt
/usr/src/linux-2.4.4/drivers/net/.8139too.o.flags
/usr/src/linux-2.4.4/drivers/net/8139too.c
/usr/src/linux-2.4.4/drivers/net/8139too.o
/usr/src/linux-2.4.4/include/config/8139too
/usr/src/linux-2.4.4/include/config/8139too.h
/usr/src/linux-2.4.4/include/config/8139too/8129.h
/usr/src/linux-2.4.4/include/config/8139too/module.h
/usr/src/linux-2.4.4/include/config/8139too/pio.h
/usr/src/linux-2.4.4/include/config/8139too/tune
/usr/src/linux-2.4.4/include/config/8139too/tune/twister.h

so, dann poste mal bitte die Infos

cu


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 19. Jun 2001 16:42 
Offline

Registriert: 16. Aug 1999 13:06
Beiträge: 165
hier das gewünschte,
#
venus:~ # cat /etc/modules.conf | grep eth0
alias eth0 ne2k-pci
#
venus:~ # locate ne2k-pci
/usr/local/lgp-2.4.0a/image/drivers/net/ne2k-pci.c.ne2k_pci_block_input.+INDIRECT+
/usr/local/lgp-2.4.0a/image/drivers/net/ne2k-pci.c.ne2k_pci_block_output.+INDIRECT+
/usr/local/lgp-2.4.0a/image/drivers/net/ne2k-pci.c.ne2k_pci_close.+INDIRECT+
/usr/local/lgp-2.4.0a/image/drivers/net/ne2k-pci.c.ne2k_pci_get_8390_hdr.+INDIRECT+
/usr/local/lgp-2.4.0a/image/drivers/net/ne2k-pci.c.ne2k_pci_init_one.+INDIRECT+
/usr/local/lgp-2.4.0a/image/drivers/net/ne2k-pci.c.ne2k_pci_open.+INDIRECT+
/usr/local/lgp-2.4.0a/image/drivers/net/ne2k-pci.c.ne2k_pci_remove_one.+INDIRECT+
/usr/local/lgp-2.4.0a/image/drivers/net/ne2k-pci.c.ne2k_pci_reset_8390.+INDIRECT+
/usr/sbin/ne2k-pci-diag
/usr/src/linux-2.2.18.SuSE/drivers/net/.ne2k-pci.o.flags
/usr/src/linux-2.2.18.SuSE/drivers/net/ne2k-pci.c
/usr/src/linux-2.2.18.SuSE/drivers/net/ne2k-pci.o
/usr/src/linux-2.2.18/drivers/net/.ne2k-pci.o.flags
/usr/src/linux-2.2.18/drivers/net/ne2k-pci.c
/usr/src/linux-2.2.18/drivers/net/ne2k-pci.o
/usr/src/linux-2.4.0.SuSE/drivers/net/ne2k-pci.c
/usr/src/linux/drivers/net/.ne2k-pci.o.flags
/usr/src/linux/drivers/net/ne2k-pci.c
/usr/src/linux/drivers/net/ne2k-pci.o
#
wobei /usr/src/linux auf den 2.4.5er verweist
gruss,
hendrik


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 19. Jun 2001 16:50 
Bitte noch die Ausgabe von
cat /usr/src/linux/.config | grep NE2K
du solltest folgendes kriegen:
CONFIG_NE2K_PCI=y

Wenn dass so ist, solltest du vielleicht das eth0 aus deiner modules.conf schmeißen, denn es ist ja schon im Kernel ! Also wird er selbstverständlich scheitern es einzubinden. Allerdings weiß ich nicht, wie dies "sauberste" Methode aussieht das ganze zu machen, probieren kannst es ja mal, eth0 auf off setzen in der modules.conf, dann noch ein depmod -a. Neustart. Was ich allerding empfehlen würde, ist das kompilieren der Netzwerkkartentreiber als Modul. Die Faustregel heist: "Alles was man nicht unbedingt zum booten des Systems braucht gehört modularisiert !"

cu


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 19. Jun 2001 16:52 
Ach ja, ich vergass vieleicht zu erwähnen, dass du mal deine boot.local untersuchen solltest. Versuchst du dort etwa mittels insmod eth0 die module zu laden ? Das geht jetzt nichtmehr, wenn du das Teil fest drin im Kernel hast.


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 19. Jun 2001 17:14 
Offline

Registriert: 16. Aug 1999 13:06
Beiträge: 165
mal sehen was da kommt,
#
venus:~ # cat /usr/src/linux/.config | grep NE2K
CONFIG_NE2K_PCI=y
#
venus:~ # cat /etc/init.d/boot.local
#! /bin/sh
#
# Copyright (c) 1996 SuSE GmbH Nuernberg, Germany. All rights reserved.
#
# Author: Werner Fink <werner@suse.de>, 1996
# Burchard Steinbild <bs@suse.de>, 1996
#
# /etc/init.d/boot.local
#
# script with local commands to be executed from init on system startup
#
. /etc/rc.config
#
# Here you should add things, that should happen directly after booting
# before we're going to the first run level.
#
########################################################################
# starten von iptables & routing, so dass mit entsprechend #
# freigebenen rechner ins www gegangen werden kann #
# die ip-adresse ist auschlag gebend #
########################################################################
#

if test `uname -r` = "2.4.2";
then
cd /usr/local/iptables-1.2.1a && echo 1 > /proc/sys/net/ipv4/ip_forward && ./iptables -A POSTROUTING -t nat -s 192.168.1.2 -j MASQUERADE
#
else
cd /usr/local/iptables-1.2.2 && echo 1 > /proc/sys/net/ipv4/ip_forward && ./iptables -A POSTROUTING -t nat -s 192.168.1.2 -j MASQUERADE
fi
#
########################################################################
# aktivierung der deutschen sprachunterstützung bei programmen #
# die einen extra aufruf dieser verlangen ein versuch #
########################################################################
#
export LANG=de
#
#######################################################################
# scsi emulation starten #
#######################################################################
#
/sbin/modprobe ide-scsi
#
# ende eintraege
#
in der boot.local ist eth0 nicht eingetragen.
die netzkarte und alles was damit zu tun hat ist wie in allen kerneln zuvor fest eingebunden.
gruss


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 19. Jun 2001 18:47 
Dann trag einfach wie von Peter schon vorgeschlagen

alias eth0 off

in deine conf.modules / modules.conf ein.


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 20. Jun 2001 8:17 
Offline

Registriert: 16. Aug 1999 13:06
Beiträge: 165
alles schon gemacht, auch alle persönlichen einträge in der boot.local auskomentiert, hat zu keiner veränderung geführt.
Werde jetzt mal den anderen weg versuchen.


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 20. Jun 2001 14:38 
Offline

Registriert: 16. Aug 1999 13:06
Beiträge: 165
also,
anscheinend liegen beim 2.4.5er grundsätzliche probleme mit den modulen vor.
meine frage:
wo kann ich mir die module für den kernel besorgen oder sind diese im kernel mit drinne?
habe alles noch einmal überprüft, das system ist up to date.
noch ne frage:
wie putze ich den kernel von der platte, auch iptabels 1.2.2, einfach löschen?
ich möchte die installation von vorn beginnen.
ach ja hier die ausgabe von depmod -a
#
depmod: *** Unresolved symbols in /lib/modules/2.4.5/kernel/net/ipv4/netfilter/ip_nat_ftp.o
depmod: *** Unresolved symbols in /lib/modules/2.4.5/kernel/net/ipv4/netfilter/iptable_nat.o
#
vieleicht hilft das ja weiter.
eth0 will immer noch nicht<img src="http://www.pl-forum.de/UltraBoard/Images/Sad.gif" border="0" align="middle"> hisax wird erkannt aber das sys versucht es immer wieder als modul einzubinden obwohl fest eingebunden, läuft aber, selsam!?
ich habe so das gefühl als ob der kernel nicht weiss wann er nach modulen suchen soll und wann nicht, da ist irgend etwas schief gelaufen.
ciao,
hendrik


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 22. Jun 2001 15:32 
sind deine modutils in einer aktuellen version vorhanden ?


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 22. Jun 2001 19:16 
ich hoffe doch du hast auch
nach dem kernel kompilieren
make modules
make modules_install
ausgeführt ???
System.map kopiert ??
cp /usr/src/linux/System.map /boot

lilo ausgeführt ??
-bernd


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 22. Jun 2001 21:04 
Offline

Registriert: 16. Aug 1999 13:06
Beiträge: 165
logisch,
make dep clean bzImage modules modules_install bzlilo
#
venus:~ # insmod -V
insmod version 2.4.6
#
iptables version 1.2.2 usw.............
das sys ist up todate.
Das Ding ist doch das eth0 fest (statisch) in den kernel eingebunden ist, ansage modul nicht gefunden, läuft nicht.
hisax ebenfalls, dort bekomme ich die meldung modul nicht gefunden, läuft aber,
ebenso bei der scsi emulation, fest im kernel, ansage modul nicht gefunden, läuft ebenfalls.
irgendwie habe ich das gefühl das der osterhase da etwas zu gut versteckt hat.........
was kann ich machen ausser von vorn anfangen?
ist schon blöd, im laufenden kernel 2.4.2 funzt iptables 1.2.2 nicht, er müsste ein update erfahren, oder ich muss das prog wieder auf 1.2.1a, wie sagt man so schön, downgraden, nur wie geht den dieses nun schon wieder?
ein schönen abend und ein noch sonnigeres wochenende,
Hendrik


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 22. Jun 2001 21:51 
da fällt mir gerade mal ein :
das feste einbinden iss ja ganz schön und gut und auch das laden mit insmod , nur dann musst du auch die entsprechenden parameter dem zu ladenden modul mitteilen,
besser iss das mit modprobe denn der suchst siche seine parameter in der regel selbst.
das heisst also wenn du diverse module in den kernel einkompileeierst dann lädt er das modul mit den STANDART-Einstellungen aber vielleicht benötigst du ja andere .
deshalb iss es doch gerade bei ner netzwerkarte sowie beim ide-scsi besser das ding per modul zu kompilieren und dann per modprobe zu laden und dann erst in die modules.conf einbinden ..

und deine ganzen ansagen modul nicht gefunden bla bla bla kommen wohl daher das du deine modules.conf nicht abgeändert hast und jetzt versucht wird diverse module zu laden die du in den kernel fest einkompiliert hast !!

-bernd


Nach oben
   
 Betreff des Beitrags: Re: kernel-2.4.5 & module
BeitragVerfasst: 22. Jun 2001 21:53 
da fällt mir gerade mal ein :
das feste einbinden iss ja ganz schön und gut und auch das laden mit insmod , nur dann musst du auch die entsprechenden parameter dem zu ladenden modul mitteilen,
besser iss das mit modprobe denn der suchst siche seine parameter in der regel selbst.
das heisst also wenn du diverse module in den kernel einkompileeierst dann lädt er das modul mit den STANDART-Einstellungen aber vielleicht benötigst du ja andere .
deshalb iss es doch gerade bei ner netzwerkarte sowie beim ide-scsi besser das ding per modul zu kompilieren und dann per modprobe zu laden und dann erst in die modules.conf einbinden ..

und deine ganzen ansagen modul nicht gefunden bla bla bla kommen wohl daher das du deine modules.conf nicht abgeändert hast und jetzt versucht wird diverse module zu laden die du in den kernel fest einkompiliert hast !!

-bernd


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 14 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de