Ubuntu 11.10 Bootprobleme nach Neu-Installation

Antworten
Nachricht
Autor
Entropy
Beiträge: 2
Registriert: 17. Jun 2012 15:37

Ubuntu 11.10 Bootprobleme nach Neu-Installation

#1 Beitrag von Entropy » 17. Jun 2012 16:55

Hallo Leute,

ich habe ein kleines Problem bekommen während meiner Re-Installation von Ubuntu. Ich hoffe, einer von Euch kann mir weiterhelfen bzw. das Problem einzugrenzen.
Vor zwei Monaten habe ich Ubuntu 11.10 über das Netzwerk auf meinem Toshiba Convertible Notebook ohne DVD-Laufwerk via Netzwerk – dank Tftpd32! – installiert. Damals hat alles bestens geklappt. Dieses Wochenende wollte ich, nach einem kleinen Unfall, Ubuntu wieder neu re-installieren. Die Neu-Installation von Ubuntu auf meinem Rechner hat zumindest zu einem gewissen Punkt funktioniert. Beim Neustart des Rechners nach der Installation, bleibt der Rechner im Bootvorgang bei „* Starting MySQL Server“ stehen und bootet nicht weiter!

Hier das Bootprotokoll des Rechners:

Code: Alles auswählen

Fsck from util-linux 2.19.1
/dev/sda1: sauber, 50941/3564736 Dateien, 530162/14258176 Blöcke	
* Starting Mount network filesystems                                                          [OK]
* Stopping Mount network filesystems                                                          [OK]
* Stopping Failsafe Boot Delay                                                                [OK]
* Starting System V initialisation combatibility                                              [OK]
* Starting configure network device                                                           [OK]
* Stopping System V initialisation combatibility                                              [OK]
* Starting System V runlevel combatibility                                                    [OK]
* Starting LightDM Display Manager                                                            [OK]
* Starting save kernel messages                                                               [OK]
* Starting NTP server ntpd                                                                    [OK]
* Starting regular background program processing daemon                                       [OK]
* Stopping save kernel messages                                                               [OK]
* Stopping System V runlevel combatibility                                                    [OK]
* Starting MySQL Server                                                                        _
Hinweis: Ich habe den Grub Bootmanager installiert. Ich habe es spaßeshalber auch mit dem Lilo Bootmanager probiert und auch keinen Erfolg gehabt.

Zur Sicherheit habe ich die frisch installierte Festplatte ausgebaut und mit meinem anderen PC verbunden, um mal nachzuschauen. Auf die schnelle sieht es so aus, als wären alle notwendigen Ordner für Ubuntu auf der Festplatte installiert worden.

Einen Verdacht habe ich zumindest, was die Fehlerquelle sein könnte. Bei der Installation holt sich das Installationsprogramm einen großen Teil von zu installierenden Softwarepaketen aus dem Internet. Möglicherweise gab es mittlerweile Updates für einige Softwarepakete, die jetzt die Probleme bereiten.

Eine Neu-Installation mit Ubuntu 12.04 über das Netzwerk habe ich auch mal ausprobiert. Dort hat sich das Installationsprogramm direkt am Anfang nach der Eingabe „Install“ aufgehängt. Ob ein generelles Problem vorliegt oder ein Fehler von mir gab, habe ich nicht weiter geprüft. Zurzeit Versuche ich es weiter mit der Version 11.10.

Für einen Tipp wäre ich sehr dankbar.

VG


Entropy

Benutzeravatar
Janka
Beiträge: 3575
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 17. Jun 2012 21:19

Es gibt mit upstart keine feste Startreihenfolge der Dienste mehr, so dass man aus dem Symptom "Steht bei MySQL" leider keine Rückschlüsse ziehen kann, was genau nicht funktioniert. Hast du mal probiert, in Runlevel 3 zu booten? Evtl. funktioniert X11 nicht richtig und damit kein Login.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Entropy
Beiträge: 2
Registriert: 17. Jun 2012 15:37

#3 Beitrag von Entropy » 09. Jul 2012 21:52

Hallo Janka,

danke für Deine schnelle Antwort! Sorry, dass es bei mir leider länger gedauert hat zu antworten, aber bei mir war in letzter Zeit Land unter gewesen.

Runlevel 3 habe ich mal mit Shift-Alt zu starten und wenig erfolg gehabt. Irgendwo habe ich gelesen, dass es abgeblich in Ubuntu nicht möglich sein soll. Dennoch bin ich über den "Rescue Mode" in die Kommandozeile gekommen. Auf der Kommandozeile kann ich soweit arbeiten und über das Netzwerk andere Rechner erreichen. Ich habe zuerst befürchtet, dass er aufgrund von Netzwerkproblemen nicht bootet.
Den X-Server konnte auf der Kommandozeile mit startx nicht starten. Mit dem X-Server hatte ich bereits vor der Neu-Installation Probleme gehabt. Genauer gesagt ist er davor abgestürzt und ließ sich nicht mehr neu-installieren. Könnte es mit meiner Graphik-Karte zu tun haben (nvidia go 5200)? Bei der hatte der Treiber zuvor nicht 100%ig unter Ubuntu gepasst.

VG

Entropy

DH
Beiträge: 103
Registriert: 19. Feb 2006 13:31

#4 Beitrag von DH » 10. Jul 2012 11:09

Hi,

ich habe mich in letzter Zeit intensiv mit den Ubuntu-Versionen 11.04, 11.10 und 12.04 beschäftigt.
Meiner Meinung nach ist 11.10 total bugy, hatte nach Updates auch öfters Bootprobleme.

12.04 ist seit dem 26.April freigegeben, und wird jeden Tag besser.

Gruß - Dieter

Benutzeravatar
Janka
Beiträge: 3575
Registriert: 11. Feb 2006 19:10

#5 Beitrag von Janka » 10. Jul 2012 12:54

Entropy hat geschrieben:Den X-Server konnte auf der Kommandozeile mit startx nicht starten. Mit dem X-Server hatte ich bereits vor der Neu-Installation Probleme gehabt.
Dann würde ich mal den Treiber auf fbdev ändern und gucken ob es damit funktioniert. Wenn ja, ist der Grafiktreiber das Problem. Dann natürlich noch die Frage, was für einen Treiber du bisher nutzt? nouveau oder nvidia? Beachte, dass Nouveau unbedingt KMS benötigt, und nvidia und nv unbedingt *kein KMS* (Kerneloption "nomodeset") benötigen.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Antworten