Seite 1 von 1

Drucker druckt nicht und zieht Papier laufend durch

Verfasst: 20. Sep 2006 15:33
von bursche73
Hallo,

vorhandenen Drucker (Brother HL 2040) konnte über YaST2 gefunden und installiert werden. Nur wenn der Druckbefehl gegeben wird, dann zieht der Brother nur die Blätter durch und bedruckt diese nicht. Auch wenn nur eine Seite zum Druck freigegeben wird, dann werden über 20 Seiten eingezogen.

Was kann ich tun? (Drucker wegschmeißen geht übrigends nicht - gehört meinem Cheffe)

;-)

Verfasst: 20. Sep 2006 17:36
von Clio
Das sieht nach einem falschen Treiber aus.
Benutze die rpm Pakete von Brother.
Erst den Treiber, dann den cupswrapper installieren, anschließend über localhost:631 den Drucker einrichten.

http://solutions.brother.com/linux/sol/ ... rs.html#de
http://solutions.brother.com/linux/sol/ ... rs.html#de

YaST2 meldet sich...

Verfasst: 20. Sep 2006 21:12
von bursche73
Hallo Clio,

danke für die links - download der Suse-Treiber hat geklappt und dann beim installieren über YaST2 gibt es die Fehlermeldung:

"Folgende Pakete wurden auf dem Medium nicht gefunden: brhl2040lpr"

Ich habe aber ja das Paket angeklickt und YaST2 legte darauf los.
Über zen-installer bricht die Installation auch ab.

Was kann ich denn noch ausprobieren? Ich möchte doch nur bißchen drucken...

Gruß

Frank

Verfasst: 21. Sep 2006 11:14
von Clio
Hallo Frank,

solche Pakete kann man auch manuell auf der Konsole installieren, natürlich als root:
rpm -i <Paketname>

Etwas Basiswissen:
http://www.linuxfibel.de/

klappt nich... :-(

Verfasst: 22. Sep 2006 22:09
von bursche73
die manuelle Installation in der Konsole hat auch nicht geklappt, der Drucker wird zwar bei den Druckern angezeigt, localhost ist auch richtig drinne - aber der Drucker zieht nur die Blätter durch den Kasten und bedruckt sie nicht. Ich habe auch schon versucht anstatt USB-Anschluss über den guten alten LPT1 zu gehen - klappt auch nicht. Der Brother-Fachhändler hat den Linux-Onkel in Urlaub geschickt (frechheit) und Brother Deutschland will erst am Montag zurückrufen (immerhin).

Könnte ein Printserver Abhilfe schaffen? (Linux mal austricksen...) ??

Gruß in dir Runde

Frank

Verfasst: 23. Sep 2006 7:06
von Janka
Das Problem ist ja nicht die Datenübertragung zum Drucker. Das funktioniert ja. Also wird dir ein Printserver genau gar nichts bringen.

Installier den Druckertreiber. Wenn es nicht funktioniert, solltest du hier Fehlermeldungen posten.

Janka

Fehlermeldung?

Verfasst: 25. Sep 2006 10:20
von bursche73
ich habe manuell die Installation eines rpm-pak´s versucht:

rpm -i brhl2040lpr-1.1.2-2.i386.rpm
package brhl2040lpr-1.1.2-2 is already installed

Danach den CUPS-Treiber ohne eine Meldung. Irgendwas stimmt doch nicht, oder?

Gruß

Frank