Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 11. Dez 2018 16:31

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 28 Beiträge ]  Gehe zu Seite Vorherige 1 2
Autor Nachricht
 Betreff des Beitrags:
BeitragVerfasst: 20. Jan 2015 18:20 
Offline

Registriert: 13. Jan 2015 20:24
Beiträge: 15
Hallo Janka,

sorry, mein Fehler, hab ich nicht bemerkt!

Ich hoffe, dass das so jetzt richtig ist.

1.
[helfko62@helfko62-System-Product-Name ~ $ aplay -L
default
Playback/recording through the PulseAudio sound server
null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
hdmi:CARD=HDMI,DEV=0
HDA ATI HDMI, HDMI 0
HDMI Audio Output
dmix:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Direct sample mixing device
dsnoop:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Direct sample snooping device
hw:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Direct hardware device without any conversions
plughw:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Hardware device with all software conversions
sysdefault:CARD=U24XL
U24XL, USB Audio
Default Audio Device
front:CARD=U24XL,DEV=0
U24XL, USB Audio
Front speakers
surround40:CARD=U24XL,DEV=0
U24XL, USB Audio
4.0 Surround output to Front and Rear speakers
surround41:CARD=U24XL,DEV=0
U24XL, USB Audio
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=U24XL,DEV=0
U24XL, USB Audio
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=U24XL,DEV=0
U24XL, USB Audio
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=U24XL,DEV=0
U24XL, USB Audio
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=U24XL,DEV=0
U24XL, USB Audio
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=U24XL,DEV=0
U24XL, USB Audio
Direct sample mixing device
dmix:CARD=U24XL,DEV=1
U24XL, USB Audio #1
Direct sample mixing device
dsnoop:CARD=U24XL,DEV=0
U24XL, USB Audio
Direct sample snooping device
dsnoop:CARD=U24XL,DEV=1
U24XL, USB Audio #1
Direct sample snooping device
hw:CARD=U24XL,DEV=0
U24XL, USB Audio
Direct hardware device without any conversions
hw:CARD=U24XL,DEV=1
U24XL, USB Audio #1
Direct hardware device without any conversions
plughw:CARD=U24XL,DEV=0
U24XL, USB Audio
Hardware device with all software conversions
plughw:CARD=U24XL,DEV=1
U24XL, USB Audio #1
Hardware device with all software conversions
helfko62@helfko62-System-Product-Name ~ $ ...
[/list]

2.
[helfko62@helfko62-System-Product-Name ~ $ aplay -D iec958 /usr/share/sounds/alsa/test.wav
aplay: main:722: Fehler beim Öffnen des Gerätes: Datei oder Verzeichnis nicht gefunden
helfko62@helfko62-System-Product-Name ~ $
][/list]

Hab's so kopiert, aber ne Fehlermeldung bekommen.

Trau mich gar nicht zu fragen, aber was sind PCM's?
:oops:

cu helfko62


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 20. Jan 2015 20:24 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Aus irgendeinem Grund scheint er iec958 wohl beim HDMI-Audio oder so zu suchen. Der Befehl
Code:
$ aplay -D iec958:CARD=U24XL,DEV=0 /usr/share/sounds/alsa/test.wav
sollte jedenfalls funzen. Wie klingt es?

(Du kannst hier übrigens solche Ergebnis-Blöcke in
Code:
-Tags einschließen, dann sind sie leichter lesbar.)

PulseCodeModulation. Das sind Ausgänge, auf denen man Samples ausgeben kann. Im Gegensatz zu Midi-Ausgängen, auf denen man nur Noten ausgibt und das angeschlossene Gerät macht daraus erst ein Geräusch. Ganz früher hatten Soundkarten auch eingebaute Synthesizer. Das ist durch PCM alles obsolet geworden.


Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 20. Jan 2015 21:37 
Offline

Registriert: 13. Jan 2015 20:24
Beiträge: 15
Hallo Janka,
vielen Dank für Deine schnelle Antwort.
Leider führte die Eingabe zu folgender Fehlermeldung:

[lhelfko62@helfko62-System-Product-Name ~ $ aplay -D iec958:CARD=U24XL,DEV=0 /usr/share/sounds/alsa/test.wav
/usr/share/sounds/alsa/test.wav: Datei oder Verzeichnis nicht gefunden
helfko62@helfko62-System-Product-Name ~ $ ][/list]

cu helfko62

P.S. Vielen Dank auch für Deine Erklärungen!


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 21. Jan 2015 0:39 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Dann such dir doch bitte eine andere Wav-Datei zum Testen!

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 21. Jan 2015 20:03 
Offline

Registriert: 13. Jan 2015 20:24
Beiträge: 15
Hallo Janka!

T*schuldige, aber ich als unwissender, hatte jetzt angenommen, das dieses ein Befehl wahr, Linux dazu bewegen, auf die richtige Soundkarte zu verweisen, ich wusste nicht, dass dadurch eine Musikdatei abgespielt wird.

Wenn das so ist, in welchen Ordner muss sich den die Datei befinden/heissen? Oder bin ich jetzt schwer von Begriff :?

cu helfko62


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 21. Jan 2015 20:20 
Offline

Registriert: 30. Okt 2012 18:20
Beiträge: 68
Wohnort: umme Ecke
Navigiere in das Verzeichnis
/usr/share/sounds/alsa/ mittels
Code:
cd /usr/share/sounds/alsa
und schaue dort mittels
Code:
ls
nach welche Dateien dort liegen.
Die kannst Du dann mit
Code:
aplay DATEI.WAV
abspielen (DATEI.WAV an die Gegebenheiten anpassen).

_________________
Greetz
sojasau


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 21. Jan 2015 20:30 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Ist doch völlig egal, kannst dir eine Wav-Datei von irgendwoher besorgen. Wenn sie im aktuellen Verzeichnis liegt, ersetzt du /usr/share/sounds/alsa/test.wav durch den Dateinamen im aktuellen Verzeichnis, sonst halt durch einen beliebigen anderen Pfad.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 21. Jan 2015 21:14 
Offline

Registriert: 13. Jan 2015 20:24
Beiträge: 15
Hallo sojasau/Janka,

ich habe jetzt den Dateipfad geändert und so im Terminal eingegeben.

"aplay -D iec958:CARD=U24XL,DEV=0 /home/helfko62/Musik/test.wav"

Sound ist ausgegeben worden, nur leider so verzerrt wie vorher auch. :cry:

cu helfko62


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 21. Jan 2015 22:31 
Offline

Registriert: 13. Jan 2015 20:24
Beiträge: 15
Also, ich hab jetzt mal einen Mitschnitt gemacht.

http://www.FastShare.org/download/Sprachmemo_001.m4a

Man hört:

Sounddatei im Programm Banshee abgespielt, ohne weitere Einstellungen......( Ton verzerrt), mittendrin hab ich dann wie schon in meinem ersten Posting erwähnten Programm PulseAudio-Lautstärkeregler geöffnet mit den beschiebenen Einstellungen), ( Ton OK ), kurze Zeit später wieder geschlossen, Ton wieder verzerrt.

cu helfko62


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 22. Jan 2015 0:44 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Die Abspielgeschwindigkeit stimmt durchgehend, die Änderung ist ohne Aussetzen, was Kanaleinstellungen ausschließt. Und klingen tut es am Anfang und Ende einfach nur total übersteuert. Womit ich bei meiner ursprünglichen Annahme bin, dass die Mixereinstellungen nicht passen.

EDIT: Kannst du mal bitte den Alsamixer aufrufen, dann auf den Punkt "PCM capture source" gehen und "PCM out" einstellen - besser?

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 22. Jan 2015 19:42 
Offline

Registriert: 13. Jan 2015 20:24
Beiträge: 15
Hallo Janka,
Ich habe im Auswahlfenster von Alsamixer nur zwei Auswahlmöglichkeiten:

1. Line

https://www.dropbox.com/s/6uk4i5hv82lu5 ... 2.png?dl=0

2. IEC 958 in
https://www.dropbox.com/s/hlfqp9gqhsou3 ... 1.png?dl=0

Ob1 oder 2.....kein Ton.

Ich weiß nicht ab das wichtig ist, aber wenn ich im Terminal den Alsamixer aufmache, ab ich nie meine Soundkarte U24 XL sondern immer erst:

──────────────────────────── AlsaMixer v1.0.27.2 ─
────────────────────────────┐
│ Gerät: HDA ATI HDMI F1: Hilfe │
│ Chip: ATI R6xx HDMI F2: System-Informationen │
│ Ansicht: F3:[Wiedergabe] F4: Aufnahme F5: Alle F6: Soundkarte auswählen │
│ Element: S/PDIF Esc: Beenden │


_----------------------------------------------------------------------------------------------------------

Dann muss ich erst mit F6 umstellen. Ist das richtig?

[/list]


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 25. Jan 2015 10:13 
Offline

Registriert: 13. Jan 2015 20:24
Beiträge: 15
@ All

Großes Finale:

:lol:

Also, ich habe nach langen Überlegungen mich dazu entschlossen, meine Festplatte zu
formatieren und endgültig auf Linux umzusteigen, auch wenn das Problem mit der Soundkarte noch bestand.

Ich habe mich aber nicht für "Mint" sondern für "Ubuntu" entschieden.

Habe mir verschiedene Programme mit Hilfe des Ubuntu Software Centers installiert.
Beim stöbern viel mir da ein Programm wieder auf, und zwar der Gnome Alsamixer.

Ich weiß zwar nicht warum, aber nach der Installation ist alles in Ordnung.

Ich bin HAPPY!!!

An der Stelle möchte ich mich bei allen, insbesondere Janka für seine Hilfestellungen bedanken!

Bis zum nächsten Problem.............helfko62
:wink:


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 26. Jan 2015 0:23 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Schön, dass du dein Problem lösen konntest, wenn's ohne meine Hilfe ging, umso besser. Leider sind diese Soundprobleme sehr schwierig zu debuggen, weil es einfach zu viele Komponenten gibt, wo es hängen kann. Ich vermute, dass Ubuntu deine Hardware einfach korrekt einrichtet und es deshalb funzt.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 28 Beiträge ]  Gehe zu Seite Vorherige 1 2

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de