Seite 1 von 1

[x] Stabilität von aMule

Verfasst: 23. Apr 2005 18:41
von Lateralus
Ich benutze ein aMule 1.2.8 auf einem Gentoo-System. Ich habe es gestern erst installiert und es lief einwandfrei, aber jetzt stürzt es regelmäßig ab. Ich glaube nicht, dass ich zwischendurch Bibliotheken, welche vielleicht von dem Programm genutzt werden, verändert habe, bin mir da allerdings nicht sehr sicher.

Auf dem Terminal wird mir

Code: Alles auswählen

OOPS! - Seems like aMule crashed
--== BACKTRACE FOLLOWS: ==--

[0] amule(_ZN9CamuleApp16OnFatalExceptionEv+0x3c) [0x81e95cc]
[1] [0xffffe420]
Aborted
ausgegeben.

Ein

Code: Alles auswählen

while(true); do amule; done
tut es (samt entsprechender Starteinstellungen)
zwar auch, aber es wäre wirklich schön, wenn das Programm nicht abstürzte.

Was sind eure Erfahrungen mit aMule?

edit: Unter FreeBSD 5.3 passiert das gleiche (und da habe ich definitiv nach der Installation gar nichts am System geändert).

Verfasst: 02. Mai 2005 10:45
von Lateralus
Es scheint an einer zu hohen Einstellung unter Einstellungen -> Connection -> Max Connections gelegen zu haben. Vielleicht wurden zuviele Sockets erzeugt...