[ISDN] Starten von Applikationen Anruf

Gesperrt
Nachricht
Autor
Robert

[ISDN] Starten von Applikationen Anruf

#1 Beitrag von Robert » 22. Aug 2000 14:50

Hallo Leute,
kann mir jemand bei folgendem Problem helfen?
Ich benutze Debian (Potato) mit ISDN. Funktioniert soweit auch alles einwandfrei. Allerdings möchte ich bei eingehenden Anrufen ein Programm (vielmehr Script) starten, welches ein Foto des Anrufers zeigt. Das funktioniert im Prinzip auch, allerdings erst nachdem ich den isdnlog neu gestartet habe. (etc/init.d/isdnutils restart)

Kann jemand was damit anfangen?

TIA
Robert

odauter
Beiträge: 460
Registriert: 17. Apr 2000 20:05
Wohnort: Hamburg
Kontaktdaten:

Re: [ISDN] Starten von Applikationen Anruf

#2 Beitrag von odauter » 22. Aug 2000 15:26

> Das funktioniert im Prinzip auch, allerdings erst nachdem ich den isdnlog neu gestartet habe.

Und wo ist dann das Problem, wenn's funzt?
Zuletzt geändert von odauter am 22. Aug 2000 15:26, insgesamt 1-mal geändert.
bye.olli
--
"Where's Oswald when we need him.."

Robert

Re: [ISDN] Starten von Applikationen Anruf

#3 Beitrag von Robert » 23. Aug 2000 9:16

Ich habe keinen Bock den isdnlog jedesmal von Hand zu starten. Ich weiss ich könnte auch einfach ein Skript während dem Booten ausführen lassen, das das automatisiert, aber ich würde gerne wissen woran's liegt. Du verstehe? <img src="http://www.pl-forum.de/UltraBoard/Images/Happy.gif" border="0" align="middle">

odauter
Beiträge: 460
Registriert: 17. Apr 2000 20:05
Wohnort: Hamburg
Kontaktdaten:

Re: [ISDN] Starten von Applikationen Anruf

#4 Beitrag von odauter » 23. Aug 2000 10:12

Axo, von _jedesmal_ war nicht die rede... <img src="http://www.pl-forum.de/UltraBoard/Images/Happy.gif" border="0" align="middle"> Hmmm, keine Ahnung ehrlich gesagt.
Schreib uns doch mal genau, wie Du das mit diesem Bild gemacht hast, dann kommen wir der Sache vielleicht näher.
bye.olli
--
"Where's Oswald when we need him.."

cptchaos
Beiträge: 129
Registriert: 06. Jun 2000 21:42

Re: [ISDN] Starten von Applikationen Anruf

#5 Beitrag von cptchaos » 23. Aug 2000 18:01

Moin moin,

ich denke mal das Du die Skripte über die callerid.conf eingebunden hast.

In den meisten Fällen wird I4L über ein rc Skript gestartet (habe leider kein Debian), versuch doch einfach das entsprechnde Skript von Hand mittels der Optionen Stop und Start neu zu starten.

Ein besserer Weg wäre vieleicht ein Skript zu schreiben welches von ISDNLog die Nummer bekommt, und dann selbständig die entsprechenden Bilder läd und anzeigt. Dieses könnte dann später einfacher über eine Konf. Datei erweitert werden ohne neustart irgendwecher Dienste.
Der Ansatz aus dem Linuxmagazin ist nicht schlecht (gehe mal davon aus das Du hierher die Idee hattest) ist aber sicherlich noch ausbaufähig. Lese doch einfach mal die Docu. die du unter /usr/doc/pakages/i4l/isdnlog findest.

MfG Marek

Gesperrt