2 Rechner Linux Netzwerk... Ping funktioniert nicht

Antworten
Nachricht
Autor
Syrex

2 Rechner Linux Netzwerk... Ping funktioniert nicht

#1 Beitrag von Syrex » 24. Jan 2002 15:21

Hey
bin noch nicht so fit in Linux.. komme aber ganz gut damit klar. Habe gerade versucht ein Netzwerk aufzubauen..
2 PC´s mit Linux installiert. Der eine hat 3 Netzwerkkarten und der andere 2 (sollen mal als router fungieren)
Ich habe die IP und die Netmask eingestellt.. sieht auch gut aus. sind beide im gleichen netz. Die Routing tabelle stimmt auch..
Aber das netz geht nicht. der Ping kommt einfach nicht an..
Habe gelesen das teilweise noch dienste gestartet werden müssen??? Aber wie und vorallem was..
Wo liegt mein fehler?
gruß syrex

gewitter
Beiträge: 1354
Registriert: 09. Apr 2001 9:03

Re: 2 Rechner Linux Netzwerk... Ping funktioniert nicht

#2 Beitrag von gewitter » 24. Jan 2002 15:39

1. wie sieht die testumgebung aus? hub, switch, crossover?
2. hast du den ping auch dann ausprobiert, wenn die jeweils passenden schnittstellen/netzwerke zusammengesteckt waren?
3. wie sieht die routing tabelle aus?

Syrexx

Re: 2 Rechner Linux Netzwerk... Ping funktioniert nicht

#3 Beitrag von Syrexx » 24. Jan 2002 15:54

@Thomas...
hatte es erst über ein crossoverkabel probiert. War mir aber nicht ganz sicher welche der karte nun die eth0 ist. daher habe ich dann alle 5 karten an einen Switch gehängt um sicherzugehen das mein problem daran nicht liegt.
die Routing tabelle sieht wie folgt aus:

rechner 1
Destination GW GenMask IFace Flags Metric Ref Use
192.168.100.128 * 255.255.255.192 eth0 4 0 0 0
192.168.100.192 * 255.255.255.192 eth1 4 0 0 0
172.16.0.0 * 255.255.0.0 eth2 4 0 0 0

IP adressen:
eth0 = 192.168.100.141
eth1 = 192.168.100.200
eth2 = 172.16.0.1

Rechner 2
Destination GW GenMask IFace Flags Metric Ref Use
192.168.100.128 * 255.255.255.192 eth0 4 0 0 0
192.168.100.0 * 255.255.255.192 eth1 4 0 0 0

IP- Adressen
eth0 = 192.168.100.144
eth1 = 192.168.100.1

die beiden eth0 karten sollen dann ein Routing netz bilden. Aber dazu müssen sie sich erst mal ping könne sprich eine verbindung haben...

trinity
Beiträge: 821
Registriert: 12. Okt 2001 10:04

Re: 2 Rechner Linux Netzwerk... Ping funktioniert nicht

#4 Beitrag von trinity » 24. Jan 2002 16:02

@Syrexx
Das kann so nicht funktionieren. Ändere mal folgende Dinge ab:
rechner 1
Destination GW GenMask IFace Flags Metric Ref Use
192.168.100.0 * 255.255.255.192 eth1 4 0 0 0

IP adressen:
eth1 = 192.168.100.2
"Korrekt, Freundlich, Kostenfrei", wähle genau zwei. (Lutz Donnerhacke in dcsf)

Syrex

Re: 2 Rechner Linux Netzwerk... Ping funktioniert nicht

#5 Beitrag von Syrex » 24. Jan 2002 16:18

@Lutz
die Netzwerkkarten eth1 liegen doch ganz außen vor die sollen kein gemeinsames netz haben..
es geht momentan nur um die eth0... die beiden karten sollen eine connection kriegen. Die anderen sollten ihn doch gar nicht interessieren. Oder???

trinity
Beiträge: 821
Registriert: 12. Okt 2001 10:04

Re: 2 Rechner Linux Netzwerk... Ping funktioniert nicht

#6 Beitrag von trinity » 24. Jan 2002 16:36

Beide Karten (eth0 & eth1) liegen aber im gleichen Subnetz (141 & 200), dass führt zwangsläufig zu Problemen.
"Korrekt, Freundlich, Kostenfrei", wähle genau zwei. (Lutz Donnerhacke in dcsf)

Syrex

Re: 2 Rechner Linux Netzwerk... Ping funktioniert nicht

#7 Beitrag von Syrex » 24. Jan 2002 16:39

Das ist doch gar nicht war.. wie kommst du denn da drauf.
0-64; 65-128; 129-192; 193-255
bei der SNM 255.255.255.192
Oder irre ich da??? Also liegen sie in unterschiedlichen Netzen. Ich denke er das mir irgendwelche dienste fehlen.

Antworten