Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 19. Dez 2018 1:04

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 13 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: lilo mag win98 nicht
BeitragVerfasst: 08. Jan 2001 20:22 
Einen schönen Guten.

Ich habe eine kleine Unannehmlichkeit.
Ich möchte mit LILO win98 booten.
Ich habe zwei Festplatten.
Eine 6,4 GByte für Linux ganz alleine, und die bootet auch prima, sie ist hda.
Die zweite ca 30 GByte für Win98/Linux-Daten.
Diese bootet auch wunderbar, wenn ich im Bios
booten von D einstelle.
In Lilo habe ich eingegeben:
other=/dev/hdb1
label=windows
table=/dev/hdb

Über einen Tip wäre ich dankbar, schönen Dank schon im vorraus.


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 09. Jan 2001 15:36 
<humoristisch>
Also, als erstes saugen wir uns die neueste LILO-Version aus dem Netz, denn Du willst ja wohl nicht mit dem "alten Schinken" von Deiner Distri starten... <img src="http://www.pl-forum.de/UltraBoard/Images/Happy.gif" border="0" align="middle">
</humoristisch>

Aber Spass beiseite:
Ueberpruef mal, ob sich Deine zweite Platte auch wirklich hdb nennt.
Das ist immer unterschiedlich. Ich habe nur eine Festplatte, da ist hda meine Festplatte und hdc das CDROM-Laufwerk. Ich kenne aber auch jemanden, der zwei Festplatten hat und da ist hda, die erste Festplatte und hdc die zweite Festplatte. hdb gibt es dort garnicht und hdd ist das CDROM-Laufwerk.

Somit mein Tip: Ueberpruefe erst einmal, wie sich Deine zweite Festplatte nennt.


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 09. Jan 2001 15:48 
> <i>lilo mag win98 nicht</i>
Niemand mag Win98...
Aber trage doch mal in Deine /etc/lilo.conf ein loader=/boot/chain.b in den Abschnitt mit windows ein und guck was passiert.


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 09. Jan 2001 20:30 
Ersteinmal Danke!

Lilliput: die zweite Festplatte ist hdb, ich habe eine partition gemountet und es funktioniert.

Ben: ich habe den "loader" eingetippt, mit und ohne "table" aber ich sehe nur einen Eingabestrich der sich aber nicht bewegen läst. Es hilft, wie vorher auch nur ein RESET.


Habt Ihr noch einen anderen Tip?
Oder eine deutsche Lilo Erklärung?

PS: Win hat für Umsteiger den Vorteil das Viele dinge schon Unterstützt werden.
Mausrad,TV-Karte mit Ton, mp3-Files in anständiger Umgebung etc.


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 09. Jan 2001 23:54 
Hi!

Leider hab' ich noch kein Win auf der zweiten Festplatte installiert. Aber BSD, das braucht die gleichen Einträge wie Win. Das funktioniert reibungslos.

Daher blöde Frage: Wo hast Du LILO installiert? Im MBR? Hast Du danach auch /sbin/lilo aufgerufen, damit der weiß, daß er neues Geschäft bekommen hat, sprich ein weiteres Betriebssystem zum starten?

Meiner Meinung nach ist Dein Eintrag in der lilo.conf OK. (Da Du nun die Benennung der Platte als korrekt kennst).

Wenn LILO läuft, brauchst Du nichts mehr im Bios umstellen.

Übrigens: Linux kann's mit dem Rädchen der Maus (könnte ohne gar nicht leben). TV-Karten mit Ton laufen meines Wissens auch prima. MP3 weiß ich nicht.

Viel Erfolg,
Eared


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 10. Jan 2001 9:41 
@Olli:

Wenn Du Änderungen an "lilo.conf" vorgenommen hast, hast Du dann danach auch immer das Programm "lilo" aufgerufen? (Weil sonst die Änderungen nicht wirksam werden)


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 10. Jan 2001 12:44 
>lilo mag win98 nicht
Ich auch nicht


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 10. Jan 2001 13:59 
Hallo!

Also als erstes ich finde hier im Forum lauter total sinnlose einträge von diesem FRM.FROSCH? Kann das sein das dein Papa dich als unbeaufsichtigt an den PC lässt?

Zu deinem Problem Olli:
Mormalerweisse will M$ Windoof immer von der erstem Platte aus booten (hda), dies kann man aber auch umgehem. Mit diesem chain.b.

Durch die anschliessende Angabe von map-drive kann man eine Umlenkung von Festplatten durch /boot/chain.b vornehmen lassen, so kann man z.B. auch M$-DOS von einer zweiten Platte booten, obwohl es nur von der Primären bootbar ware. Mit Linux ist eben alles möglich *GG* <img src="http://www.pl-forum.de/UltraBoard/Images/Wilk.gif" border="0" align="middle">

Der eintarg sieht so aus:
loader = /boot/chain.b
map-drive = 0x80
to = 0x81
map-drive = 0x80
to = 0x81

Um die einträge zu verstehen muss man wissen, das die erste Platte des PCs mit der ID 80 (hexdezimal) eingetragen ist. Die zweite Platte hat die Nummer 81 (ebenfalls hexdezimal). Durch die oben geschriebene Anweisung wird also dem ausführen von /boot/chain.b die erste Platte zur zweiten umgekehrt. Das gilt auch für für das Bootsektor Programm os2_d.b, also werden die any_b.b und any_d.b nicht benötigt.

Ich hoffe das hilft dir ... <img src="http://www.pl-forum.de/UltraBoard/Images/Happy.gif" border="0" align="middle">

Benjamin Kl.


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 10. Jan 2001 19:06 
Hi, mal wieder.

Also Lilo ist natürlich im MBR installiert.
Das supertolle(ironisch) win98 ist zwar D.
Aber beim einstellen des Bios "booten von D" klappt das Booten von win prima es ignoriert ganz einfach die Linux-festplatte.
Beide Festplatte sind zu 100% bootfähig.
Sie sind beide als Primär(oder so ähnlich)
aktiviert. Nur deshalb bootet wahrscheinlich win trotzdem es D ist.
Das ich lilo Änderungen mitteilen muß weiß ich.
Wenn ich meine beiden Festplatten umjumpern würde, hätte ich sofort win, würde aber nicht an das bessere linux rankomme.<img src="http://www.pl-forum.de/UltraBoard/Images/Happy.gif" border="0" align="middle">

Benjamin KL.: habe ich ausprobiert, geht nicht


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 10. Jan 2001 22:03 
Hi nochmal ...

hmmm ... wenn das nicht hilft weiss ich auch nicht weiter ... aber wenn du Zeit und Lust hast kannst du die Platten mal umbauen, so das die Linuxplatte hdb und die winplatte hda ist. Denn Windows (oder besser M$-DOS) braucht die erste Platte (Primary Master) um zu booten. Vergess aber nicht vorher in der /etc/fstab die Einträge zu ändern und mit einer Bootdiskette kannst du dann lilo neuschreiben.
Wenn das aber auch nicht hilft, dann musst du warscheinlich alles neuinstallieren. Mach zuerst M$ Winshit und dann Linux (Frage nebenbei, was für eine Distri hast du denn??) Installier aber Win auf die erste Platte und Linux auf die erste und/oder zweite.

Noch was, ich habe mir von einem Freund sagen lassen, dass man Winshit98 auch auf hdb (D:\) installieren kann, und es von dort booten kann. Er hat das mal gemacht und bei ihm hast funktioniert. Es was das Update von Win98.

Nun, ich hoffe es hilt dir jetzt, auch wenn das jetzt nicht so ermutigend ist, (neuinstallationen sind nie ermutigend, aber das will ja kein winuser wahr haben <img src="http://www.pl-forum.de/UltraBoard/Images/Wilk.gif" border="0" align="middle"> ) geholfen.

Benjamin Kl.


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 11. Jan 2001 20:47 
Die Experten, die gar nicht wissen worum es geht, sollten auf ihre Postings ersatzlos verzichten!!

Also ich hab bei mir eine Konfiguration, wo ich Windows von der Platte boote, die als Master am 2. IDE-Controller hängt: "HDC" !!!

Der funktionierende Eintrag in lilo.conf lautet:
================================================ schnipp
other = /dev/hdc2
label = win
map-drive = 0x80
to = 0x81
map-drive = 0x81
to = 0x80
table = /dev/hdc
================================================ schnapp
Rechtschreibgeprüft!

Muss jetzt nur noch geändert werden auf hdb und partitionsnummer ändern, die gebootet werden soll!

Gruß Thomas


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 12. Jan 2001 0:12 
@Thomas
Hallo,

kann sein das ich mich da wohl vertippt habe und zweimal die erste zu zweiten Platte machen wollte und keine wieder zu ersten ... sorry ... nobody is perfect, und keiner ist ein nobody.
Und noch was, er hat nicht sicher gesagt ob er die zweite Platte auch an den zweiten IDE Controller gehängt hat, er hat gesagt:
<zitat>
[...]
Sie sind beide als Primär(oder so ähnlich)
[...]
</zitat>
und wer kann sich da schon was drunter vorstellen?! du als obertoller, supermäsiger Linuxer gewiss net! Auserdem hat er mal was von "hdb" geschriben (!!!) ... klingelt es?!

@Olli
sorry wenn ich dich vielleicht sogar zur einer neuinstallation überredet habt, war ein Tippfehler von mir <img src="http://www.pl-forum.de/UltraBoard/Images/Sad.gif" border="0" align="middle">

Benjamin Kl.


Nach oben
   
 Betreff des Beitrags: Re: lilo mag win98 nicht
BeitragVerfasst: 13. Jan 2001 23:05 
OK - Benjiamin Kl. - ich hab nur das kopiert, was bei mir drin steht und darauf hingewiesen, daß es geändert werden muss. Aber Du hast sicherlich recht, wenn Du mir unterstellst keinen guten Tag gehabt zu haben.

Gruß Thomas


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 13 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de