Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 16. Dez 2018 4:05

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 4 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: mutt Pager
BeitragVerfasst: 11. Jan 2001 7:40 
Offline
Pro-Linux
Benutzeravatar

Registriert: 15. Aug 1999 16:59
Beiträge: 3238
Wohnort: Bruchsal
Hi,

kann man den internen Pager von mutt dazu kriegen, Umlaute korrekt anzuzeigen? Ich will ungern einen externen Pager wie less verwenden (mit less funktionieren die Umlaute).

Danke,
hjb

_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?


Nach oben
   
 Betreff des Beitrags: Re: mutt Pager
BeitragVerfasst: 13. Jan 2001 0:02 
dammich, das problem hatte ich schon mal erfolgreich geloest,... und wegen unwichtig (!?) wieder nicht dokumentiert und jetzt krieg ich's nicht mehr hin...

...nicht aufgeben, next week, I'll try again...

ratte


Nach oben
   
 Betreff des Beitrags: Re: mutt Pager
BeitragVerfasst: 13. Jan 2001 4:35 
Offline

Registriert: 16. Aug 1999 6:44
Beiträge: 597
Wohnort: Lorsch (Südhessen)
Hi!

Also bei mir lag das daran, dass die Umgebungsvariable LANG nicht auf "de_DE" gesetzt war. Allerdings zeigte Mutt nur bei manche Mails die Umlaute nicht korrekt an, bei den meisten funktionierte es.

alias mutt="LANG=de_DE mutt"

Cheers,
Wolfgang


Nach oben
   
 Betreff des Beitrags: Re: mutt Pager
BeitragVerfasst: 13. Jan 2001 11:02 
Offline
Pro-Linux
Benutzeravatar

Registriert: 15. Aug 1999 16:59
Beiträge: 3238
Wohnort: Bruchsal
Hi,

die Variable LANG ist bereits auf de_DE gesetzt. In .muttrc habe ich charset auf iso-8859-1 gesetzt. Ich habe jetzt auch mal

set locale="de_DE"

eingefügt, auch das hilft nichts. Laut Doku gilt das auch nur für das Datumsformat.

Dann habe ich zu meinem Standard-Debugging-Tool gegriffen: strace. Laut strace greift mutt auf /usr/lib/locale/* zu, während meine Locale-Daten in /usr/share/locale liegen. Typisches Problem, wenn man auf einem System compiliert und das Programm auf einem anderen ausführen will <img src="http://www.pl-forum.de/UltraBoard/Images/Sad.gif" border="0" align="middle">

Also schnell mal einen Link gesetzt. Nun findet mutt die Locale-Dateien, doch im Pager ändert sich nichts. Fürs erste reicht mir das - die Version, die ich einsetze (letzte Entwicklerversion) ist wohl fehlerhaft.

Gruß,
hjb

_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 4 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de