Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 21. Nov 2018 7:37

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 15. Feb 2007 14:24 
Also da will ich doch glatt komplett auf Linux umsteigen ,habe aber ein großes Problem . Nach dem installieren der proprietären Nvidia Treiber ,friert X ein ,Habe es mit verschiedenen Distributionen ,und verschiedenen einstellungen in der /xorg.conf versucht ,hilft alles nichts .
Habe schlieslich bei holarse-linuxgaming.de lesen können ,das mein Problem wohl damit zusammenhängt ,das dieser Nvidia treiber sich unter Linux nicht mit meinem SiS Chipsatz versteht ,als Lösung wird die Verwendung des "agpgart"Moduls Vorgeschlagen ,Nur weiss ich nicht WIE? und überhaupt habe ich dann wenigstens noch eine wenn auch vielleicht verlangsamte 3D Hardware Beschleunigung ?

Wäre toll wenn mir jemand weiterhelfen könnte ,bin völlig frustriert !
Danke


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 16. Feb 2007 4:26 
du musst im kernel den agpgart treiber entfernen. für die sis chipsätze stellt nvidia einen eigenen agp treiber zur verfügung.
in der xorg-config muss man dann
Zitat:
Option NvAGP "1"
einfügen. dann wird der nvidia agp-treiber benutzt.
im kernel ist das irgendwo in device-drivers drin.
bei mir klappt das zwar trotzdem nicht, aber vielleicht bei dir.
und es kommt darauf was du für eine graka hast. ältere laufen nur noch mit den
legacy-drivers.
alles zu lesen auf der nvidia seite.


Nach oben
   
 Betreff des Beitrags: Problem gelöst
BeitragVerfasst: 16. Feb 2007 12:37 
also ich habe mir nochmal die Liste der unterstützten Motherboard Chipsätze bei Nvidia angeschaut ,und meiner (SiS 746FX) ist nicht dabei ,also ist es falsch "option NvAGP "1" zu setzen statdessen sollte der Wert 2 oder 3 sein um "agpgart" statt des Nvidia agp zu benutzen (3D Beschleunigung bleibt aktiv).

Das alleine reichte aber nicht, zusätzlich musste ich noch in die /etc/X11/xorg.conf in die Liste "load Modules" den Eintrag "Load GLcore" machen .
Seiddem startet X ohne Probleme mit 3D Hardware Beschleunigung .


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de