Zentyal + https://localhost:8443/Samba/Composite/FileSharing#SambaShares +acl?

Antworten
Nachricht
Autor
Andreas 1967
Beiträge: 149
Registriert: 18. Mai 2013 5:01

Zentyal + https://localhost:8443/Samba/Composite/FileSharing#SambaShares +acl?

#1 Beitrag von Andreas 1967 » 02. Mär 2015 16:55

Hallo , vor einigen wenigen Tagen habe ich Zentyal 4.0 CommunityEdition installiert.
Ich möchte einen Ordner als Sambashare freigeben, dazu nutze ich Firefox und die Zentyal Administration.
Also dort >>>
https://localhost:8443/Samba/Composite/ ... ambaShares

Nur bekomme ich bei der Eingabe des per pacmanfm per copy and paste eingefügten Ordners folgendes >>>
The mount point '/' must be mounted with 'acl' option. This is required for permissions to work properly.
Was ist 'acl'?
Was muss ich machen damit Zentyal 4.0 einen Netzwerkfreigabeordner akzeptiert?

Benutzeravatar
Janka
Beiträge: 3575
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 02. Mär 2015 18:55

Du versuchst, ein SMB-Netzwerkdateisystem als root-Dateisystem zu verwenden. Das wird auf diese Weise sowieso nicht funktionieren, der Mountpoint ist falsch und die Fehlermeldung nicht auf diesen Versuch gemünzt.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Andreas 1967
Beiträge: 149
Registriert: 18. Mai 2013 5:01

#3 Beitrag von Andreas 1967 » 03. Mär 2015 12:33

Nachdem ich fstab angepasst hatte siehe unten, funktioniert die Netzwerkordnerfreigabe.

Code: Alles auswählen

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda14 during installation
UUID=7575f22b-4efa-45d8-a03e-a996264a56f5 /               ext4    acl,errors=remount-ro 0       1

Benutzeravatar
Janka
Beiträge: 3575
Registriert: 11. Feb 2006 19:10

#4 Beitrag von Janka » 03. Mär 2015 14:41

Diese fstab-Zeile enthält nichts netzwerkspezifisches, die Fehlermeldung hatte also auch nichts mit dem Versuch, ein Netzlaufwerk zu mounten, zu tun. Vermutlich einfach nur Fallout eines älteren Problems.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Andreas 1967
Beiträge: 149
Registriert: 18. Mai 2013 5:01

#5 Beitrag von Andreas 1967 » 04. Mär 2015 15:53

Doch Janka
UUID=7575f22b-4efa-45d8-a03e-a996264a56f5 / ext4 acl,errors=remount-ro 0 1
--------------------------------------------------------------------------^^^----------------------------------------------------------------------acl ist Netzwerkspeziefisch.

ups

acl

#6 Beitrag von ups » 04. Mär 2015 21:23

acl ist "access control list" und regelt den Zugriff auf das Filesystem

gro

#7 Beitrag von gro » 04. Mär 2015 23:08

lol. bist du sicher das linux wirklich was für dich ist? ein bisserl selbst denken und problem lösen sollte man schon können. wenn man deine threads liest kann man nur mit dem kopf schütteln.

Benutzeravatar
Janka
Beiträge: 3575
Registriert: 11. Feb 2006 19:10

#8 Beitrag von Janka » 05. Mär 2015 14:16

Nein, der Schalter "acl" hat mit Netzwerk direkt nichts zu tun. Damit gibst du an, dass du über die normalen Unix-Rechte hinaus auch noch Access Control Lists in dem Dateisystem unterbringen willst. Die meisten Dateisysteme haben diese Funktionalität, man muss sie allerdings explizit einschalten.

Da die normalen Linux-Distributionen ACLs für Sonderzwecke nutzen, sollte man sie auf jeden Fall einschalten. Zum Beispiel der Samba-Server benutzt ACLs, um die über ihn angelegten Dateien mit Rechten nach MS-Windows-Manier zu taggen. Ohne ACLs geht das nicht, der Samba-Server meckert dann, funzt aber trotzdem. Nur kann er dann eben nicht alle Benutzerrechte der MS-Windows-Seite abbilden.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Antworten