Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Serieller Port belegt nach Update Suse 6.1->6.2

 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Uwe Koch
Gast





BeitragVerfasst am: 02. Nov 1999 22:29   Titel: Serieller Port belegt nach Update Suse 6.1->6.2

Hallo !

nach dem Update auf 6.2 kann ich mit keinem Programm mehr meinen seriellen Port erreichen. wvdial sagt alle Ports durchgescannt kein Modem - kppp sagt modem busy... aber ich habe sogar den hylafax ausgestellt, obwohl er bei 6.1 nicht dazwischengefunkt hat. Im Kernel ist die serielle Unterstützung wie beim alten Kernel einkompiliert.

Wer weiss Rat ?

Danke schon mal !
Uwe
 

Uwe Koch
Gast





BeitragVerfasst am: 04. Nov 1999 6:56   Titel: Inhalt /proc Filesystem

Im /proc Verzeichnis habe ich folgendes gefunden:

______________
/proc/tty/drivers:
serial /dev/cua 5 4-107 serial:callout
serial /dev/ttyS 4 64-107 serial

pty_slave /dev/ttyp 3 0-255 pty:slave
pty_master /dev/pty 2 0-255 pty:master
serial /dev/cua 5 64-67 serial:callout
serial /dev/ttyS 4 64-67 serial

/dev/tty0 /dev/tty0 4 0 system:vtmaster
/dev/console /dev/console 5 1 system:console
/dev/tty /dev/tty 5 0 system:/dev/tty
unknown /dev/tty 4 1-63 console


/proc/tty/driver/:
2x serial - identisch...
_____________

Sieht also so aus, als ob 2x ein serieller Treiber geladen wird -
(ich habe eine PS/2 Maus und ein Modem).

Aber irgendwie wird für den seriellen Port (COM1)
scheinbar der serielle Treiber doppelt geladen und blokiert
dann jeden Zugriff.
Oder es liegt einfach an den beiden seriellen Ports, die existieren.

Wer kennt sich mit Suse 6.2 aus und weiss, wie
man diese Blockierung von COM1 aufheben kann ?

Uwe
 

ThomasK.
Gast





BeitragVerfasst am: 04. Nov 1999 11:39   Titel: Re: Serieller Port

Hallo,

ich hatte dasselbe Problem, und habe dann einfach das Modem an den 2. Port rangesteckt,
und seit dem geht es.

ansonsten weiss ich im Moment auch nicht mehr


Tschüss

TK
 

Uwe Koch
Gast





BeitragVerfasst am: 06. Nov 1999 19:19   Titel: Leider Nein !

Auch das funktioniert nicht !!

Auch auf dem Port ist das Modem busy
Vor dem Update lief alles - Mist.

Uwe
 

Stefan
Gast





BeitragVerfasst am: 06. Nov 1999 19:38   Titel: Serieller Port belegt nach Update

Ich hatte das Problem auch nach einer Kernelkompilierung. Zunächst hat folgender Befehl geholfen( als root):
setserial /dev/ttyS0 uart 16550A (für com1)
setserial /dev/ttyS1 uart 16550A (für com2)
Das hilft den Schnittstellen ein wenig auf die Sprünge, mußte aber nach jedem Booten ausgefühlrt werden.
Endgültig gelöst wurde das Problem als ich in der Suse-Support-Datenbank nachgeschaut hatte, wo stand:
##########################################
Serielle Unterstützung

Bezieht sich auf

Kernel: Version 2.2.5

Symptom:

Nach der Kompilierung eines neuen Kernels kann auf serielle Geräte nicht mehr zugegriffen werden.

Ursache:

Ab der Kernelversion 2.2.5 wird die serielle Unterstützung automatisch als Modul geladen. Sollte sie also in den Kernel kompiliert worden sein, so wird sie nach
dem Laden des Kernels zusätzlich als Modul geladen.

Lösung:

Die Datei:

/lib/modules/2.2.5/misc/serial.o

muss gelöscht werden, dann kann das Modul nicht mehr geladen werden.

In der Datei /etc/conf.modules die Zeile:

alias char-major-4 serial

nach:

alias char-major-4 off

ändern, um zu verhindern dass der Kernel versucht das Modul nachzuladen.

############################################
Also einfach serielle Unterstützung nicht fest einkompilieren, sondern als Modul und schon gehen Maus und Modem wieder einwandfrei.
Stefan
 

Uwe Koch
Gast





BeitragVerfasst am: 19. Nov 1999 3:12   Titel: Das wars..Serieller Port laeuft jetzt..

Danke, Stefan - das war der Fehler !!!

Vielen Dank für den genauen Hinweis auf die genaue Hilfeseite bei SuSE.

(Ich war mir sicher, die Support DB durchforstet zu haben, aber ich konnte den Artikel damals nicht finden...peinlich)
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy