Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Qt 1.4x und 2.0 gleichzeitig?

 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
markus



Anmeldungsdatum: 18.08.1999
Beiträge: 2

BeitragVerfasst am: 21. Jan 2000 21:22   Titel: Qt 1.4x und 2.0 gleichzeitig?

Ich habe folgendes Problem:

Auf meinem Rechner ist die Qt-Lib in der Version 1.44 und 2.0 installiert. Soweit alles gut. Da die aktuelle KDE-Version 1.1.x noch mit Qt-1.4x arbeitet und ich Programme für KDE schreiben möchte muß ich derzeit noch diese Version verwenden.

Und nun zu meinem Problem:
Beim Linken kommpt es bei mir immer zu Fehlermeldungen und es wird abgebrochen. Das ist nicht nur bei meinen Programmen so. Auch wenn ich andere KDE-Programme übersetzen ist es das gleiche! Anscheinend wird immer versucht dir 2.0-Libs zu Linken. Es wird aber nach dem Aufruf von einem "configure"-Script angezeit, dass die 1.44-Libs verwendet werden. Wenn ich aber reine Qt-Programme schreibe, funktioniert alles prima, allerdings nur Qt-2.0-Programme.

Es sind auch beide in "/etc/ld.so.conf" eingetragen.

Ich bin nun mit meinem Latain am Ende!
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Joachim Ansorg
Gast





BeitragVerfasst am: 22. Jan 2000 1:02   Titel: Re: Qt 1.4x und 2.0 gleichzeitig?

Hi!

Leider verwendet der Compiler die Einstellkugen in /etc/ld.so.conf nicht.
Der verwendet -L und -l als Option.
Schreib mir einfach mal unter Jockel12@gmx.de für mehr, da ich jetzt nicht so viel Zeit habe.

--Joachim
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy