Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Kommunikationsproblem: XWindows und xfstt

 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Michael Bernards
Gast





BeitragVerfasst am: 09. Feb 2000 14:26   Titel: Kommunikationsproblem: XWindows und xfstt

Ich habe nach der Anleitung bei Pro-Linux xfstt auf SuSE 6.3 installiert.
Das hat auch bestens funktioniert. Leider mußte ich die Installation wegen
zweier Probleme rückgängig machen:

- Sobald xfstt läuft und der X-Server mit dem neuen FontPath gestartet ist
komme ich nicht mehr über Netz mit einem X-Server an den Rechner (in diesem
Falle Exceed von einer NT4-Workstation.

- Ich habe KDM als grafischen Login installiert. Nach dem Reboot kommt X
nicht mehr hoch. Es wird permanent zwischen Grafik-Modus und Text-Modus
gewechselt. Erst ein 'init 2' via telnet konnte den Spuk beenden.

Sind dies bekannte Probleme und lassen die sich evtl. beheben?
 

heinrich



Anmeldungsdatum: 22.09.1999
Beiträge: 219
Wohnort: N49.137 E8.544

BeitragVerfasst am: 09. Feb 2000 14:27   Titel: Re: Kommunikationsproblem: XWindows und xfstt

> - Sobald xfstt läuft und der X-Server mit dem neuen FontPath gestartet ist
> komme ich nicht mehr über Netz mit einem X-Server an den Rechner (in diesem
> Falle Exceed von einer NT4-Workstation.

Dazu kann ich leider nichts sagen. Ich habe weder Windows NT4, Exceed noch eine vergleichbare Software.


> - Ich habe KDM als grafischen Login installiert. Nach dem Reboot kommt X
> nicht mehr hoch. Es wird permanent zwischen Grafik-Modus und Text-Modus
> gewechselt. Erst ein 'init 2' via telnet konnte den Spuk beenden.

Deit neuestem tritt dieses Problem auch bei mir auf (Kernel 2.3.42, SuSE 6.3, XF86 v3.3.6)

Das Problem liegt (bei mir) darin, dass zwar xfstt korrekt beim Reboot gestartet wurde, aber X-Windows schmirt beim ersten starten ab (kann nicht auf den Font-Server zugreifen ? warum ?) und hängt wieder an der Konsole. Ein Starten des X-Windows ist erst dann möglich, wenn root den Font-Server explizit noch einmal stoppt und neu startet (KEIN xfstt restart !).
Beendet ein User sein X-Windows und versucht danach mit startx an der Konsole es neu zu starten haben wir wieder das Problem mit dem Font-Server.

Weil Du den Rechner für ein grafisches Login konfiguriert hast (Runlevel 3), wird nachdem der X-Server runtergeknallt ist (Runlevel 2), erneut versucht in den Runlevel 3 zu wechseln --> Endlosschleife ?
 
Benutzer-Profile anzeigen Private Nachricht senden AIM-Name

Tux
Gast





BeitragVerfasst am: 10. Feb 2000 20:49   Titel: Re: Kommunikationsproblem: XWindows und xfstt

He so ein Problem habe ich hier auch.
Hier mal die Fehlermeldung:

code:

XFree86 Version 3.3.5 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: August 23 1999
If the server is older than 6-12 months, or if your card is newer
than the above date, look for a newer version before reporting
problems. (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.5-15 i686 [ELF]
Configured drivers:
SVGA: server for SVGA graphics adaptors (Patchlevel 0):
NV1, STG2000, RIVA 128, RIVA TNT, RIVA TNT2, RIVA ULTRA TNT2,
RIVA VANTA, RIVA ULTRA VANTA, RIVA INTEGRATED, GeForce 256,
GeForce DDR, Quadro, generic
(using VT number 7)

XF86Config: /etc/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(--) no ModulePath specified using default: /usr/X11R6/lib/modules
GLX extension module for XFree86 3.3.5c -- Mesa version 3.0
GLX package version 0.9, GLX protocol version 1.2.
(**) module glx.so successfully loaded from /usr/X11R6/lib/modules
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc104"
(**) XKB: layout: "de"
(**) XKB: variant: "nodeadkeys"
(**) Mouse: type: PS/2, device: /dev/psaux, samplerate: 60
(**) Mouse: buttons: 3
(**) SVGA: Graphics device ID: "Primary-Card"
(**) SVGA: Monitor ID: "Primary-Monitor"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/URW,/usr/X11R6/lib/X11/fonts/Speedo,/usr/X11R6/lib/X11/fonts/misc,/usr/X11R6/lib/X11/fonts/75dpi,/usr/X11R6/lib/X11/fonts/100dpi,/usr/X11R6/lib/modules,unix/:7101"
(--) SVGA: PCI: NVidia Unknown chipset (0x0101) rev 16, Memory @ 0xf0000000, 0xe8000000
(--) SVGA: chipset: GeForce DDR
(--) SVGA: videoram: 32640k
(**) SVGA: Option "dac_8_bit"
(**) SVGA: Using 16 bpp, Depth 16, Color weight: 565
(--) SVGA: Maximum allowed dot-clock: 350.000 MHz
(**) SVGA: Mode "1152x864": mode clock = 114.590
(**) SVGA: Virtual resolution set to 1152x864
(--) SVGA: SpeedUp code selection modified because virtualX != 1024
(--) SVGA: GeForce DDR: Using hardware cursor
(--) SVGA: Using XAA (XFree86 Acceleration Architecture)
(--) SVGA: XAA: Solid filled rectangles
(--) SVGA: XAA: Screen-to-screen copy
(--) SVGA: XAA: Using 9 128x64 areas for pixmap caching
(--) SVGA: XAA: Caching tiles and stipples
(--) SVGA: XAA: Horizontal and vertical lines and segments
GlxExtensionInit
RIVA GLX Version = 1.2
_FontTransSocketUNIXConnect: Can't connect: errno = 2
failed to set default font path '/usr/X11R6/lib/X11/fonts/75dpi:unscaled,/usr/X11R6/lib/X11/fonts/100dpi:unscaled,/usr/X11R6/lib/X11/fonts/Type1,/usr/X11R6/lib/X11/fonts/URW,/usr/X11R6/lib/X11/fonts/Speedo,/usr/X11R6/lib/X11/fonts/misc,/usr/X11R6/lib/X11/fonts/75dpi,/usr/X11R6/lib/X11/fonts/100dpi,/usr/X11R6/lib/modules,unix/:7101'
Fatal server error:
could not open default font 'fixed'

When reporting a problem related to a server crash, please send
the full server output, not just the last messages

XIO: fatal IO error 104 (Die Verbindung wurde vom Kommunikationspartner zurückgesetzt) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

 

Thomas Gern
Gast





BeitragVerfasst am: 14. Feb 2000 23:40   Titel: Re: Kommunikationsproblem: XWindows und xfstt

Ich habe das hier bei mir mal geprüft.
Ergebnis:
Die genannten Probleme lassen sich mit den Kernel-Versionen 2.3.4* nachvollziehen.
Keine Probleme macht bei mir der Kernel 2.2.13-SuSE.

Kann mir jemand Erklären, warum das bei den anderen Kerneln der Fall ist, dass der X-Server wieder runterknallt ?!
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy