Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
SuSe 6.4-Installation: Bitte um Hilfe!

 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Giuli
Gast





BeitragVerfasst am: 11. Apr 2000 12:49   Titel: SuSe 6.4-Installation: Bitte um Hilfe!

Hallo Leute,

ich habe ein System mit zwe Festplatten: C mit 20 GB (Eide) und D mit 4,3 GB (SCSI). Auf C ist eine primäre Partition mit einer grösse von 3 GB (Win98). Danach habe ich dann Linux installiert. Hier habe ich drei an die primäre Partition anschliesende logische Laufwerke erstellt (17 GB erweiterte Partition auf C); 24 MB für /boot, 133 MB für swap und ca 7,3 GB für /.
Nach der Installation von Linux konnte ich mich ohne Probleme bei Linux einloggen (im Grafiksystem von Linux).
Nun habe ich aber an diese drei logischen Laufwerte zwei folgende Laufwerke, je 2 GB für Win98, erstellt.

Jetzt funzt aber Linux nicht mehr richtig. Denn jetzt kann ich das Grafiksystem von Linux nicht mehr laden (es kommt ein Eingabemaske wie "repair filesystem". Das Programm fsck.ext2 meldet nur Fehler.

Jetzt meine Frage: Kann es sein, das Linux nur richtig funzt, wenn es die letzten Partitionen, und diese zusammenhängend, in der Festplatte verwendet? Kann es sein, das sobald Linux nicht mehr die letzten Partitionen hat auf der Festplatte (so eben wie bei mir mit den zwei anschliessenden 2GB-Partitionen von Win98) nicht mehr funzt?

Würde mich auf eine Antwort sehr freuen, denn ich habe SuSe-Linux 6.4 nun seit schon über einer Woche, aber zum endgültigen laufen bekomme ich es nicht! :(

Gruss Giuli
 

AndreasM
Gast





BeitragVerfasst am: 11. Apr 2000 15:04   Titel: Re: SuSe 6.4-Installation: Bitte um Hilfe!

Hallo Giuli,
eigentlich ist Linux sehr robust.
Ich will mal sehen was ich so bisher verstanden habe:
Auf der grossen EIDE-Platte hast Du eine primäre Partition für Windows eingerichtet.
Dahinter dann eine erweiterte Partition über die ganze restliche Platte, in der Du mehrere logische Laufwerke angelegt hast.
Soweit in Ordnung.
Wie hast Du die letzten beiden Partitionen angelegt ? Mit fdisk unter Linux oder fdisk unter Dos/Windows. Hat Windows versucht etwas zu formatieren ?

Starte nochmal eine Linux-Installation und kontrolliere gegebenfalls nochmal die Partitionierung. Notfalls lass auch mal e2fsck über die Partitionen laufen. Du sagst es kommen Fehlermeldungen : was sagen sie ?

Grüsse
AndreasM
 

Giuli
Gast





BeitragVerfasst am: 11. Apr 2000 23:56   Titel: Re: SuSe 6.4-Installation: Bitte um Hilfe!

Hallo AndreasM,
ok, ich versuche weiter zu spezifieren:

>Wie hast Du die letzten beiden Partitionen angelegt ? Mit fdisk unter Linux oder fdisk unter Dos/Windows. Hat Windows >versucht etwas zu formatieren ?

Bei der Errichtung der erweiterten Partition hatte ich diese sofort vollkommen in diverse grosse log. Laufwerke eingerichtet (alles mit Windows Fdisk). Diese besagten zwei log. Laufwerke für Win98 waren also z.B. im Explorer sichtbar - ich musste sie nur noch in Win98 dort formatieren, was ich auch tat.

>Starte nochmal eine Linux-Installation und kontrolliere gegebenfalls nochmal die Partitionierung. Notfalls lass auch> >mal e2fsck über die Partitionen laufen. Du sagst es kommen Fehlermeldungen : was sagen sie ?

Die letzte Seite auf dem Bildschirm sieht ca. so aus:

"e2fsck -b 8193 <device>

fsck.ext2 /dev/hda9 failed (status8)! Runt it manually!
fsck.ext2: Device not configured while trying to open /dev/hda10
Possibly non-existent or swap device?

........../dev/hda10....................................
....................................................../dev/hda11
......................................

........../dev/hda11....................................
....................................................../dev/hda12
......................................

........................................................ failed"

(Die Punkte entsprechen dem ersten Absatz mit drei Zeilen - wollte mir Schreibarbeit ersparen. Nur die Device-Angaben waren anderst)

"Can not find a keymap for de-latin-nodeadkeys.map.gz, trying fallback.
Loading keymap Loading /etc/defkeymap.map

fsck faild. Please repair manually and reboot. The root
file system is curently mounted read-only. To remount it
read-write do:
bash # mount -n -o remount,rw/

Attention: Only Control-D will reboot the system in this
maintanance mode. Shutdwon or reboot will not work.

Give root passwort to login:"

----

So, jetzt habe ich noch ein weitere Problem! Plötzlich kann ich die zwei eingerichteten log. laufwerke für Win9x nicht mehr im dortigen Explorer sehen, auch nicht mehr im DOS!!!!! Dummerweise hatte ich dort Daten gespeichert. Weisst du vielleicht, wie man diese log. Laufwerke wieder sichtbar machen bzw. retten kann, damit ich die Daten retten kann?

Ich habe denn Eindruck, dass sich Linux und die zwei log. Laufwerke für Win98 in der erweiterten Partition gegenseitig abgeschossen haben! Kann dies sein? Wenn das echt so ist, dann kann ich wohl meine Daten vergessen!

Wäre dir für ne Antwort/Hilfe sehr dankbar!

Gruss Giuli
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy