Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
SBLive unter RedHat 6.1 (Kernel 2.2.14)

 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Eddie



Anmeldungsdatum: 22.09.1999
Beiträge: 180
Wohnort: Lennestadt

BeitragVerfasst am: 26. Apr 2000 20:14   Titel: SBLive unter RedHat 6.1 (Kernel 2.2.14)

Hi Zusammen!

Hat schon mal jemand die SBLive Value unter RH 6.1 mit Kernel 2.2.14 ans laufen bekommen?

Ich bekomme immer die Fehlermeldung:
insmod: soundcore: o module by that namne found
_________________
Gruß
Eddie
 
Benutzer-Profile anzeigen Private Nachricht senden

MiGo
Gast





BeitragVerfasst am: 27. Apr 2000 18:42   Titel: Re: SBLive unter RedHat 6.1 (Kernel 2.2.14)

Moin

das klappt wie folgt:

Du brauchst auf jeden Fall den emu10k1 Treiber von Creative...

http://opensource.creative.com/

Latest source snapshots --> emu10k1-20000310.tar.gz


Installationsanweisungen fuer Creative EMU10K1 (v0.4)
Deutsche version 1.01
-----------------------------------------------------

Unterstuetzte Karten
--------------------
- Creative Sound Blaster Live!

Eigenschaften
-------------
- Open Sound System (OSS) kompatibel
- Fullduplex Wave Wiedergabe/Aufnahme (/dev/dsp)
- Gleichzeitige Wave playback-streams
- Analog-Mixer (AC97) Support (/dev/mixer)
- Soundstatus Informationen (/dev/sndstat)
- MIDI UART Support (/dev/midi)
- Joystick Support (nur Kernel >= 2.2.x)
- Unterstuetzt mehrere EMU10K1-basierte Karten

System-Anforderungen
--------------------

- Der Kernel muss wie folgt kompiliert sein:
- mit Unterstuetzung fuer Kernel-Module
(loadable modules support) (CONFIG_MODULES = y)
- mit Soundkarten-Support als Modul
(soundcard support as a module) (CONFIG_SOUND = m)
- Ohne integrierte Soundkarten-Treiber (CONFIG_SOUND_* = n)
- "PnP-compatible OS installed" Option muss im BIOS ausgeschaltet sein
- Empfohlene System-Konfiguration: Mind. 200 Mhz Pentium-kompatibler
Prozessor mit 32 MB RAM

Installation
------------

1. Bestimme das Verzeichnis, in welchem Sound-Module installiert werden
(normalerweise /lib/modules/2.x.y/misc)
2. Entpacke das Archiv emu10k1-xy.tar.gz
(tar -xvzf emu10k1-xy.tar.gz)
3. Kompiliere den Treiber
(cd emu10k1 && make)
4. Kopiere den Treiber (emu10k1.o) in das Modul-Verzeichnis
(z.B. cp emu10k1.o /lib/modules/2.x.y/misc/emu10k1.o)
5. Entlade alle existierenden Soundkarten-Treiber, inklusive soundcore
(z.B. rmmod sb soundcore)
6. Entferne alle alten Referenzen auf andere Soundkarten in /etc/conf.modules
7. Erstelle eine neue Referenz in /etc/conf.modules auf den neuen Treiber:
(z.B. "alias sound emu10k1" oder "alias char-major-14 emu10k1")
8. Ist der Kernel mit Versions-Informationen kompiliert, fuege folgendes
an den vorherigen Eintrag an:
pre-install emu10k1 insmod soundcore
post-remove emu10k1 rmmod soundcore
9. Erstelle mit depmod -a die neuen Abhaengigkeits-Informationen
10. lade den Treiber
(modprobe emu10k1)

Joystick-Support
----------------

1. Lade den Treiber mit dem Parameter "joystick=0x200"
(z.B. insmod emu10k1 joystick=0x200)
2. Lade den Basis-Joystick-Treiber
(insmod joystick)
3. Lade den jeweiligen Joystick-Treiber
(z.B. insmod joy-analog (fuer analoge Joysticks))

Dann sollte es klappen

MFG
 

Eddie



Anmeldungsdatum: 22.09.1999
Beiträge: 180
Wohnort: Lennestadt

BeitragVerfasst am: 27. Apr 2000 20:07   Titel: Re: SBLive unter RedHat 6.1 (Kernel 2.2.14)

Hi!

Danke für deine Antwort!

Genauso steht's ja auch im README zu den Treibern und genauso habe ich's auch gemacht.

Funktioniert allerdings trotzdem nicht... Leider!!!
_________________
Gruß
Eddie
 
Benutzer-Profile anzeigen Private Nachricht senden

MiGo
Gast





BeitragVerfasst am: 28. Apr 2000 7:22   Titel: Re: SBLive unter RedHat 6.1 (Kernel 2.2.14)

Moin,

dann erklär Deine FM mal bitte genauer, wobei erhält Du sie? Sicherlich beim Starten (Booten), oder? --> Hast Du den Kernel auch richtig übersetzt? Schreib noch alles etwas genauer, bei mir läuft die Karte nämlich super.

MiGo
 

Eddie



Anmeldungsdatum: 22.09.1999
Beiträge: 180
Wohnort: Lennestadt

BeitragVerfasst am: 29. Apr 2000 11:01   Titel: Re: SBLive unter RedHat 6.1 (Kernel 2.2.14)

Hi!

Jetzt funktionierts plötzlich!

Habe sowohl Kernel als auch EMU-Modul nochmal kompiliert, jetzt läuft das Teil... Komische Sache!!!

Hat jemand von euch MIDI schon irgendwie ans Rennen bekommen?
_________________
Gruß
Eddie
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy