Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Adaptec 2940 UW nimmt den Scanner/zip nicht, ....

 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
haegar
Gast





BeitragVerfasst am: 03. Mai 2000 23:48   Titel: Adaptec 2940 UW nimmt den Scanner/zip nicht, ....

Hi,

hatte weiter unten das selbe gepostet und leider keine Antwort erhalten.
Meine config:
p-200, 96 MB Ram, 2x 4,5 GB HD UW-SCSI, CD-ROM und Teac CD-R 55 S
(als interne devices)
Mein Problem:
Sobald ich den Scanner (Mustek SP12000 SCSI) an den äußeren Port des Adaptec hänge bekomme ich die Meldung 0x20, hänge ich dann zusätzlich noch das SCSI-Zip (ebenfalls extern) dran lautet die Meldung 0x80.
Die Geschichte ist korrekt terminiert (CD-ROM und Scanner bzw. ZIP) und in Windows-Zeiten lief das ganze mit den Einstellungen.
Distribution ist RH 6.1 (jetzt 6.2), vorher Mandrake 7.0 (jeweils mit kernel 2.2.14).
Eine Anfrage bei Adaptec ergab, dass man mir nicht helfen könne, da ich seit Ende März keinen Support mehr erwarten könne. Gleichzeitig bot man mir an, die Supporthotline zu kontaktieren für lächerliche 35 $ pro Anruf.... Gut dass ich auf so ein renommiertes Markenprodukt gesetzt habe (ist sicherlich das letzte mal gewesen, liebe Firma ADAPTEC) (
In den RedHat-Sites habe ich auch gewühlt und bin dabei auch "Fündig" geworden und zwar in dem Listing für den SCSI-Source-Code für den Treiber. Dort stand folgendes:

blabla
---------------------

The 'driver_status' field is always output. When ('driver_status' &
DRIVER_SENSE) is true the 'sense_buffer' is also output. A copy of these
defines can be found in sg_err.h (see the utilities section):
#define DRIVER_OK 0x00 /* Typically no suggestion */
#define DRIVER_BUSY 0x01
#define DRIVER_SOFT 0x02
#define DRIVER_MEDIA 0x03
#define DRIVER_ERROR 0x04
#define DRIVER_INVALID 0x05
#define DRIVER_TIMEOUT 0x06
#define DRIVER_HARD 0x07
#define DRIVER_SENSE 0x08 /* Implies sense_buffer output */
/* above status 'or'ed with one of the following suggestions */
#define SUGGEST_RETRY 0x10
#define SUGGEST_ABORT 0x20
#define SUGGEST_REMAP 0x30
#define SUGGEST_DIE 0x40
#define SUGGEST_SENSE 0x80
---------------------------------
blabla

leider konnte ich mit den Zeilen überhaupt nix anfangen (hab auch schon länger nich mehr programmiert, und schon gar nicht Hardware).

Vielleicht weiss diesmal jemand


H I L F Ä Ä Ä Ä Ä Ä Ä Ä !!!!!!


Danke im Voraus !

cya

Haegar
 

KlausL
Gast





BeitragVerfasst am: 04. Mai 2000 6:38   Titel: Re: Adaptec 2940 UW nimmt den Scanner/zip

Hallo,
ich habe eine ähnliche konfiguration wie du:
Adaptec 2940 (7)
intern :
0 = FP
1 = FP
3 = FP
4 = CDROM (terminiert)
6 = Brenner
extern:
2 = Scanner
5 = Zip (terminiert)

und bei mir hatte ich noch nie probleme.
wie siehts denn mit der kabellänge aus ??
ich habe bemerkt Linux nimmt´s mit hardware sehr genau, du solltest die max. kabellänge nicht überschreiten.

prüfe auch mal die einstellung im SCSI - bios
und schalte die autoterminierung aus.
 

Jochen
Gast





BeitragVerfasst am: 05. Mai 2000 8:41   Titel: Re: Adaptec 2940 UW

Jepp, ich tippe ebenfalls auf Kabellänge. Bei Ultra-SCSI single-ended und mehr als 3 angeschlossenen Geräten (mit Controller? Ohne? Weiss ich jetzt nicht genau) ist die Maximallänge des Kabels auf 1,5 m festgelegt. Wenn man sich ein "ausbaufähiges" SCSI-Kabel mit 8 Steckern in den Rechner eingebaut hat, ist die Maximallänge meist schon erreicht, und alles was man dann aussen anschliesst, wird zuviel. Adaptec ist da nach meiner Erfahrung auch vergleichsweise empfindlich.

Alternativ wäre da noch eine fiese Möglichkeit: Die externe Adaprec-Buchse ist wide, die Anschlüsse der externen Geräte mit einiger Sicherheit narrow. Bist Du sicher, dass der Controller eine HIGH-Terminierung einstellt bzw. Dein externes Kabel die HIGH-Terminierung übernimmt?
 

haegar
Gast





BeitragVerfasst am: 11. Mai 2000 14:26   Titel: Adaptec 2940 UW nimmt den Scanner/zip nicht, ....

Problem gelöst
Fehler war eigentlich recht einfach (aber ohne Hilfe aus linuxforen.de, hätt ich mich totgesucht).
Die High-Bits waren nicht terminiert.... Danach hat er die Platten durcheinandergeworfen und wollte nicht mehr booten, deshalb von Hand die /etc/fstab geändert und schon lief die Kiste wieder.
Vielen Dank auch noch an die antwortenden hier im Forum.

Gruss

Haegar
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy