Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
/dev/lp1

 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Sebastian Pfohl
Gast





BeitragVerfasst am: 23. Mai 2000 12:48   Titel: /dev/lp1

Hallo

Ich habe hier ein Problem mit einem Drucker. Und zwar möchten wir hier gerne zwei Drucker installieren, einen Lase4rjet auf Parallelport 1 (dev/lp0) und den anderen (Tinte) auf Parallelport 2 (/dev/lp1). Beide Drucker funktionieren bestens auf Parallelport 1. Sobald ich aber einen Drucker auf Parallelport 2 installiere wird die zu druckende Datei zwar gespullt aber nicht auf dem Drucker ausgegeben. Die Schnittstellenkarte wird aber beim hochfahren (vor dem booten von Linux) korrekt auf der Adresse 0x278 angezeigt. Im Moment ist SuSE 6.3 installiert.
 

zwatz



Anmeldungsdatum: 19.04.2000
Beiträge: 144
Wohnort: OOE

BeitragVerfasst am: 23. Mai 2000 14:32   Titel: Re: /dev/lp1

hi,
ist /dev/lp1 eine zusätzliche Schnittstellenkarte und auch in /etc/conf.modules erfasst ?
Hab grad kein Linux zur Hand, aber schau mal unter /proc ob auch beide LPT Ports initialisiert wurden; auch /var/log/messages gibt vielleicht Aufschluss.

mfg
Thomas
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Jochen
Gast





BeitragVerfasst am: 23. Mai 2000 14:34   Titel: Re: /dev/lp1

Schau mal unter /usr/src/linux/Documentation/parport.txt nach, vielleicht hilft Dir das ja weiter. Dazu müssen allerdings die Kernelsourcen installiert sein.
 

Sebastian Pfohl
Gast





BeitragVerfasst am: 23. Mai 2000 15:50   Titel: Re: /dev/lp1

Unter /proc/parport gibt es leider nur das Verzeichniss /0 . /1 was ja für Parallelport 2 zuständig wäre exisitiert nicht und ich kann es auch nicht per Hand anlegen. Ich bekomme jedesmall die Meldung das Verzeichniss existiere schon. Muss ich wirklich im Kernel extra ein Modul einstellen ? Ich habe dummerweise keine Kernelsourcen installed und die CD's stehen auch nicht mehr zur Verfügung.
Im Verzeichniss /0 stehen alle notwendigen Dateien zum einstellend es Druckers drinnen nur halt ein Verzeichniss /1 gibt es nicht und es wird auch nicht anegelegt wenn ich mit yast1 einen drucker hinzufügen möchte.
 

zwatz



Anmeldungsdatum: 19.04.2000
Beiträge: 144
Wohnort: OOE

BeitragVerfasst am: 23. Mai 2000 16:15   Titel: Re: /dev/lp1

aha, hast du /etc/conf.modules gecheckt ?
bei SuSE sind die Angaben für die zweite parallele Schnittstelle dort angegeben, du musst nur die Werte an deine Gegebenheiten anpassen.
Die I/O Werte findest du unter /proc (pci ...).

mfg
Thomas
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Sebastian Pfohl
Gast





BeitragVerfasst am: 24. Mai 2000 13:34   Titel: Re: /dev/lp1

hmm soweit hab ich das jetze in den conf.modules eingestellt, daraufhin gibts auch einen eintrag unter /proc/parport/1. aber wenn ich auf lp1 drucken möchte wird dennoch auf lp0 gedruckt, und wenn ich auf lp0 drucke geht auch ales auf lp0 logischwerweise, was könnte da noch falsch sein ?
 

zwatz



Anmeldungsdatum: 19.04.2000
Beiträge: 144
Wohnort: OOE

BeitragVerfasst am: 24. Mai 2000 14:00   Titel: Re: /dev/lp1

hi,
ist auch in /etc/printcap die Druckerschnittstelle richtig angegeben ?

Thomas
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

sebastian Pfohl
Gast





BeitragVerfasst am: 24. Mai 2000 14:21   Titel: Re: /dev/lp1

hier mal meine derzeitige /etc/printcap:

ascii|lp1|bj200-a4-ascii-mono-360|bj200 a4 ascii mono 360:\
:lp=/dev/lp1:\
:sd=/var/spool/lpd/bj200-a4-ascii-mono-360:\
:lf=/var/spool/lpd/bj200-a4-ascii-mono-360/log:\
:af=/var/spool/lpd/bj200-a4-ascii-mono-360/acct:\
:if=/var/lib/apsfilter/bin/bj200-a4-ascii-mono-360:\
:la@:mx#0:\
:tr=:cl:sh:sf:
#
lp|lp2|bj200-a4-auto-mono-360|bj200 a4 auto mono 360:\
:lp=/dev/lp1:\
:sd=/var/spool/lpd/bj200-a4-auto-mono-360:\
:lf=/var/spool/lpd/bj200-a4-auto-mono-360/log:\
:af=/var/spool/lpd/bj200-a4-auto-mono-360/acct:\
:if=/var/lib/apsfilter/bin/bj200-a4-auto-mono-360:\
:la@:mx#0:\
:tr=:cl:sh:sf:
#
raw|lp3|bj200-a4-raw|bj200 a4 raw:\
:lp=/dev/lp1:\
:sd=/var/spool/lpd/bj200-a4-raw:\
:lf=/var/spool/lpd/bj200-a4-raw/log:\
:af=/var/spool/lpd/bj200-a4-raw/acct:\
:if=/var/lib/apsfilter/bin/bj200-a4-raw:\
:la@:mx#0:\
:tr=:cl:sh:sf:
#
### END apsfilter: ### bj200 a4 mono 360 ###
### BEGIN apsfilter: ### laserjet a4 mono 300 ###
# Warning: Configured for apsfilter, do not edit the labels!
# apsfilter setup Wed May 24 14:53:31 CEST 2000
#
laserjet-ascii|lp4|laserjet-a4-ascii-mono-300|laserjet a4 ascii mono 300:\
:lp=/dev/lp0:\
:sd=/var/spool/lpd/laserjet-a4-ascii-mono-300:\
:lf=/var/spool/lpd/laserjet-a4-ascii-mono-300/log:\
:af=/var/spool/lpd/laserjet-a4-ascii-mono-300/acct:\
:if=/var/lib/apsfilter/bin/laserjet-a4-ascii-mono-300:\
:la@:mx#0:\
:tr=:cl:sh:sf:
#
laserjet|lp5|laserjet-a4-auto-mono-300|laserjet a4 auto mono 300:\
:lp=/dev/lp0:\
:sd=/var/spool/lpd/laserjet-a4-auto-mono-300:\
:lf=/var/spool/lpd/laserjet-a4-auto-mono-300/log:\
:af=/var/spool/lpd/laserjet-a4-auto-mono-300/acct:\
:if=/var/lib/apsfilter/bin/laserjet-a4-auto-mono-300:\
:la@:mx#0:\
:tr=:cl:sh:sf:
#
laserjet-raw|lp6|laserjet-a4-raw|laserjet a4 raw:\
:lp=/dev/lp0:\
:sd=/var/spool/lpd/laserjet-a4-raw:\
:lf=/var/spool/lpd/laserjet-a4-raw/log:\
:af=/var/spool/lpd/laserjet-a4-raw/acct:\
:if=/var/lib/apsfilter/bin/laserjet-a4-raw:\
:la@:mx#0:\
:tr=:cl:sh:sf:
#
### END apsfilter: ### laserjet a4 mono 300 ###
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy