Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Squid klappt, aber....

 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Norbert
Gast





BeitragVerfasst am: 09. Jun 2000 15:03   Titel: Squid klappt, aber....

Hallo,

habe fast das gleiche Problem wie weiter unten, aber bei mir klappt das alles seit langem das Squid läuft und ich mich wunderbar ins Internet einloggen kann......
....aber!!
Jetzt soll Squid weg und ich will den ehemaligen Proxy als einfachen Router ins Internet verwenden!!!
Wenn ich Squid einfach stoppe und bei meinen Win-Rechnern dann den DNS von meinem Provider angebe und als Gateway den Pinguin, wählt er sich auch ganz klasse ein.....aber ich bekomme meine Antwort von dem Webserver d.h. ich kriege keine Seiten angezeigt!!
Wer weiss was??
Verwende Suse 6.3 mit einer Fritz PCI

Danke und Gruss

Norbert
 

cptchaos



Anmeldungsdatum: 06.06.2000
Beiträge: 129

BeitragVerfasst am: 09. Jun 2000 15:54   Titel: Re: Squid klappt, aber....

Hallo Norbert,

Das ganze kann so leider nicht ohne weiteres Funktionieren. Du hast für dein internes Netzwerk (hoffentlich) eine IP aus dem frei verfügbaren Adresseraum gewählt, z.B. 192.168.x.x . Pakete mit solchen Adressen werden im Internet nicht weitergeleitet, da es sonst zu einem Chaos kommen würde. Das heißt dein Gateway versucht die Verbindung zur entsprechenden Site aufzubauen, bekommt diese Verbindung aber nicht hin. Im Internet müssen alle Host´s eine eigene IP haben, deine wird Dir bei der Einwahl dynamisch vom Provider zugewiesen, mit dieser ist dein Rechner dann ereichbar und ihm können Datenpakete ereichen. Rechner die hinter diesen Server liegen sind leider nicht erreichbar ! Der Trick bei der ganzen Geschichte ist der Site, die man ereichen möchte, vorzugaukeln die Datenpakete kommen vom Gateway und nicht vom Host hinter dem Gateway. Dann wird die Site die entsprechenden Datenpakete deinem Gateway schicken, und dieser muß diese dann sortieren und an den Enstprechenden Host hinter dem Gateway weiterleiten. Das ganze nennt man Masquering, die einfachste Möglichkeit ist die Verwendung eines Proxy´s. oder man konfiguriert auf dem Gateway einen Firewall mittels IPChains. Das Ganze wurde in Pro-Linux auch in einem extra Artikel mit Beispielkonfiguration abgehandelt, suche einfach mal nach Firewall. Bei einfachen (Einseite Verbindung) Protokollen wie HTTP funktioniert dieses relativ gut, leider sind aber viele Dienste im Internet nicht einseitig, z.B. FTP, Telnet, IRC, Realvideo, SSL ... Für diese Dienste müßte dann doch wieder ein Proxy in den Firewall integriert werden, und das kann ganz schön Frusten.

Mein Tip: Bleib bei Squid, und besorge dir für Dienste die Squid nicht unterstützt entsprechende Proxy´s.

MfG Marek Walther
_________________
.... das gehört bei uns zum Service.
Ich brauche jetzt nur noch Ihre Keditkartennummer ....
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

killerhippy



Anmeldungsdatum: 19.05.2000
Beiträge: 529

BeitragVerfasst am: 09. Jun 2000 18:43   Titel: Re: Squid klappt, aber....

oder aktiviere *ipchains* für's masqerading Smile
_________________
Es gibt keine dumme Fragen!

Killerhippy
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Norbert
Gast





BeitragVerfasst am: 09. Jun 2000 21:39   Titel: Re: Squid klappt, aber....

Hallo ihr beiden,

vielen Dank erstmal, aber leider muss ich euch sagen das ich das von euch beschriebene schon kenne....
Der Tip: Bleib bei Squid ist schon klasse, folgendes belastet mich dabei aber sehr stark, deshalb will ich ja einen Umstieg.....ich will meine Mails über den Pinguin auch abfragen!
Das Problem ist dabei das ich meine Mails mit Outlook verwalte, leider gibt es noch keine alternative unter Linux!!!
Das ganze soll im Endausbau über das Laptop laufen, das als Grudnsystem Linux hat und dann aufgesetzt VMWare mit verschiedenen Windoof Installationen!
Wenn ich nun aber zu Hause bin und mein Laptop im internen Netz habe (192.168.0.1 - 200 / 24/) dann sollen die Mails über den "festen" Pinguin abgefragt werden!
Wie bekomme ich die Ports zusätzlich freigeschaltet??? So das ich meinen POP und SMTP- Server erreiche?
Der derzeitige Gateway ist wie schon einmal bemerkt mit SuSE 6.3 /Squid/Fritz PCI/EthernetKarte konfiguriert.

Klappt www-mässig ja auch alles Klasse, aber wie bekomme ich die beiden Ports frei?

Gruss Norbert
 

killerhippy



Anmeldungsdatum: 19.05.2000
Beiträge: 529

BeitragVerfasst am: 09. Jun 2000 22:26   Titel: Re: Squid klappt, aber....

makes me wonder...

ipchains mit firewall.sh (freshmeat)
-> null problemo

squid: wieso sollte ein proxy ports sperren, wenn man ihm das nicht extra beibringt? Schließlich ist er ja quasi nur n Cache, wenn die Info nicht da ist oder obsolete, holt er sie einfach. Oder ist das jetzt naiv?
_________________
Es gibt keine dumme Fragen!

Killerhippy
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

cptchaos



Anmeldungsdatum: 06.06.2000
Beiträge: 129

BeitragVerfasst am: 09. Jun 2000 23:00   Titel: Re: Squid klappt, aber....

Hallo Norbert,

Ich gehe mal davon aus, das Du die E-Mails auf deinen Schlepptop über den Gateway (fester Pinguin) von deinem Mailhoster im Internet laden möchtest.

Wenn dem so ist dann tritt hierbei das masquerading Problem auf !
Der Rechner kommt nicht raus.
SMPT liegt hierbei auf Port 25.
und POP auf Port 110.

Für diese Ports bietet Squid soweit mir bekannt keine proxy Dienste an.
Ich bin mir jetzt auch noch nicht so ganz sicher ob sich dieses Problem mittels IPchains masquarading lösen läst, werde dieses morgen einmal ausprobieren.

Das Verschicken der E-Mails sollte aber kein Problem darstellen, wenn Du auf dem Gateway (fester Pinguin) Sendmail konfigurierst und zum laufen bringst. Dann gibst Du dem Schlepptop als SMPT Server zur Mailauslieferung den Gateway an. Und wenn dieser danach richtig konfiguriert ist (auch DNS abfragen) sollter er die Mails direkt ausliefern (nicht über deinen Mailhoster, geht wenn gewünsch aber auch) oder in seiner Warteschlage ablegen (bei offline Betrieb).

POP Abfragen sehen dabei schon schlechter aus.

Ich mache das bei mir so das mein Gateway alle E-Mail Konten abfragt und alle Mails holt (cron, Fetchmail). Dann habe ich noch einen POP Server auf dem Gateway installiert, diesen findest du bei SuSE unter N leicht versteckt. Und meine Clients holen sich dann ihre E-Mails mittes POP vom Gateway ab, dazu benötigen sie einen normalen Benutzeraccount auf dem Gateway.

Mir ist damals leider auch keine andere Lösung eingefallen ?
Aber wir arbeiten daran.

MfG Marek Walther
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Norbert
Gast





BeitragVerfasst am: 10. Jun 2000 0:01   Titel: Re: Squid klappt, aber....

Hallo Marek,

das Problem ist einmal, das wenn ich zu Hause bin über den festen Pinguin gehe, da ich aber mehr unterwegs bin und meine Mails über GSM abfrage, halt von Windows über VMWare über den "mobilen"Pinguin gehe und meine Mails abholen will.....muss....
Daher auch keine Lösung mit Sendmail......habe das auch schon einmal in betracht gezogen aber dann kommt die Einwahl bei mir zu Hause dazu.....Preislich fast das gleiche, aber wenn ich dann noch was im I-net nachschauen will dann kommt da die zweite Rechnung....einmal per GSM zum Heimischen Pinguin und dann von da ins I-net.....naja bei Flatrate nicht ganz sooooo wild.....
Daher suche ich halt eine Lösung, ganz einfach (wenn es das in der EDV gibt ) einen Router hinzu zimmern, der bei allem aufmacht was kommt!!!! Egal ob SMTP oder Http oder sonst was.....die Sicherheit kommt dann erst.....mit NAT oder masqerading muss das doch gehen?!
Wenn ich vom festen Pinguin einen Ping oder auch Traceroute absetze dann klappt das ja auch alles wunderbar....aber von den Windows und Linux und Solaris Büchsen nicht......


Gruss Norbert
 

Michael Flaig
Gast





BeitragVerfasst am: 10. Jun 2000 10:22   Titel: Re: Squid klappt, aber....

Hm ... also ich versteh das Problem nicht ganz. Squid soll weg ! - Ist das richtig !?
Dann werfen wir squid weg !

Dann nehmen wir die Anleitung für einen Gateway Server von Pro-Linux, da du ja ne SuSE Büchse hast ...

Wenn das alles gemacht ist, dann gehts einwandfrei mit dem Gateway. Normalerweise keine Probleme ...

Ich habe das so hier laufen. Meine Firewall ist halt nicht eingestellt. Die macht nur das was von SuSE standardmäßig eingestellt wird. ALLOW all und ein paar forward und masquarading dienste. Das ist alles. Kein Sperren von Ports oder so ...

Ich habe ein paar Dienst deaktiviert, die ich nicht benötigt habe. Aber eigentlich läuft alles in der SuSE Standard Konfig ...

Für das was du machen willst brauchst du einen Gateway Rechner, der alles maskiert, was rausgeht.

Gruß,

Michael
 

Norbert
Gast





BeitragVerfasst am: 10. Jun 2000 20:27   Titel: Re: Squid klappt, aber....

Danke an alle......die mir helfen wollten.....!

Was nutzt der Tiger im Tag wenn der Esel am steuer sitzt ????
Wenn man das Firewall Paket aus der Sec "Abteilung" nicht installiert sondern nur ipchains und ipf.... dann klappt das mit dem Gateway nie!!!!
Das es über Squid geklappt hat ist klar......
Also ganz einfach das Firewall Paket installiert, susefirwall gestartet und noch ein paar sachen für die Sicherheits elbst konfiguriert und schon geht das!!!!

Also nochmal danke den Weg den ihr mir gemeinsam gezeigt habt war gut und meine Zweifel an Linux sind auch wieder behoben


Gruss Norbert
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy