Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Kdat-Backup
Gehen Sie zu Seite 1, 2  Weiter
 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Welle
Gast





BeitragVerfasst am: 04. Jul 2000 9:28   Titel: Kdat-Backup

Ich mache (besser gesagt machTE) Backups mit Kdat, einem Frontend, das bei Suse Linux 6.3 dabei war.
Nun möchte (muß) ich Daten wiederherstellen und stelle fest, daß das Programm zwar eine Restorefunktion hat, sie aber nicht funktioniert. Die Backups habe ich auf ein SCSI-Bandlaufwerk gemacht, das unter dev/st0 angesprochen wird.
Kdat behauptet, als Backupbefehl tar zu verwenden, aber mit tar komme ich nicht an die Dateien heran.
Dringlichste Frage: Wie komme ich an meine Daten heran?
 

Jochen
Gast





BeitragVerfasst am: 04. Jul 2000 10:34   Titel: Re: Kdat-Backup

Was heisst: Du kommst nicht an die Daten dran? Welche Fehlermeldung liefert tar? Ggf. setzt KDat eine spezielle Blockgröße. An der Kommandozeile kann die mittels
mt -f /dev/st0 setblk size
eingestellt werden, mit size = 0 zum Aufheben jedweder Blockung.
 

Jochen
Gast





BeitragVerfasst am: 04. Jul 2000 10:35   Titel: Re: Kdat-Backup

Was heisst: Du kommst nicht an die Daten dran? Welche Fehlermeldung liefert tar? Ggf. setzt KDat eine spezielle Blockgröße. An der Kommandozeile kann die mittels
mt -f /dev/st0 setblk size
eingestellt werden, mit size = 0 zum Aufheben jedweder Blockung.
 

Welle
Gast





BeitragVerfasst am: 04. Jul 2000 12:59   Titel: Re: Kdat-Backup

Ich habe folgendes versucht:
tar tf /dev/st0
die tar-Fehlermeldung ist:
Hmm, this doesn't look like a tar archive
und dann
Skipping to next file header
woraufhin wieder die Kommandozeile blinkt.

Mit mt -f /dev/st0 setblk 0 erhalte ich folgendes Ergebnis:
Input/output error

Ich weiß, vielleicht stelle ich mich wirklich blöd an, aber wenn ich Programmierer wär, würd ich Backups nicht über ein grafisches Frontend wie Kdat machen.
 

Klaus
Gast





BeitragVerfasst am: 04. Jul 2000 13:32   Titel: Re: Kdat-Backup

Kann es sein, dass Kdat die Archive nicht nur zusammenfuegt und somit Archiviert, sondern auch packt?
Versuche mal die Dateien mir folgendem Befehl zu restaurieren:

Fuer Gzip:
tar tfz /dev/st0

Oder fuer BZip2:
tar tfI /dev/st0

Muesste alo jetzt rein theoretisch klappen...

Klaus
 

Welle
Gast





BeitragVerfasst am: 04. Jul 2000 15:52   Titel: Re: Kdat-Backup

bei tar tfz bekomme ich folgende Meldung
gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error exit delayed from previous errors

bei tar tfi erscheint wieder
tar: Hmm, this doesn't look like a tar archive

Da ja die Meldung kommt, daß es nicht wie ein tar archiv aussieht, scheint ja aber immerhin was auf dem Band drauf zu sein. Weil, wenn ich mit Kdat zurückspielen will macht der mir nur ein paar leere Ordner (beim Backup war er aber einige Stunden beschäftigt)
 

Jochen
Gast





BeitragVerfasst am: 05. Jul 2000 10:00   Titel: Re: Kdat-Backup

Dann muss jetzt erst mal herausgefunden werden, was eigentlich auf dem Band drauf ist. Entweder
file -s /dev/st0
oder
dd if=/dev/st0 of=/tmp/tapeblocks bs=512 count=4

file /tmp/tapeblocks
sollten die entsprechende Auskunft 'rausrücken.
 

Welle
Gast





BeitragVerfasst am: 06. Jul 2000 8:46   Titel: Re: Kdat-Backup

Immerhin keine Fehlermeldung!

dd if=/dev/st0 of=/tmp/tapeblocks bs=512 count=4 nennt als Ergebnis
4+0 records in
4+0 records out

file /tmp/tapeblocks führt zu
/tmp/tapeblocks: ASCII text

Und der Texteditor bringt mir dann sage und schreibe folgenden Dateiinhalt:

KDatMAGIC

Kann man damit was anfangen, oder heißt das, daß außer diesem Spruch nix auf dem Band ist?
 

Jochen
Gast





BeitragVerfasst am: 06. Jul 2000 14:31   Titel: Re: Kdat-Backup

Grumpf, dass heisst, dass KDat erstmal eine eigene Kennung auf das Band geschrieben hat. Wahrscheinlich, damit es eigene Bänder erkennen kann. Wenn es denn tatsächlich mit tar sichert, kann das eigentliche tar-Archiv nur hinter dem ersten "Kennungs"-File liegen. Also:

Lege das Band ein und tippe erstmal vorsichtshalber
mt -f /dev/nst0 rewind
damit das band auch sicher am Anfang steht. Dann ein
mt -f /dev/nst0 fsf
dann überliest das Drive das erste File auf dem Band. Dann das gleiche Kommando noch mal, damit wird dann der File-Ende-Marker überlesen und das Tape steht am Anfang des nächsten Files. Dann probier wieder die dd/file-Kombi von oben. Wenn Du Glück hast, sagt er jetzt etwas von wegen "tar-Archiv". Falls ja, die mt-Kommandos wiederholen (alle, auch das rewind!) und mittels tar das Archiv auslesen.

Sollte es nicht klappen (nach dem ersten File auf dem Tape ist nix mehr weiter drauf), hat KDat das tar-Archiv direkt an seine Kennung angehängt. Dann einfach den gesamten Band-Inhalt mittels
dd if=/dev/st0 of=/tmp/mytape bs=512
auf Platte knallen und mittels hexdump nach der tar-Kennung suchen. Den ersten Teil bis dahin abschneiden und dann /tmp/myfile mittels tar auspacken. Aber probier erst mal den ersten Tip...
 

Welle
Gast





BeitragVerfasst am: 10. Jul 2000 9:02   Titel: Re: Kdat-Backup

das mit dem
mt -f /dev/st0 rewind
geht nicht. Da bekomme ich die Meldung
mt: /dev/st0 is not a character special file

Um Möglichkeit 2 zu testen, muß ich erst mal Platz auf der Platte schaffen. Über Top oder Flop werde ich Bescheid geben.

Oder hat jemand noch ne Idee, wie man die Daten auf dem Band rankommen kann?
 

Jochen
Gast





BeitragVerfasst am: 10. Jul 2000 9:33   Titel: Re: Kdat-Backup

Was denn?!? /dev/st0 ist kein character special file?!? Da muss man nachfassen. Erst mal ein
ls -l /dev/st0
Das erste Zeichen muss ein "c" sein! Wenn es ein "-", wurde Dir irgendwie die Gerätedatei durch eine normale Datei ersetzt. Für den Fall des Falles: Erstelle Dir einfach mittels
mknod -m 0600 /dev/meintape c 9 0
eine neue Gerätedatei und versuch die o.a. mt-Kommandos mit /dev/meintape statt /dev/st0. Allerdings kann es dann sein, dass auf Deinem Tape eigentlich gar nix drauf ist, weil KDat immer ein eine normale Datei im dateisystem gesichert hat...

Viel Erfolg!
 

Welle
Gast





BeitragVerfasst am: 10. Jul 2000 19:14   Titel: Re: Kdat-Backup

ls -l/ dev/st0 ergigt
crw-rw---- 1 root disk 9, 0 Now 8 1999 /dev/st0

dafür bekomme ich nun bei
mt -f dev/nst0 rewind die Meldung
mt: dev/nst0: No such file or directory

irgenwie schein mir da irgendwas nicht zu stimmen?????
 

Jens
Gast





BeitragVerfasst am: 11. Jul 2000 9:39   Titel: Re: Kdat-Backup

Hallo

schau mal nach ob überhaupt das st (scsiTape) Modul geladen ist 'lsmod'.
Hast du evll. am Kernel gespielt?

Jens
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 11. Jul 2000 9:49   Titel: Re: Kdat-Backup

Hi,

ganz klar: nicht dev/nst0, sondern
/dev/nst0

Der feine Unterschied liegt im ersten Slash...

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Jochen
Gast





BeitragVerfasst am: 11. Jul 2000 13:47   Titel: Re: Kdat-Backup

Jens: Sollte das SCSI-Tape-Modul nicht geladen sein (oder der Kernel einfach keine Unterstützung dafür bieten, da nicht fix einkompiliert oder so), lautet die Fehlermeldung "No such device". Schliesslich ist der eigentliche Treiber, den man über ein device file wie /dev/st0 ansprechen will, nicht vorhanden.

Ansonsten hat hjb recht, bei dem mt-Kommando fehlt vorneweg das "/". Wenn man nicht zufällig in / steht, funktioniert das nicht.

> das mit dem
> mt -f /dev/st0 rewind
> geht nicht. Da bekomme ich die Meldung
> mt: /dev/st0 is not a character special file

Das verstehe ich jetzt nicht. Welle, bist Du sicher, dass Du Dich nicht bei der Eingabe vertippt hast? So, wie es da steht, ist es korrekt, und /dev/st0 ist ein character special file, wie Du ja durch die "ls -l"-Angabe bewiesen hast. Poste hier mal die Ausgabe von
ls -l /dev/st*
Vielleicht hast Du aus Versehen Dateien unter /dev angelegt, die bei Vertippern (Buchstabe O/o statt Null?) gesehen werden?
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy