Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
kernel-modul-problem

 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
sellmi
Gast





BeitragVerfasst am: 11. Jul 2000 13:37   Titel: kernel-modul-problem

ich habe schon wieder ein problem,
ich habe mir den kernel 2.2.16 geholt entpackt kompeliert und installiert [make modules, make modules_install)
beim booten jedoch werden die module nicht mehr gestartet und nicht funktioniert mehr. ob wohl das verzeichnis /lib/modules/2.2.16 steht.

muss ich noch irgendwo etwas eintragen damit die 2.2.16 module gestartet werden
 

Jochen
Gast





BeitragVerfasst am: 11. Jul 2000 13:52   Titel: Re: kernel-modul-problem

Mach mal ein
cat /proc/version
Die Ausgabe muss dann die Version 2.2.16 enthalten. Weiterhin ist die Zeitangabe der Kompilierung ein wertvoller Hinweis, ab hier überhaupt Dein neuer Kernel läuft oder ob Du immer noch den alten bootest. Sollte tatsächlich der neue Kernel laufen, versuch mal ein
depmod -a
Damit sollte dann die Datei /lib/modules/2.2.16/modules.dep erstellt worden sein. Die braucht modprobe, um Abhängigkeiten von Modulen untereinander auflösen zu können.
 

sellmi
Gast





BeitragVerfasst am: 11. Jul 2000 14:22   Titel: Re: kernel-modul-problem

wenn ich cat /proc/version eingebe erscheint 2.2.16
und die datei modules.deb ist auch vorhanden doch das hilft mir leider alles nicht weiter
 

Jochen
Gast





BeitragVerfasst am: 11. Jul 2000 14:50   Titel: Re: kernel-modul-problem

Tjaaa, dann must Du wohl oder übel ein paar Informationen mehr rausrücken . Also:

Welche Distribution? Welche Fehlermeldung von welchem Programm? Welche Treiber sind explizit als Modul kompiliert, lassen sich aber nicht laden? Kann der Treiber nicht automatisch geladen werden, aber händisch schon? Oder wird der Treiber geladen, aber das Gerät funzt nicht?

Fragen über Fragen...
 

sellmi
Gast





BeitragVerfasst am: 11. Jul 2000 18:44   Titel: Re: kernel-modul-problem

suse 6.2 mit kernel 2.2.10
beim boot mit kernel 2.2.16 werden il4, network und rote nicht gestartet

ich glaube das das problem daran liegt das bei dem befehl make modules, einfehler auftritt und die kompelierung
beendet wird und deshalb die module nicht fertig gebaut werden.

kann das sein? wenn ja wie kann ich das verhindern?
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy