Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
SuSE 6.4 mit wvdial und sendmail

 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
pleinkar



Anmeldungsdatum: 02.08.2000
Beiträge: 1
Wohnort: 46399 Bocholt

BeitragVerfasst am: 03. Aug 2000 12:28   Titel: SuSE 6.4 mit wvdial und sendmail

Hallo,

ich habe ein großes Problem mit der Internetverbindung unter SuSE 6.4.

Ich verwende wvdial um eine PPP Verbindung zu erstellen. (auch mit mehreren ISP's getestet)
Die Verbindung wird hergestellt und auch die default route wird richtig gesetzt. Ich habe auch mit yast mehrere DNS konfiguriert.

Merkwürdig erscheintmir, das ich wenn ich nach Aufbau der Verbindung die routen einsehe, selbst die IP meiner Netzwerkkarte (192.168.0.2) mit RFC1819 o.ä. aufgelöst
wird.
Ich kann mit ping zwar meinen gegenrechner erreichen aber keinen anderen Rechner im Netz. Außerdem will desshalb sendmail die mails nicht versenden, und stellt sie ständig zurück.

Hier habe ich mal einige Daten:
Ich habe die DNS :
193.175.175.160
162.104.197.199
195.145.66.20
konfiguriert.
Erreichen kann ich mit PING allerdings nur den letzten.
Ich kann allerdings mit Lynx beliebig im Netz surven.
Wenn ich auf URL's pinge, wird sie aufgelöst!


> route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
tnt7.Hilden.de. * 255.255.255.255 UH 0 0 0 ppp0
RFC1918-Host * 255.255.255.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default tnt7.Hilden.de. 0.0.0.0 UG 0 0 0 ppp0


> route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
139.4.248.7 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 139.4.248.7 0.0.0.0 UG 0 0 0 ppp0

>ifconfig

eth0 Link encap:Ethernet HWaddr 00:08:C7:FA:CD:E1
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:30 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
Interrupt:5 Base address:0x1010



ppp0 Link encap:Point-to-Point Protocol
inet addr:149.225.77.223 P-t-P:139.4.248.7 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1524 Metric:1
RX packets:118 errors:0 dropped:0 overruns:0 frame:0
TX packets:119 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:10


Was kann das wohl sein ?
Gruß Karsesn
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Steffen
Gast





BeitragVerfasst am: 03. Aug 2000 19:35   Titel: Re: SuSE 6.4 mit wvdial und sendmail

Hallo erstmal,

von mir nur zwei Dinge die bie mir im selben Zusammenhang falsch liefen, daher die vieleicht etwas simplen Anmerkungen:
1.) Deine eth0 muss in der Routing-Tabelle des Kernels sein und zwar immer wenn eine eingerichtet ist.
2.) Hängt ein TCP/IP-Netzwerk an dem Rechner? Wenn ja, dann musst Du die /etc/hosts anpassen, für sendmail sollten da soweit ich mich erinnere auch die DNS aufgelöst werden.
3.) ggf. kann es nötig sein die Startparameter von sendmail mit YaST zu ändern.

Schau´Dir zu den Themn die Beiträge im Server-Workshop an. Speziel zu sendmail, Routing etc.

BYE
Steffen
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy