Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
über 1024.. und alles kaputt

 
Dieses Forum ist gesperrt, Sie können keine Beiträge editieren, schreiben oder beantworten.   Dieses Thema ist gesperrt, Sie können keine Beiträge editieren oder beantworten.    Pro-Linux Foren-Übersicht -> Linux-Forum (alt)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
sellmi
Gast





BeitragVerfasst am: 11. Aug 2000 14:39   Titel: über 1024.. und alles kaputt

seit dem ich eine 20 gig platte habe lässt sich suse 6.4 nicht istallieren
lilo spinnt mir irgenwas von 1024 zylinder bla bla vor
und beim boot ist nur noch li

zu lesen was kann ich da machen

2 problem ich kann mit 6.4 den x-server mit sax nicht mehr einrichten auch nicht mit der --server vga16 option
bei 6.2 funzte alles einwadfrei
 

odauter



Anmeldungsdatum: 17.04.2000
Beiträge: 460
Wohnort: Hamburg

BeitragVerfasst am: 11. Aug 2000 16:49   Titel: Re: über 1024.. und alles kaputt

Das berühmte 1024-Cylinder-Problem...
Das Problem ist, daß Bootmanager zum Booten anfangs Routinen des BIOS' benutzen müssen, um das System zu starten, da ja eben noch keinerlei Treiber geladen wurden. Dummerweise können die Standart-x86-BIOS' nicht auf Cylinder >1024 zugreifen.
Auf LILO/Linux gemünzt heißt das, daß die zum Booten benötigten Files - also vorrangig der Kernel - innerhalb dieses Bereiches liegen müssen. Ergo ist das kein Fehler von LILO, sondern der Kurzsichtigkeit der PC-Entwicklern zuzuschreiben.
Die klassische Lösung ist am Anfang der Bootplatte eine kleine ext2-Partition zu erstellen und als /boot zu mounten. Dort liegen dann die Kernel und evtl. initrds. Neudings gibt es aber auch Motherboards mit BIOS' die diese 1024 Cylinder Grenze durchbrechen. LILO unterstützt diese Funktion auch schon. Soll funktionieren, hab's aber nie ausprobiert.
_________________
bye.olli
--
"Where's Oswald when we need him.."


Zuletzt bearbeitet von odauter am 11. Aug 2000 16:49, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

odauter



Anmeldungsdatum: 17.04.2000
Beiträge: 460
Wohnort: Hamburg

BeitragVerfasst am: 11. Aug 2000 16:50   Titel: Re: über 1024.. und alles kaputt

Zum dem Sax-Problem:
xf86config ist Dein Freund. Mühsam, aber das funzt zumindest!
_________________
bye.olli
--
"Where's Oswald when we need him.."
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

rakl



Anmeldungsdatum: 17.06.2000
Beiträge: 194
Wohnort: Beckum

BeitragVerfasst am: 11. Aug 2000 21:21   Titel: Re: über 1024.. und alles kaputt

Hi,

schau Dir auch mal die Seite http://www.pro-linux.de/work/newbie/index.html an.
Dort werden Vorschläge zur partitionierung gemacht.
Hilfreich ist auch die SuSe-Supportdatenbank unter http://www.suse.de => dort nach lilo suchen.
Mit man lilo kannst Du Dir auch noch die Bedeutung anzeigen lassen, wenn beim booten nur ein li kommt.
Gruß
rakl
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Linux-Forum (alt) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy