Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Zwei Netzwerkkarten unter SuSE 7.0

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
riedel1



Anmeldungsdatum: 16.08.1999
Beiträge: 2
Wohnort: BS

BeitragVerfasst am: 16. Sep 2000 19:27   Titel: Zwei Netzwerkkarten unter SuSE 7.0

Hallo,
ich versuche hier eine 2. Netzwerkkarte (eth1) zum laufen zu bringen.
Leider ohne erfolgt.
Bei Netzwerkkarten sind ISA und vom gleichen Hersteller.
Beide haben unterschiedliche IP's und auch die I/O Ports sind unterschiedlich.
De-Aktiviere ich eth0 und aktiviere nur eth1 läuft eth1 ohne Probleme.
Auch nur eth0 alleine Funktioniert. Nur beide zusammen nicht. In der rc.config sind beide zu sehen.
Bei init 1 kommt folgende Meldung:
Shutting down network device eth1eth1: unknown interface: No such device
failed
Bei init 2:
Setting up network device eth1
SIOCSIFADDR: No such device
eth1: unknown interface: No such device
SIOCSIFBRDADDR: No such device
eth1: unknown interface: No such device
SIOCSIFNETMASK: No such device
eth1: unknown interface: No such device failed
Setting up network device eth1
SIOCSIFADDR: No such device
eth1: unknown interface: No such device
SIOCSIFBRDADDR: No such device
eth1: unknown interface: No such device
SIOCSIFNETMASK: No such device
eth1: unknown interface: No such device failed

Wer kann mir weiterhelfen?
DANKE
_________________
bye
Riedel -> www.riedelweb.de
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 16. Sep 2000 22:12   Titel: Re: Zwei Netzwerkkarten unter SuSE 7.0

Hi,

o du Scheiße. ISA-Karten sind der letzte Dreck. Keine automatische Konfiguration, endlose Probleme.

Haben deine beiden Karten vielleicht denselben Interrupt? Das ist bei ISA absolut verboten und kann sogar die Hardware beschädigen.

Oder eine von beiden liegt auf einem Interrupt, der schon anderweitig belegt ist.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

riedel1



Anmeldungsdatum: 16.08.1999
Beiträge: 2
Wohnort: BS

BeitragVerfasst am: 17. Sep 2000 12:52   Titel: Re: Zwei Netzwerkkarten unter SuSE 7.0

Hi HJB,

Bis jetzt hatte ich noch nie Probleme mit ISA Karten und einzeln funktionieren sie ja auch
Die IRQ sind verschieden und auch noch nicht belegt.

Was ich jetzt nochmal machen kann, ist eine Netcard in einen anderen Slot stecken.
Hoffe mal das es was bringt.
Ich möchte nämlich mal wieder gerne richtig surfen und mit lynx macht das keinen grossen Spass
_________________
bye
Riedel -> www.riedelweb.de
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 17. Sep 2000 16:59   Titel: Re: Zwei Netzwerkkarten unter SuSE 7.0

Hi,

eventuell findet der Treiber nur die erste Karte automatisch. Wenn der Treiber als Modul vorliegt, sollte man beide Karten als Parameter eingeben, z.B.

insmod 3c503.o io=0x280,0x300,0x330,0x350 \ xcvr=0,1,0,1

(Beispiel aus Documentation/network/net-modules.txt).

Ist der Treiber kein Modul, dann kommt die Kommandozeile ether=... zum Einsatz.

Bei PCI dagegen kann der Treiber alle Karten eines Typs automatisch finden

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

germannightwing



Anmeldungsdatum: 08.08.2000
Beiträge: 29
Wohnort: Oberhausen

BeitragVerfasst am: 17. Sep 2000 22:40   Titel: Re: Zwei Netzwerkkarten unter SuSE 7.0

Hallo,

Kann es sein das die beiden Karten nebeneinander liegen? Würfel mal die Karten neu und steck eine andere Karte dazwischen. Bei mir hat's was gebracht.

bye
/ Bernd /
_________________
<!--http--><a href="http://www.blue-temple.de" target="_blank"><img src="http://www.blue-temple.de/footer.png" border="0"></a><!--url-->
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

riedel1



Anmeldungsdatum: 16.08.1999
Beiträge: 2
Wohnort: BS

BeitragVerfasst am: 18. Sep 2000 11:55   Titel: Re: Zwei Netzwerkkarten unter SuSE 7.0

Hallo alle miteinander.

Ich habe das Problem jetzt mal ganz einfach gelöst:
Eine ISA raus und eine neue PCI-Karte rein.
Und schwuppsss es klappt.
Warum sich beide ISA-Karten nicht vertragen haben, weiss ich bis jetzt nicht. Aber egal jetzt klappt es und ich kann in ruhe MASQ für T-DSL zum laufen bringen

_________________
bye
Riedel -> www.riedelweb.de
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Freddy
Gast





BeitragVerfasst am: 24. Sep 2000 22:20   Titel: Ich hab 2 ISA Karten drin

Hallo

Also ich habe 2 ISA karten zum laufen gebracht, ich habe nur einige Zeit (2 Stunden) dafür gebraucht um drauf zu kommen wie es gehen könnte.
Eigentlich isses ganz einfach.

Da ich nur die Installations CD habe udn keine Boot Disk, hab ich die Install CD eingelegt
Dann hab ich das Setup abgebrochen und konnte mir so Hardware Informationen anschauen.
Da hat er beide ISA Karte erkannt und ich konnte mir den IO wert jeweils beider Karten aufschreiben.
Den hab ich dann eingetragen und schwups die wups ging es.

Greez Freddy
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy