Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Netzwerkkarte D-Link DFE-530TX

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Peter
Gast





BeitragVerfasst am: 30. Okt 2000 16:09   Titel: Netzwerkkarte D-Link DFE-530TX

Hi,

habe mir der besagten Karte probleme ein passendes Modul zu finden, soll angeblich mit Rhine II gehen, das vorhandere Module LM 7.1 lässt sich nicht laden, die sources von Rhine.c (oder so) machen bei depmod einen "unresolver symbol" Fehler. Kann mir jemand weiterhelfen, Tipps?

Vielen Dank!

Peter
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 31. Okt 2000 19:12   Titel: Re: Netzwerkkarte D-Link DFE-530TX

Hi,

es heißt via-rhine.c und hat bei mir schon immer funktioniert (mal davon abgesehen, daß es oft Timeouts gab, wonach das Netzwerk dann tot war).

Was ist dein Problem? Nochmal in deutsch bitte, dennn die Sourcen haben mit depmod überhaupt nichts zu tun. Und depmod nichts mit dem Laden von Modulen.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Schiermi
Gast





BeitragVerfasst am: 31. Okt 2000 23:53   Titel: Re: Netzwerkkarte D-Link DFE-530TX

http://www.scyld.com/network/ethercard.html
 

Peter
Gast





BeitragVerfasst am: 01. Nov 2000 11:33   Titel: Re: Netzwerkkarte D-Link DFE-530TX

sorry, via-rhine.c heißt die source! also nochmal auf deutsch: ich kompiliere die source-datei (von der oben erwähnten adresse), soweit sogut, wenn ich dar modul jedoch laden will (insmod ...) kommt die meldung "unresolved symbol" ich weiß jetzt nicht mehr genau die meldung aber irgendein symbol mit "pci_...", und bei depmode kommt die gleiche meldung, soviel ich weiß überprüft man doch die abhängigkeit von modulen mit depmod, und ich schliße daraus das es eine abhängigkeit gibt die nicht aufgelöst werden kann... korrigiert mich wenn ich das fasch verstehe!

ich habe auch schon die rpm-sources probiert, gleiches verhalten.

die vorkompilierten module gehen auch nicht. kann man irgendwie rausbekommen welchen chip die karte benutzt? damit ich da zumindest sicher sein kann.

Ciao

Peter
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 01. Nov 2000 21:32   Titel: Re: Netzwerkkarte D-Link DFE-530TX

Hi,

mit lspci kannst du sehen, welcher Chip es ist.

Das 'unresolved sysmbol' mit PCI sagt mir was. Es könnte sein, daß der Treiber zu neu ist und nur funktioniert, wenn man noch ein kleines Kompatibilitätsmodul hinzufügt.

Du hast Kernel 2.2.15 oder so (Mandrake 7.1) und der Treiber ist vermutlich schon an Kernel 2.4 angepaßt.

Offenbar hast du die benötigten Header, pci-scan.h usw., schon auf deinem System, sonst hätte sich der Treiber nicht compilieren lassen. Es gibt auch noch eine pci-scan.c, die zu einem Modul namens pci-scan.o compilieren läßt. Das mußt du dann vor via-rhine.o laden.

Es wundert mich nur, daß das via-rhine Modul von Mandrake nicht gehen soll.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

peter
Gast





BeitragVerfasst am: 01. Nov 2000 22:44   Titel: Re: Netzwerkkarte D-Link DFE-530TX

ich habe heute LM 7.2 installiert, jetzt kann ich auch das modul via-rhine.o laden, allerdings wenn ich das interface eth0 hochbringe sieht das so aus:
ifconfig eth0

eth0 Linkverkapselung:Ethernet HWaddr 00:00:00:00:00:00
inet addr:192.168.10.70 Bcast:192.168.10.255...
usw
man beachte die Hardware Adresse.
und via-diag (ein diagnosetool) findet die karte als VIA VT3065 Rhine-II und auch wieder mit der HWaddr 00:00....
irg und io_addr sind i.o.

lspci bringt: VIA Technologies, Inc: Unknown device 3065 (rev 42)
ich kann auf mich selber pingen aber nicht nach aussen. unter win funktioniert die karte einwandfrei.

wer kann mir weiterhelfen? danke!!!

stimmt HJB, das unresolved symbol problem lag an dem pci-scan.o modul. aber ich konnte das modul auch nicht mit linuxconf laden, jetzt geht es.
Peter
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 02. Nov 2000 10:16   Titel: Re: Netzwerkkarte D-Link DFE-530TX

Hi,

also ich habe einen anderen Rhine-Chip als du: VT86C100A. Ist deine Karte schon älter oder brandneu? Nach meinen Infos ist der Chip eher älter.

Ist die Hardware-Adresse unter Windows nicht 0?

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Peter
Gast





BeitragVerfasst am: 02. Nov 2000 19:51   Titel: Re: Netzwerkkarte D-Link DFE-530TX

unter windows ist die 00:50:BA:6D:1C:49 also i.o.
was ich noch auf der sclyd homepage gelesen habe das für die revision 3065 das modul min. version 1.07 sein soll, meiner ist 1.08 also müsste es eigendlich gehen.

unter win wird der treiber mit der Rev A verwendet, falls das irgendwie weiterhilft.

und übrigens KDE 2.0 ist spitze und der konqi wird noch der ultimative browser!!!

Peter
 

conloos
Gast





BeitragVerfasst am: 03. Nov 2000 17:27   Titel: Re: Netzwerkkarte D-Link DFE-530TX

Smile,

schoen das es anderen leuten auch manchmal so geht wie mir.. die DFE-530TX gibt es in 2 revisionen a1 geht mit den mitgelieferten treibern rev. b1 nicht. dazu must du neue treiber von dlink de!! ziehen. das problem hab ich schon ein paar mal suse gemeldet -> die haben mir dan auch die richtige addr. zurueck gemailt, aber geaender haben sie es ,soweit ich weis, in der hardwaredatenbank noch nicht.

con
 

conloos
Gast





BeitragVerfasst am: 04. Nov 2000 15:11   Titel: Re: Netzwerkkarte D-Link DFE-530TX

die seite sollte helfen:

http://www.dlink.de/support/download/treiber/treiber.asp?nummer=DFE-530TX&B2=Suchen

fuer Rev. a1 und b1

con
 

Peter
Gast





BeitragVerfasst am: 06. Nov 2000 11:19   Titel: Re: Netzwerkkarte D-Link DFE-530TX

direkt auf der karte ist ein aufkleber: Rev A3.
werde der sache nochmal nachgehen, danke für den tip!
 

Peter
Gast





BeitragVerfasst am: 09. Nov 2000 9:56   Titel: Re: Netzwerkkarte D-Link DFE-530TX

Danke , Danke und Danke!

Genau das war es, scheiß Win98, ich konnte den Fehler einwandfrei nachbilden. Win98 gestartet - runtergefahren, MAC-Adresse 00:00:0.., Rechner ausgeschaltet, Karte ausgebaut bisrl gewartet, eingebaut, gleich Linux gestartet geht einwandfrei!

Ich wünsche diesen Fehler keinem, den soviel Zeit wie ich damit verbracht habe... ich wollte die Karte schon verschrotten!

Ciao

Peter
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy