Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Hilfe, mein Router ist zu lahm!

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
mimamau



Anmeldungsdatum: 24.01.2001
Beiträge: 3
Wohnort: 65520 Bad Camberg - Würges

BeitragVerfasst am: 27. Jan 2001 19:26   Titel: Hilfe, mein Router ist zu lahm!

Hi! Ich habe mir mit SuSE 7.0 einen Router, der sich über Modem einwählt gebastelt, geht auch alles wunderbar. Leider dauert es eine Ewigkeit, bis eine Seite aufgebaut ist oder eine Mail empfangen wurde. Ausserdem läuft Half-Live nicht, aber das ist erst mal unwichtig. Ich habe auch die IP_MASQ_X Module installiert, nur bei AUTOFW, MFW und PORTFW kommt eine Fehlermeldung mit "unresolved Symbol ...".
Was habe ich falsch gemacht?
Vielen Dank
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 27. Jan 2001 21:50   Titel: Re: Hilfe, mein Router ist zu lahm!

Hi,

ohne Kernelversion und exakte Konfigurationsbeschreibung kann dir niemand helfen.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 27. Jan 2001 21:52   Titel: Re: Hilfe, mein Router ist zu lahm!

Hi,

ohne Kernelversion und exakte Konfigurationsbeschreibung kann dir niemand helfen.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

mimamau



Anmeldungsdatum: 24.01.2001
Beiträge: 3
Wohnort: 65520 Bad Camberg - Würges

BeitragVerfasst am: 28. Jan 2001 10:55   Titel: Re: Hilfe, mein Router ist zu lahm!

Meine Kernelversion ist 2.2.16.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

jwm
Gast





BeitragVerfasst am: 28. Jan 2001 16:45   Titel: Re: Hilfe, mein Router ist zu lahm!

Hi,
und wie sieht das Script für's MASQ aus??
Und die Einstellung der Clients?
Auf meiner RH (gleiche kernelversion sieht's z.B. so aus (HalfLife läuft auf den Clients astrein, der Router fungiert nebenbei noch als Dedicated Server für HL & CS, auch Battlecom funzt):

#!/bin/sh
#Erst mal die Basics:
echo -n "Setting IP chains..."
echo "1" > /proc/sys/net/ipv4/ip_forward

#IP-Spoofing unterdrücken:
if [ -e /proc/sys/net/ipv4/conf/all/rp_filter ]; then
for i in /proc/sys/net/ipv4/conf/*/rp_filter; do
echo 1 > $i
done
fi

for i in /proc/sys/net/ipv4/conf/*/accept_source_route; do
echo 0 > $i
done


#Alle chains löschen:
/sbin/ipchains -F forward
/sbin/ipchains -F input
/sbin/ipchains -F output

#Grundregeln setzen:
/sbin/ipchains -P forward DENY
/sbin/ipchains -P input ACCEPT
/sbin/ipchains -P output ACCEPT

#Neue Regelliste für alles, was über ISDN rausgeht:
/sbin/ipchains -N ippp-out
/sbin/ipchains -A output -i ippp+ -j ippp-out

#Die ganze Sache in der Performance verbessern:
/sbin/ipchains -A ippp-out -p TCP -d 0.0.0.0/0 80 -t 0x01 0x10
/sbin/ipchains -A ippp-out -p TCP -d 0.0.0.0/0 ftp-data -t 0x01 0x08
/sbin/ipchains -A ippp-out -p TCP -d 0.0.0.0/0 nntp -t 0x01 0x02
/sbin/ipchains -A ippp-out -p TCP -d 0.0.0.0/0 pop-3 -t 0x01 0x02

#Neue Regelliste für alles, was über ISDN reinkommt:
/sbin/ipchains -N ippp-in
/sbin/ipchains -A input -i ippp+ -j ippp-in

#Von aussen darf nix den lokalen Addressbereich besitzen:
/sbin/ipchains -A ippp-in -s 192.168.1.0/24 -l -j DENY
#/sbin/ipchains -A ippp-in -l -s 0.0.0.0/0 -p tcp -y -j DENY
#Das ganze Netz maskieren:
#/sbin/ipchains -A forward -s 192.168.1.0/24 -j MASQ

#Nur 2 Clients maskieren:
/sbin/ipchains -A forward -s 192.168.1.3 -j MASQ
/sbin/ipchains -A forward -s 192.168.1.2 -j MASQ

#Nun noch Windows am browsen hindern:
/sbin/ipchains -A forward -j DENY -p -l tcp -s 0.0.0.0/0 137:139
/sbin/ipchains -A forward -j DENY -p -l udp -s 0.0.0.0/0 137:139

#Damit alle Clients möglichst viel vom Netz haben,
#laden wir noch einige Goodies:
/sbin/modprobe ip_masq_ftp
/sbin/modprobe ip_masq_user
/sbin/modprobe ip_masq_raudio
/sbin/modprobe ip_masq_portfw
/sbin/modprobe ip_masq_mfw
/sbin/modprobe ip_masq_irc
/sbin/modprobe ip_masq_cuseeme
/sbin/modprobe ip_masq_quake

#Herr Sohn möchte sein Headset über battlecom nutzen,
#machen wir also Port-Forwarding:
ipmasqadm autofw -A -r tcp 47624 47625 -h 192.168.1.2
ipmasqadm autofw -A -r tcp 2300 2400 -h 192.168.1.2
ipmasqadm autofw -A -r udp 2300 2400 -h 192.168.1.2
#ipmasqadm autofw -A -r udp 2213 2214 -h 192.168.1.2
#ipmasqadm autofw -A -r udp 6665 6666 -h 192.168.1.2

#schnell noch den letzten Rest eingestellt:
echo "1" > /proc/sys/net/ipv4/ip_dynaddr
echo "1" > /proc/sys/net/ipv4/tcp_syncookies
echo "Ready to go."
 

mimamau



Anmeldungsdatum: 24.01.2001
Beiträge: 3
Wohnort: 65520 Bad Camberg - Würges

BeitragVerfasst am: 28. Jan 2001 19:04   Titel: Re: Hilfe, mein Router ist zu lahm!

Danke, ich habe das in etwa genauso vor. (Das mit dem nebenbei als CS-Server und Battlecom)
Ich werde es mal mit deinem Script versuchen.
Marius
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy