Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
e-smith server & gateway 4.1

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 15. Feb 2001 19:09   Titel: e-smith server & gateway 4.1

Hallo,
nach der äußerst interessanten Anmoderation von HJB habe ich mir denn mal die 342 MB download gegönnt, und war, sprich bin, begeistert. Ein (fast) absolut simpel zu installierender Router/Gateway/Firewall/etc.
Nun bin ich nicht gerade erfahren im Umgang mit RedHat7 (darauf basiert e-smith), und diese Distribution unterstützt erst einmal nur Netzwerkkarten und externe Modems.
Per email hat man mir aber mitgeteilt, daß selbstredend die RedHat Module genutzt werden können. Leider gibt es für solche nachträglichen Änderungen keine Hilfestellungen.
Wie installiere ich also auf einem RedHat7 System ohne ISDN Unterstützung eben dies?
Welche Pakete benötige ich?

Danke!
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)
 
Benutzer-Profile anzeigen Private Nachricht senden

STEFAN
Gast





BeitragVerfasst am: 16. Feb 2001 9:51   Titel: Re: e-smith server & gateway 4.1

meine erfahrungen mit nach installieren und komaptibiliät sin nicht sehr gut -
linuxconf läßt sich installieren, fremdpakete, wie webmin (der ja uch viele unterschiedliche
distributionen erkennt), läuft nicht. auch lassen sich nicht alle module konfigurieren z. B. rpc-portmap.

Lies doch mal mein topic mit dt. Umlauten und e-smith..
Hast du eine idee?
 

Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 16. Feb 2001 10:20   Titel: Re: e-smith server & gateway 4.1

Also weder das Installieren von joe (ich magi ihn einfacj ...), noch die Installation von webmin haben irgendwelche Probleme bereitet. Auch das webmin Modul für qmail ließ sich anstandslos einbinden.
Linuxconf gibt es unter e-smith nicht.
Nur, wie die Einbindung von I4L läuft, ist mir nicht klar ...
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)


Zuletzt bearbeitet von Stormbringer am 16. Feb 2001 10:20, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

Ph0bY
Gast





BeitragVerfasst am: 23. Feb 2001 17:14   Titel: Re: e-smith server & gateway 4.1

E-Smith ist wirklich eine gute Distri, aber das mit ISDN und E-Smith ist wohl ein Problem. Es gibt zwar ein HowTo (http://internet-sicherheit.net/isdn4es-howto.html), die ist aber nur für 4.0 und funzte bei mir nicht.

Hat schon jemand rausbekommen wie das mit ISDN geht?
 

Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 25. Feb 2001 14:08   Titel: Re: e-smith server & gateway 4.1

Also, nur zur Info:
ISDN klappt hervorragend!!!!! Es darf halt nur keine ISDN Karte sein, ein ISDN Modem (z. B. Elsa Microlink ISDN TL/pro) funzt einwandfrei.

Mit dem Autor von isdn4es stehe ich in lockerem Kontakt, er wird es in den nächsten Wochen einmal testen.
Es gibt eine Menge Unterschiede zwischen 4.0 und 4.1, ein "einfaches eintragen in modules.conf anstelle von conf.modules" reicht bei weitem nicht aus, teste momentan die unterschiedlichen Modulversionen aus .... man weiß ja nie zu 100% ...
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)
 
Benutzer-Profile anzeigen Private Nachricht senden

ph0by



Anmeldungsdatum: 23.02.2001
Beiträge: 3

BeitragVerfasst am: 25. Feb 2001 21:27   Titel: Re: e-smith server & gateway 4.1

Die externen ISDN Modems sind aber auch um einiges teurer als interne Karten. Hoffentlich bekommt ihr das zum Laufen, ich freu mich schon auf ne nette HowTo Smile
 
Benutzer-Profile anzeigen Private Nachricht senden

Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 26. Feb 2001 16:01   Titel: Re: e-smith server & gateway 4.1

Hi,
ich möchte keine allzu großen Hoffnungen wecken, aber ...
zumindest eine AVM Fritz!PCI wurde vom E-Smith 4.1 System akzeptiert - leider aber nicht immer.?!
Vorgehensweise: isdn4es HowTo befolgen, OHNE die Datei modules.con/conf.modules zu verändern.
Die Softwareversionen zum Einspielen waren:
- tcl-8.3.1-46.i386.rpm
- isdn4k-utils-3.1-32.i386.rpm
Ein modprobe hisax type=27 protocol=2 erkennt die Karte und es wird versucht eine Verbindung
aufzubauen .
Die Dateien /etc/e-smith/.../chat-ppp0/* & /sbin/e-smith/console habe ich angepaßt, allerdings wird immer noch ^M angehängt .
Darum klappt es momentan auch noch nicht mit der Verbindung ...
Mit der Teles Karte PCI klappt es (bei mir noch) nicht, ebensowenig mit einer ISA Fritz!.

Zusätzlich habe ich noch installiert:
- joe-2.8-43.i386.rpm (WordStar Editor - komme leichter mit klar als mit vi ...)
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)
 
Benutzer-Profile anzeigen Private Nachricht senden

ph0by



Anmeldungsdatum: 23.02.2001
Beiträge: 3

BeitragVerfasst am: 27. Feb 2001 14:55   Titel: Re: e-smith server & gateway 4.1

Also meine AVM A1 ISA wurde schon immer korrekt erkannt, auch mit eintrag in modules.conf "options hisax type=5 io=0x300 irq=12" (io=0x300 -> das kann man auf der Karte ja per Jump einstellen). Ebenso ohne Eintrag in modules.conf mit modprobe. Installiert hab ich jeweils die neuste Version von tcl-8.x.x.i386.rpm und isdn4k-utils-x.x.i386.rpm (von redhat.com).

Jetzt weiss ich wenigsten das es an dem ^M hängt, aber waurm macht der das? Meine Dateien editiere ich immer mit vi oder pico...
 
Benutzer-Profile anzeigen Private Nachricht senden

ph0by



Anmeldungsdatum: 23.02.2001
Beiträge: 3

BeitragVerfasst am: 05. März 2001 11:16   Titel: Re: e-smith server & gateway 4.1

Ich habs jetzt hinbekommen, ich musste nur die AT Befehle für T-Online (mein Provider) ändern! Früher kam bei der Anwahl immer "NO CARRIER", also die Gegenstelle trennet die Verbindung!

So hab ichs gemacht hab:

Komplette Neuinstallation von E-Smith 4.1.1, dann nach dem HowTo (http://internet-sicherheit.net/isdn4es-howto.html) vorgegangen bis auf die AT Befehle (in den /etc/e-smith/templates/etc/sysconfig/network-scripts/chat-ppp0/ templates), die hab ich wegen T-Online ändern müssen.
Da ich bei AVM keine AT-Befehle gefunden hab, hab ich kurz die T-Online Software installiert und dort die AT-Befehle für meine ISDN-Karte für die Anwahl bei T-Online ausgelesen und in die Templates kopiert.

Nun klappt die Anwahl und ich komme auch ins Internet....vielleicht hilft euch das weiter!


Zuletzt bearbeitet von ph0by am 05. März 2001 11:16, insgesamt 3-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy