Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Netzwerk-Problem mit Linux-Router (T-DSL)

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
daster
Gast





BeitragVerfasst am: 31. März 2001 15:33   Titel: Netzwerk-Problem mit Linux-Router (T-DSL)

Hallo Liste!

Ich plage mich schon seit längerer Zeit mit einem Problem rum. Hier
mal eine möglichst genaue Beschreibung:

Nach einem nicht genau definierbaren Zeitraum (5-15 Stunden), von
einer Sekunde auf die andere, kommen bestimmte TCP-Connections nicht
mehr korrekt zustande. Betroffen hiervon sind Connections die aktiv
vom Router ausgehen. Das heisst im Klartext, daß ich z.B. noch
passives FTP-, SSH-, UDP- aber keine HTTP-, POP3-, SMTP- bzw. aktive
FTP-Connections machen kann (von der Windowskiste als auch vom Router
selbst). Von außen kann ohne Probleme auf den Router zugegriffen
werden. Das Problem kann ich nur beheben, indem ich neu boote (gehe
deshalb stark von einem Kernel-Problem aus).

Details zum Netzwerk:

2 Rechner (Win98 und der Linux-Router) im lokalen Class-C-Netz
192.168.1.* per Cross-Kabel verbunden.

Details zum Router:

Pentium 133 mit 64 MB Ram und 10 GB IBM Festplatte.
Debian 2.2r2 mit neusten Package-Updates.
Linux georgia 2.2.18pre21 #1 Mon Mär 26 13:50:00 CEST 2001 i586
Hier die Prozessliste

PID TTY STAT TIME COMMAND
1 ? S 0:07 init
2 ? SW 0:00 [kflushd]
3 ? SW 0:00 [kupdate]
4 ? SW 0:00 [kpiod]
5 ? SW 0:00 [kswapd]
153 ? S 0:00 /sbin/syslogd -m 0
159 ? S 0:00 /sbin/klogd
167 ? S 0:00 /usr/sbin/named
174 ? S 0:00 /usr/sbin/inetd
180 ? S 0:00 /usr/sbin/isdnlog
-f/etc/isdn/isdnlog.isdnctrl0 /dev/isdnctrl0
194 ? S 0:00 /usr/sbin/lpd
207 ? S 0:00 sh /usr/bin/safe_mysqld
293 ? S 0:00 /usr/sbin/nmbd -D
301 ? S 0:00 /usr/sbin/smbd -D
312 ? S 0:02 /usr/sbin/sshd
319 ? S 0:00 /usr/sbin/squid -D -sYC
351 ? S 0:00 /usr/sbin/cron
357 ? S 0:01 /usr/sbin/apache
360 tty1 S 0:00 /sbin/getty 38400 tty1
361 tty2 S 0:00 /sbin/getty 38400 tty2
362 tty3 S 0:00 /sbin/getty 38400 tty3
363 tty4 S 0:00 /sbin/getty 38400 tty4
364 tty5 S 0:00 /sbin/getty 38400 tty5
365 tty6 S 0:00 /sbin/getty 38400 tty6
371 ? S 0:00 /usr/sbin/sshd
412 pts/1 S 0:00 sh /usr/sbin/adsl-connect
422 ? S 0:00 /usr/sbin/pppd pty /usr/sbin/pppoe -p
/var/run/pppoe.conf-adsl.pid.pppoe -I eth1 -T 80 -U -m 1412
423 ? S 0:45 /usr/sbin/pppoe -p
/var/run/pppoe.conf-adsl.pid.pppoe -I eth1 -T 80 -U -m 1412
860 pts/1 S 0:00 -su
870 pts/1 R 0:00 ps x

Die beiden Netzwerkkarten im Router sind Allied Telesyn (die von der
Telekom "verschenkt" wurden Wink mit Realtek 8139 Chipsatz. Außerdem
verwende ich rp-pppoe3.0.

Folgende Dinge habe ich bereits vergeblich versucht:

-Netzwerkkarten getauscht.
-ADSL-Zugang über pppoed laufen lassen.
-Verschiedene Kernel-Versionen u.a. den 2.2.17 Standardkernel von
Debian.
-ADSL komplett deaktiviert und mit ISDN ins Netz gegangen. Auch hier
kam dieses Problem.

Ich habe mal mit SnifferPro von meiner Windows-Kiste aus den
HTTP-Verkehr vorher und nachdem das Problem eintritt gesnifft.
Folgende Screenshots stehen zur Verfügung:

http://e-starts.de/files/net/http_vorher.jpg
http://e-starts.de/files/net/http_nachher.jpg

Sorry, daß ich euch das nid in ASCII-Form bieten kann, aber das
Sniffer-Programm bietet anscheinend keine Exportfunktion ;(

Ich hoffe, daß ich möglichst viele Informationen geliefert habe. Falls
nicht, bitte bescheid sagen. Ich werde beim nächsten eintreten des
Problems auch noch nen Tcpdump machen und posten!
Vielleicht kann mir ja ein Netzwerkmensch sagen, was mein Router hier
in den falschen Hals bekommt ;)

Danke im voraus und sorry für das lange Posting!

Grüße, daster
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 01. Apr 2001 17:56   Titel: Re: Netzwerk-Problem mit Linux-Router (T-DSL)

Hi,

hast du die Kernel-Logs mal angeschaut?

Außerdem kann ein Update auf 2.2.19 und den neuesten 8139-Treiber (der ist nicht notwendig schon im Kernel) hilfreich sein.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

daster
Gast





BeitragVerfasst am: 01. Apr 2001 18:25   Titel: Re: Netzwerk-Problem mit Linux-Router (T-DSL)

Hi!

Also in den Logs unter /var/log/* waren keine Meldungen zu finden.
Ich habe gerade eben 'nen Kernel 2.2.19 kompiliert und installiert. Mal schauen, obs damit geht.

Grüße, daster
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy