Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Apache core dump

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
odauter



Anmeldungsdatum: 17.04.2000
Beiträge: 460
Wohnort: Hamburg

BeitragVerfasst am: 24. Apr 2001 14:56   Titel: Apache core dump

Hi,

ich hab mal wieder son richtiges sch... Problem. Ich installiere gerade unseren neuen Webserver und versuche dabei natürlich die neuesten Sachen zu verwenden:
RedHat 7.1
apache-1.3.19
openssl-0.9.6a
mod_ssl-2.8.2-1.3.19
php-4.0.4pl1

Ich habe das (wie gewohnt) folgendermaßen installiert:
- blanke RH7.1
- benötigte libs (zlib,tifflib, pdflib,..) nachinstalliert
- Apache configure
- OpenSSL "sh config _no_idea", make, make test (ok)
- mod_ssl configure --with-apache=/usr/local/apache
- php "configure --with-mysql --enable-ftp --with-pdflib=/usr/local --with-apache=/usr/local/src/apache --enable-track-vars", make und make install
- Apache: "SSL_BASE=/usr/local/src/openssl ./configure --with-layout=Apache --prefix=/var/home/apache --enable-module=ssl --activate-module=src/modules/php4/libphp4.a", make, make certificate, make install

Das Ergebnis der ganzen Bemühungen sieht dann folgendermaßen aus:

[root@wwwinst bin]# ./apachectl start
./apachectl: line 184: 13713 Speicherzugriffsfehler (core dumped) $HTTPD
./apachectl start: httpd could not be started

Hab jetzt schon diverse Dinge versucht und komm einfach nicht mehr weiter...
Für Tipps wäre ich sehr dankbar.
_________________
bye.olli
--
"Where's Oswald when we need him.."
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

ronny



Anmeldungsdatum: 24.04.2001
Beiträge: 313
Wohnort: Muehlacker, BW

BeitragVerfasst am: 24. Apr 2001 21:53   Titel: Re: Apache core dump

warum sparst du dir nicht die arbeit und nimmst die rpms?
(falls die auf den redhat cds nicht aktuell genug sein sollten gibts neuere auf ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS )
 
Benutzer-Profile anzeigen Private Nachricht senden

odauter



Anmeldungsdatum: 17.04.2000
Beiträge: 460
Wohnort: Hamburg

BeitragVerfasst am: 25. Apr 2001 14:47   Titel: Re: Apache core dump

Hoi,

ne, geht nicht mit rpms. Der Server soll dynamische pdfs erstellen und dazu muss die pdflib einkompiliert werden.

Inzwischen hab ich das Problem etwas eingegrenzt:
Das ganze Problem liegt bei Apache selber; die ältere Version 1.3.12 läuft ohne Murren auf Anhieb.

Folgendes ist mir übrigens beim Compile der 1.3.19 aufgefallen:
gcc -I. -I../os/unix -I../include -DLINUX=22 -DUSE_HSREGEX
-DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED `../apaci`
-DPOSIX_MISTAKE -c -o regcomp.o regcomp.c

Steht da nicht was von Linux 2.2? Ich benutze 2.4.2-2!

Im Makefile steht folgendes:
PLATFORM = i686-whatever-linux22

Im Change-File vom Apache 1.3.15 steht:

*) Linux 2.2.x and later do not need a serialised single listener,
and sysv semaphores scale better than fcntl. Updated GuessOS
to distinguish 2.0.x from 2.2.x -- 2.0.x will still use fcntl.
[Andrew Morton <andrewm@uow.edu.au>, Dean Gaudet]

Hat jemand da draussen Apache schon mal mit 2.4 compiliert?
Any Suggestions? Thx in advance.
(btw. Gnome 1.4 rules. SCNR)
_________________
bye.olli
--
"Where's Oswald when we need him.."


Zuletzt bearbeitet von odauter am 25. Apr 2001 14:47, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy