Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
CAPI + AVM Fritz Card PCI 2.0

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Dataless
Gast





BeitragVerfasst am: 02. Mai 2001 17:05   Titel: CAPI + AVM Fritz Card PCI 2.0

kann mir jemand sagen wo ich eine Richtige doku finde über die installation von CAPI und das einbinden der AVM
Treiber. ich habe nämlich bis jetzt noch nichts wirklich brauchbares gefunden.

In den Newsgroups hat es geheissen, dass man als CAPI-Treiber für die AVM B1 nehmen muss doch das ist ein aktive und
die neue Fritz Card eine Pasive. (Ich glaube nicht das das geht bzw. ich habe es probiert und es ging nicht Kernel:2.2.18)

Wäre nett wenn jemand mir da weiterhelfen könnte
E-Mail: sebastian.docktor@gmx.de

Danke schonmal im Vorraus
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 02. Mai 2001 22:43   Titel: Re: CAPI + AVM Fritz Card PCI 2.0

www.avm.de
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

cptchaos



Anmeldungsdatum: 06.06.2000
Beiträge: 129

BeitragVerfasst am: 03. Mai 2001 11:55   Titel: Re: CAPI + AVM Fritz Card PCI 2.0

Moin moin,

eigendlich ganz einfach.

1. über www.avm.de die richtigen !!!! Treiber für deine Karte besorgen (Auch auf den Karten Typ achten)

(Ich gehe jetzt einmal davon aus das Du die Treiber mittels I4L benutzten möchtest)

2. I4L Funktionfähig einrichten und Testen (besonders bei ISA Karten) (Yast nutzten)

3. In das Verzeichniss mit den AVM Treibern wechseln.
4. AVM Treiber nach AVM Anleitung Installieren

-> AVM überschreibt jetzt folgende Dateien oder Passt sie an :
/etc/modules
/etc/rc.d/i4l_hardware
wenn vor der Installation der AVM Treiber nicht I4L installiert war, wird i4l_hardware kplt. ausgetauscht (alte Treiberversion), danach wird es dann Schwierigkreiten mit I4L geben (läuft nicht). Ist I4L installiert, wir i4l_hardware gegen eine Version ausgetauscht in der die Sektion für die B1 Karte die entsprechenden CAPI Treiber enthält. Nur dann kann man noch auf Standart I4L ausweichen !!!!
Sollte es schon zu spät sein , AVM hat die orig. i4l_hardware nach /etc/rc.d/i4l_hardware.old (oder ähnlich) kopiert, einfach zurückkopieren. und danch neu probieren.
(habe leider keinen Rechner mit den aktuellen AVM CAPI Treibern zur verfügung)
Sollten die CAPI Treiber (neue Version) ohne I4L schon installiert worden sein fügt AVM ein neues initscript für CAPI ein. Hierauf sind ggf. die Links in den Verschiedenen Runlevels zu entfernen.

So jetzt aber weiter.

5. Wenn die Treiber aktualliesiert worden sind, sind noch folgende Änderungen von Hand nötig um I4L mit den AVM Capi Treibern zu nutzten.
a.) Über Yast I4L auf eine AVM B1 PCI umkonfigurieren (warum siehe oben)
b.) die Datei /etc/modules.conf suchen und folgende Änderung vornehmen :

-------> schnipp
# alias char-major-43 hisax
# alias char-major-44 hisax
# alias char-major-45 hisax

# ***********************************
# 02/2001 M.Walther
# Einbindung des AVM Capi Treibers
alias char-major-43 capidrv
alias char-major-44 capidrv
alias char-major-45 capidrv
# alias char-major-43 off
# alias char-major-44 off
# alias char-major-45 off
# ***********************************
------> schnapp

Bei den Neuen AVM Capi Treiber (für Suse 7.1) sind an das Ende der modules.conf noch Einträge für die Capi inst. angehängt,
diese sollte man durch ausmarken deaktivieren.
jetzt wird I4L die Capi Treiber für den Verbindungsaufbau nutzten !!
Leider wird das entsprechende isdn Modul von i4l nicht gestartet, warum ...

.. weil AVM warscheinlich seine Treiber nicht für I4L supportet und darum eine paar Zeilen in der Datei /etc/i4l_hardware eingespart hat, also Folgende änderung in /etc/rc.d/i4l_hardware vornehmen :

--------------> schnipp
#########################################################
# AVM-B1
#########################################################
if test ! -z "$AVM_IDX" ; then
CONTR=1
capiinit start
ISDNLOG_START="yes"
LOAD_OK="yes"
fi
-----------------> schnapp

Leider ist dieser Auszug noch aus einer alten Treiber inst., aber es kommt hierbei auf den Eintrag
LOAD=OK="yes"
ISDNLOG_START="yes"
an. sonst wir isdnlog nämlich weiter unten nicht gestartet und ohne isdnlog gibt das später ausgeführte Skript (/etc/rc.d/i4l) nur eine Fehlermeldung.

Es gibt aber eine große Einschränkung !!!
Man kann jetzt zwar Faxen (Avm Patch und c2faxsend ...)
Man kann jetzt auch ins Internet über i4l ....
... aber man sollte sich vor der Nutzung der Kanalbündelung und ibod hüten, den diese Funktioniert mit den AVM Capi Treibern nicht mehr (auch wenn es den anschein hat). Oder ich bin zu blöd es mit diesen Treibern stabil hinzubekommen.

Hoffe es hat dir weitergeholfen, ansonsten never give up

MfG Marek Walther


Zuletzt bearbeitet von cptchaos am 03. Mai 2001 11:55, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Dataless
Gast





BeitragVerfasst am: 04. Mai 2001 9:33   Titel: Re: CAPI + AVM Fritz Card PCI 2.0

hi,
Das Probl. das ich habe ist, das es bei AVM nur die CAPI-Treiber für SuSE gibt und ich
aber RedHat habe.
Es kommt zwar bei den Treibern der Source mit aber wenn ich ihn kompiliere habe ich nur ein
B1-Treiber.(das ist ja dann der neue B1-Treiber der in Wirklichkeit f. die neue AVM-Fritz card ist; WEnn ich das oben richtig vertanden haben)

Den Treiber kann ich aber nicht laden. Er bringt mir den Fehler das er keine AVM B1 Karte
gefunden hat.

Was das I4l angeht, und das laden der Karte
wie soll ich die Karte laden (von Hand) ich meine mit modprobe hisax type=5.... kann ich ja die neue ISDN-Karte nicht laden. und i4l nützt doch den Hisax Treiber oder? es sei den
ich benutze eine CAPI. Aber wie man die CAPI installiert etc. steht oben nicht drin.
Und wie schon gesagt ich habe kein SuSE sonder RedHat

Ich habe bei der Capi den entsprech. Treiber in /etc/capi.conf eingetragen und ein
capiinit start gemacht.
Dann lädt er mir ein paar Module und bringt dann die Meldung das er keine AVM B1 findet.
Ebenso kann ich dann danach das modul capifs nicht mehr entladen. ein rmmod capifs sagt
das das modul benutzt wird.

Kann mir da jemand weiterhelfen ?
Danke schonmal im Vorraus
 

cptchaos



Anmeldungsdatum: 06.06.2000
Beiträge: 129

BeitragVerfasst am: 04. Mai 2001 15:31   Titel: Re: CAPI + AVM Fritz Card PCI 2.0

Moin moin,

leider habe ich die Treiber selber noch nicht auf eine RH aufgezogen, kann aber mal versuchen das einbinden der Treiber zu beschreiben wie es eigendlich gehen sollte.

1. AVM Treiber besorgen, hierbei ist es wichtig die für die Treiber für die richtige Karte zu besorgen. Also keine B1 Treiber wenn Du eine ISA PNP hast.
Die eigene /etc/modules.conf sichern.

2. Treiber übersetzen und installieren. Hierbei ggf. die Konfigurationsdatei anpassen die AVM in etc ablegt (Port, IRQ) Steht alles im "Liesmich". Ggf. auch noch ISAPNP nutzten und Konfigurieren, das sollte aber schon laufen wenn Du die Karte vorher mit Hisax benutzt hast.


3. Nach dem Installieren verändert AVM bei SuSE die /etc/modules.conf, ob er dieses auch bei RH macht kann ich nicht sagen. Einfach nachschauen, ggf. die Änderungen von Hand eintragen (vorhergehendes Posting).
Danach werden beim Zugriff auf die ipppx Geräte die capi Treiber, und nicht die Hisax Treiber benutzt.

4. Dafür sorgen das keine Treiber aus dem i4l Paket geladen werden, auch nicht die B1 Treiber. Hierfür mußt Du schauen wie dieses bei dir gemacht wird, schätzt mal das Du hierfür ein entsprechendes Init Script anpassen mußt. Bei Suse wird hierfür die B1 Karte genommen und der Teil zum laden der B1 Treiber entfernt. Dafür wird hier das laden der AVM CAPI Treiber eingefügt. Danach muß nur noch Isdnlog gestartet werden. Auch hier mal im vorhergehenden Posting nachschauen.
In wie weit es jetzt noch Auswirkungen hat kann ich jetzt leider nicht nachprüfen, da mein Schleppy gerade kein ISDN hat. Es kann aber sein das beim Starten von Isdnlog oder weiteren I4L Komponenten hier die B1 als Karte angegeben werden muß. Das wird dann wohl daran liegen das die aktive B1 selber CAPI "spricht", und dieses für diese Karte auch schon im i4l Paket integriert.
ist. Auf jedenfall dürfen die B1 Treiber nicht aktiviert werden, es wird I4L nur vorgegaukelt das es sich um eine B1 handelt, damit es über die Capi Schnittstelle mit der Karte "spricht". Aus diesem Grunde muß vorher auch der AVM Capi Treiber geladen werden, und die Änderungen in der Modules Conf sind notwendig.

Wenn es Trotzdem noch Probleme gibt, prüfe bitte erst einmal ob die AVM Capi Treiber richtig geladen wurden. Denn ohne die wird es dann nämlich auch nicht klappen, ansonsten mal die Log und Startmeldungen posten mailen. Das verdammte Teil muß doch zum Laufen zu bekommen sein. Naja, und wie bereits gesagt habe ich leider kein RH, hoffe aber dir trotzdem weitergeholfen zu haben.

MfG Marek Walther
_________________
.... das gehört bei uns zum Service.
Ich brauche jetzt nur noch Ihre Keditkartennummer ....


Zuletzt bearbeitet von cptchaos am 04. Mai 2001 15:31, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy