Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
squid2.conf

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
dirk_kl



Anmeldungsdatum: 18.05.2001
Beiträge: 1

BeitragVerfasst am: 18. Mai 2001 17:11   Titel: squid2.conf

Hallo zusammen ;=)

ich habe ein Problem mit meiner squid2 Konfiguration und weiß nicht wie ich es beheben könnte... ich bin auch noch ein Linux Anfänger und mache gerade meine ersten Erfahrungen, desshalb sind mir manche Beschreibungen in Hilfe Dateien immer noch zu kompliziert ..
ich habe mein squid2 in das verzeichnis "/usr/local/squid/" mit ark entpackt und installiert.
danach habe ich versucht squid2 zu starten mit
/usr/local/squid/bin/squid
/usr/local/squid/bin/squid -z
jedoch kam eine Fehlermeldung: FATAL: Failed to make swap directory /usr/local/squid/cache/00: (13) Keine Berechtigung
Squid Cache (Version 2.4.STABLE1): Terminated abnormally.
CPU Usage: 0.010 seconds = 0.000 user + 0.010 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 17
---------------------
Welcher Eintrag in der squid.conf ist fehlerhaft oder falsch?? wo steht er und in was müßte ich ihn ändern....
------
Außerdem habe ich mal eine "fertige" squid.conf "kopiert" rein um zu sehen ob es funktioniert.. jedoch kam auch hier eine Fehlermeldung, wie folgt:
WARNING: No units on 'cache_mem 32MB' assuming 32.000000 bytes
FATAL: Unknows cache_dir type '/usr/local/squid/cache
....
-----------
hier habe ich auch mal die squid.conf..:
# begin /etc/squid.conf

http_port 3128
# icp_port 3130

# cache_peer wwwproxy.belwue.de parent 8080 0 no-query default

# Der Wert für cache_mem kann etwa 1/4 des
# Hauptspeichers (RAM) betragen. Bei 64MB-RAM wären dies 16MB
cache_mem 16 MB

cache_swap_low 90
cache_swap_high 95
maximum_object_size 4096 KB

# Die Parameter für cache_dir bemessen sich nach der Anzahl der
# Workstations und der zur Verfügung stehenden Festplatte.
# Minimum ist etwa 500 MB in 16 Verzeichnissen zu je 256 Einträgen
# Empfehlung: 1000 32 256 möglichst auf separater Festplatte
cache_dir /var/squid/cache 500 16 256

cache_access_log /var/squid/logs/access.log
cache_log /var/squid/logs/cache.log
cache_store_log /var/squid/logs/store.log
emulate_httpd_log on
debug_options ALL,1
dns_nameservers 127.0.0.1
negative_ttl 5 minutes

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 443 563
acl Safe_ports port 80 22 443 563 70 210 1025-65535
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

# http_access never_direct allow all
http_access allow all
icp_access allow all
miss_access allow all

cache_mgr admin@schuldomain.de
cache_effective_user squid
cache_effective_group nogroup

# end of /etc/squid.conf


ich bitte um Hilfe, was mache ich Falsch? wie muß ich was ändern?

Vielen Dank im Vorraus, Dirk_Kl
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

tr0nix
Gast





BeitragVerfasst am: 18. Mai 2001 23:49   Titel: Re: squid2.conf

Hi.

Mit squid -z erstellst du den Cache. Du musst allerdings die Berechtigungen des cache-verzeichniss wechseln waehrend/nach dem Installieren von Squid. Sonst hat der Squid keine write Berechtigung. Wie das alles genau machbar ist sollte eigentlich im README stehen (ich hab Squid auch schon ein paarmal aufgesetzt)..

Joel
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy