Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Firewall und Router
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Stingway
Gast





BeitragVerfasst am: 28. Jun 2001 12:35   Titel: Firewall und Router

Hallo zusammen,
ich habe in rc.config "START_FM="yes"" gesetzt. Somit wird die Firewall gestartet.

Die Konfiguration habe ich unten gepostet. So da ich DSL benutze wähle ich mcih mit "rcpppoed start" ein, bzw. aktiviere es und sobald eine Anfrage läuft wählt sich der Rechner ein. (DoD)
Nun möchte ich nciht anderes als das der Win2k Rechenr im Netzwerk der an eth0 hängt auch ins Internet gelangt. Was ist falsch in der Konfigurations Datei ? - Was muss ich im IE Broser einstellen damit die Verbindung aufgebaut wird. Habe schon verschiedenste Sachen probiert, doch leider klappt nichts. :(

# Copyright (c) 1999,2000 SuSE GmbH Nuernberg, Germany. All rights reserved.
#
# Author: Marc Heuse <marc@suse.de>, 1999,2000
# Please contact me directly if you find bugs.
#
# If you have problems getting this tool configures, please read this file
# carefuly and take also a look into
# /usr/share/doc/packages/firewals/EXAMPLES !
#
# /etc/rc.config.d/firewall.rc.config
#
# for use with /sbin/SuSEfirewall version 2.6
#
# ------------------------------------------------------------------------
#
# PLEASE NOTE THE FOLLOWING:
#
# Just by configuring these settings and using the SuSEfirewall you are
# not secure per se! There is *not* such a thing you install and hence you
# are safed from all (security) hazards.
#
# To ensure your security, you must also:
#
# * Secure all services you are offering to untrusted networks (internet)
# You can do this by using software which has been designed with
# security in mind (like postfix, apop3d, ssh), setting these up without
# misconfiguration and praying, that they have got really no holes.
# SuSEcompartment can help in most circumstances to reduce the risk.
# * Do not run untrusted software. (philosophical question, can you trust
# SuSE or any other software distributor?)
# * Harden your server(s) with the harden_suse package/script
# * Recompile your kernel with the openwall-linux kernel patch
# (former secure-linux patch, from Solar Designer) www.openwall.com
# * Check the security of your server(s) regulary
# * If you are using this server as a firewall/bastion host to the internet
# for an internal network, try to run proxy services for everything and
# disable routing on this machine.
# * If you run DNS on the firewall: disable untrusted zone transfers and
# either don't allow access to it from the internet or run it split-brained.
#
# Good luck!
#
# Yours,
# SuSE Security Team
#
# ------------------------------------------------------------------------
#
# Configuration HELP:
#
# If you have got any problems configuring this file, take a look at
# /usr/share/doc/packages/firewals/EXAMPLES for an example.
#
#
# All types have to set option 1): set START_FW in /etc/rc.config to "yes"
#
# If you are a end-user who is NOT connected to two networks you just have to
# reconfigure (all other settings are OK): 2), and maybe 9), 11), and 1Cool.
#
# If this server is a firewall, which should act like a proxy (no direct
# routing between both networks), or you are end end-user connected to the
# internet and to a internal network, you have to setup your proxys and
# reconfigure (all other settings are OK): 2), 3), 9) and maybe 7), 10), 11)
# 12), 14) and 1Cool.
#
# If this server is a firewall, and should do routing/masquerading between
# the untrusted and the trusted network, you have to reconfigure (all other
# settings are OK): 2), 3), 5), 6), 9), and maybe 7), 10), 11), 12), 15), 1Cool.
#
# If you want to run a DMZ in either of the above three standard setups, you
# just have to config 4), 9), 13) and maybe 19).
#
# If you know what you are doing, you may also change Cool, 16), 17), 1Cool
# and the expert options 20), 21), 22) at the far end, but you should NOT.
#
# If you use diald or ISDN autodialing, you might want to set 1Cool.
#
# To get programs like traceroutes to your firewall to work is a bit tricky,
# you have to set the following options to "yes" : 11 (UDP only), 19 and 20.
#
# If you want to load the full firewall rules for an interface even if it's not
# available, configure a static IP and netmask (see 2, 3 and 4 for an example).
#
# Please note that if you use service names, that they exist in /etc/services.
# There is no service "dns", it's called "domain", email is called "smtp" etc.
#
# If you use a modem/ISDN for connections, put "/sbin/SuSEfirewall" in the
# 2nd line of "/etc/ppp/ip-up". This is important!!
#
# *Any* routing between interfaces except masquerading has to set FW_ROUTE to
# "yes" and use FW_FORWARD_TCP and/or FW_FORWARD_UDP
#
# If you just want to do masquerading without filtering, ignore this script
# and run this line (exchange "ippp0" with your masquerade/external interface):
# ipchains -A forward -j MASQ -i ippp0
#
# ------------------------------------------------------------------------

#
# 1.)
# Should the Firewall be started?
#
# This setting is done in /etc/rc.config (START_FW="yes")

#
# 2.)
# Which is the interface that points to the internet?
#
# Enter all the network devices here which are untrusted.
#
# Choice: any number of devices, seperated by a space
# e.g. "eth0", "ippp0 ippp1"
#
FW_DEV_WORLD="ppp0"
#
# You *may* configure a static IP and netmask to force rule loading even if the
# interface is not up and running: set a variable called
# FW_DEV_WORLD_[device]="IP_ADDRESS NETMASK"
# see below for an example. Otherwise automatic detection is done.
# You will still need to set FW_DEV_WORLD first!
#
#FW_DEV_WORLD_eth1="10.0.0.1 255.255.255.0" # e.g. for exernal interface ippp0

#
# 3.)
# Which is the interface that points to the internal network?
#
# Enter all the network devices here which are trusted.
# If you are not connected to a trusted network (e.g. you have just a
# dialup) leave this empty.
#
# Choice: leave empty or any number of devices, seperated by a space
# e.g. "tr0", "eth0 eth1" or ""
#
FW_DEV_INT="eth0"
#
# You may configure a static IP and netmask to force rule loading even if the
# interface is not up and running: set a variable called
# FW_DEV_INT_[device]="IP_ADDRESS NETMASK"
# see below for an example. Otherwise automatic detection is done.
# You will still need to set FW_DEV_INT first!
#
#FW_DEV_INT_eth0="192.168.1.1 255.255.255.0" # e.g. for internal interface eth0

#
# 4.)
# Which is the interface that points to the dmz network?
#
# Enter all the network devices here which point to the dmz.
# A "dmz" is a special, seperated network, which is only connected to the
# firewall, and should be reachable from the internet to provide services,
# e.g. WWW, Mail, etc. and hence are at risk from attacks.
# See /usr/share/doc/packages/firewals/EXAMPLES for an example.
#
# Special note: You have to configure FW_FORWARD_TCP and FW_FORWARD_UDP to
# define the services which should be available to the internet and set
# FW_ROUTE to yes.
# Very special note: servers/networks in FW_MASQ_NETS may access the DMZ to
# the same extent they are allowed to access the internet! No FW_FORWARD_*
# needed ...
#
# Choice: leave empty or any number of devices, seperated by a space
# e.g. "tr0", "eth0 eth1" or ""
#
#FW_DEV_DMZ="eth1"
#
# You may configure a static IP and netmask to force rule loading even if the
# interface is not up and running: set a variable called
# FW_DEV_INT_[device]="IP_ADDRESS NETMASK"
# see below for an example. Otherwise automatic detection is done.
# You will still need to set FW_DEV_DMZ first!
#
#FW_DEV_DMZ_eth1="192.168.1.1 255.255.255.0" # e.g. for dmz interface eth1

#
# 5.)
# Should routing between the internet, dmz and internal network be activated?
# REQUIRES: FW_DEV_INT or FW_DEV_DMZ
#
# You need only set this to yes, if you either want to masquerade internal
# machines or allow access to the dmz (or internal machines, but this is not
# a good idea). This option supersedes IP_FORWARD from /etc/rc.config!
#
# Setting this option one alone doesn't do anything. Either activate
# massquerading with FW_MASQUERADE below if you want to masquerade your
# internal network to the internet, or configure FW_FORWARD_TCP and/or
# FW_FORWARD_UDP to define what is allowed to be forwarded!
#
# Choice: "yes" or "no", defaults to "no"
#
FW_ROUTE="yes"

#
# 6.)
# Do you want to masquerade internal networks to the outside?
# REQUIRES: FW_DEV_INT, FW_ROUTE
#
# "Masquerading" means that all your internal machines which use services on
# the internet seem to come from your firewall.
# Please note that it is more secure to communicate via proxies to the
# internet than masquerading
#
# Choice: "yes" or "no", defaults to "no"
#
FW_MASQUERADE="yes"
#
# Which internal computers/networks are allowed to access the internet
# directly (not via proxys on the firewall)?
# Only these networks will be allowed access and will be masqueraded!
#
# Please note this config changed in firewals-2.3: You may either use just
# hosts/nets to allow all traffic from them to the internet, or use an extended
# syntax, to restrict internet access to certain services!
#
# Choice: leave empty or any number of hosts/networks seperated by a space.
# Every host/network may get a list of allowed services, otherwise everything
# is allowed. A protocol and service is appended by a comma to the host/network.
# e.g. "10.0.0.0/8" allows the whole 10.0.0.0 network with unrestricted access
# "10.0.1.0/24,tcp,80 10.0.1.0/24,tcp,21" allows the 10.0.1.0 network to use
# www/ftp to the internet. "10.0.1.0/24,tcp,1024:65535 10.0.2.0/24" is OK too.
# You may NOT set this variable to "0/0" !
#
#FW_MASQ_NETS="192.168.17.0/24"
#
# If you want (and you should) you may also set the FW_MASQ_DEV option, to
# specify the outgoing interface to masquerade on. (You would normally use
# the external interface(s), the FW_DEV_WORLD device(s), e.g. "ippp0")
#
FW_MASQ_DEV="$FW_DEV_WORLD" # e.g. "ippp0" or "$FW_DEV_WORLD"

#
# 7.)
# Do you want to protect the firewall from the internal network?
# REQUIRES: FW_DEV_INT
#
# If you set this to "yes", internal machines may only access services on
# the machine you explicitly allow. They will be also affected from the
# FW_AUTOPROTECT_GLOBAL_SERVICES option.
# If you set this to "no", any user can connect (and attack) any service on
# the firewall.
#
# Choice: "yes" or "no", defaults to "yes"
#
FW_PROTECT_FROM_INTERNAL="no"

#
# 8.)
# Do you want to autoprotect all global running services?
#
# If set to "yes", all network access to services TCP and UDP on this machine
# which are not bound to a special IP address will be prevented (except to
# those which you explicitly allow, see below: FW_*_SERVICES_*)
# Example: "0.0.0.0:23" would be protected, but "10.0.0.1:53" not.
#
# Choice: "yes" or "no", defaults to "yes"
#
FW_AUTOPROTECT_GLOBAL_SERVICES="yes" # "yes" is a good choice

#
# 9.)
# Which services on the firewall should be accessible from either the internet
# (or other untrusted networks), the dmz or internal (trusted networks)?
#
# Enter all ports or known portnames below, seperated by a space.
# TCP services (e.g. SMTP, WWW) must be set in FW_SERVICES_*_TCP, and
# UDP services (e.g. syslog) must be set in FW_SERVICES_*_UDP.
# e.g. if a webserver on the firewall should be accessible from the internet:
# FW_SERVICES_EXTERNAL_TCP="www"
# e.g. if the firewall should receive syslog messages from the dmz:
# FW_SERVICES_DMZ_UDP="syslog"
#
# Choice: leave empty or any number of ports, known portnames (from
# /etc/services) and port ranges seperated by a space. Port ranges are
# written like this, from 1 to 10: "1:10"
# e.g. "", "smtp", "123 514", "3200:3299", "ftp 22 telnet 512:514"
#
FW_SERVICES_EXTERNAL_TCP="" # Common: smtp domain
FW_SERVICES_EXTERNAL_UDP="" # Common: domain
#
FW_SERVICES_DMZ_TCP="" # Common: smtp domain
FW_SERVICES_DMZ_UDP="" # Common: domain syslog
#
FW_SERVICES_INTERNAL_TCP="" # Common: ssh smtp domain
FW_SERVICES_INTERNAL_UDP="" # Common: domain

#
# 10.)
# Which services should be accessible from trusted hosts/nets on the internet?
#
# Define trusted networks on the internet, and the TCP and/or UDP services
# they are allowed to use.
#
# Choice: leave FW_TRUSTED_NETS empty or any number of computers and/or
# networks, seperated by a space. e.g. "172.20.1.1", "172.20.0.0/16"
#
FW_TRUSTED_NETS=""
#
# leave FW_SERVICES_TRUSTED_* empty or any number of ports, known portnames
# (from /etc/services) and port ranges seperated by a space.
# e.g. "25", "ssh", "1:65535", "1 3:5"
#
FW_SERVICES_TRUSTED_TCP="" # Common: ssh
FW_SERVICES_TRUSTED_UDP="" # Common: syslog time ntp

#
# 11.)
# How is access allowed to high (unpriviliged [above 1023]) ports?
#
# You may either allow everyone from anyport access to your highports ("yes"),
# disallow anyone ("no"), anyone who comes from a defined port (portnumber or
# known portname) [note that this is easy to circumvent!], or just your
# defined nameservers ("dns").
# Note that if you want to use normal (active) ftp, you have to set the TCP
# option to ftp-data. If you use passive ftp, you don't need that.
# Note that you can't use rpc requests (e.g. rpcinfo, showmount) as root
# from a firewall using this script.
#
# Choice: "yes", "no", "dns", portnumber or known portname, defaults to "no"
#
FW_ALLOW_INCOMING_HIGHPORTS_TCP="yes" # Common: "ftp-data" (sadly!)
FW_ALLOW_INCOMING_HIGHPORTS_UDP="yes" # Common: "dns"

#
# 12.)
# Are you running some of the services below?
# They need special attention - otherwise they won´t work!
#
# Set services you are running to "yes", all others to "no", defaults to "no"
#
FW_SERVICE_DNS="no" # if yes, FW_SERVICES_*_TCP needs to have port 53
# (or "domain") set to allow incoming queries.
# also FW_ALLOW_INCOMING_HIGHPORTS_UDP needs to be "yes"
FW_SERVICE_DHCLIENT="no" # if you use dhclient to get an ip address
# you have to set this to "yes" !
FW_SERVICE_DHCPD="no" # set to "yes" if this server is a DHCP server
FW_SERVICE_SAMBA="yes" # set to "yes" if this server uses samba as client
# or server. As a server, you still have to set
# FW_SERVICES_{WORLD,DMZ,INT}_TCP="139"
# Everyone may send you udp 137/138 packets if set
# to yes!
# (note: samba on the firewall is not a good idea!)

#
# 13.)
# Which services accessed from the internet should be allowed to the
# dmz (or internal network - if it is not masqueraded)?
# REQUIRES: FW_ROUTE
#
# With this option you may allow access to e.g. your mailserver. The
# machines must have valid, non-private, IP addresses which were assigned to
# you by your ISP. This opens a direct link to your network, so only use
# this option for access to your dmz!!!!
#
# Choice: leave empty (good choice!) or use the following explained syntax
# of forwarding rules, seperated each by a space.
# A forwarding rule consists of 1) source IP/net, 2) destination IP (dmz/intern)
# and 3) destination port, seperated by a comma (","), e.g.
# "4.0.0.0/8,1.1.1.1,22",
# "4.4.4.4/12,20.20.20.20,22 12.12.12.12/12,20.20.20.20,22"
#
FW_FORWARD_TCP="" # Beware to use this!
FW_FORWARD_UDP="" # Beware to use this!

#
# 14.)
# Which services accessed from the internet should be allowed to masqueraded
# servers (on the internal network or dmz)?
# REQUIRES: FW_ROUTE, FW_MASQUERADE
#
# With this option you may allow access to e.g. your mailserver. The
# machines must be in a masqueraded segment and may not have public IP addesses!
#
# Please note that this should *not* be used for security reasons! You are
# opening a hole to your precious internal network. If e.g. the webserver there
# is compromised - your full internal network is compromised!!
#
# Choice: leave empty (good choice!) or use the following explained syntax
# of forward masquerade rules, seperated each by a space.
# A forward masquerade rule consists of 1) source IP/net, 2) destination IP
# (dmz/intern) and 3) destination port, seperated by a comma (","), e.g.
# "4.0.0.0/8,1.1.1.1,22",
# "4.4.4.4/12,20.20.20.20,22 12.12.12.12/12,20.20.20.20,22"
#
FW_FORWARD_MASQ_TCP="" # Beware to use this!
FW_FORWARD_MASQ_UDP="" # Beware to use this!

#
# 15.)
# Which accesses to services should be redirected to a localport on the
# firewall machine?
#
# This can be used to force all internal users to surf via your squid proxy,
# or transparently redirect incoming webtraffic to a secure webserver.
#
# Choice: leave empty or use the following explained syntax of redirecting
# rules, seperated by a space.
# A redirecting rule consists of 1) source IP/net, 2) destination IP/net,
# 3) original destination port and 4) local port to redirect the traffic to,
# seperated by a colon. e.g. "10.0.0.0/8,0/0,80,3128 0/0,172.20.1.1,80,8080"
#
FW_REDIRECT_TCP=""
FW_REDIRECT_UDP=""

#
# 16.)
# Which logging level should be enforced?
# You can define to log packets which were accepted or denied.
# You can also the set log level, the critical stuff or everything.
# Note that logging *_ALL is only for debugging purpose ...
#
# Choice: "yes" or "no", FW_LOG_*_CRIT defaults to "yes",
# FW_LOG_*_ALL defaults to "no"
#
FW_LOG_DENY_CRIT="yes"
FW_LOG_DENY_ALL="no"
FW_LOG_ACCEPT_CRIT="yes"
FW_LOG_ACCEPT_ALL="no"

#
# 17.)
# Do you want to enable additional kernel TCP/IP security features?
# If set to yes, some obscure kernel options are set.
# (icmp_ignore_bogus_error_responses, icmp_echoreply_rate,
# icmp_destunreach_rate, icmp_paramprob_rate, icmp_timeexeed_rate,
# ip_local_port_range, log_martians, mc_forwarding, mc_forwarding,
# rp_filter, routing flush)
# Tip: Set this to "no" until you have verified that you have got a
# configuration which works for you. Then set this to "yes" and keep it
# if everything still works. (It should!)
#
# Choice: "yes" or "no", defaults to "yes"
#
FW_KERNEL_SECURITY="yes"

#
# 18.)
# Keep the routing set on, if the firewall rules are unloaded?
# REQUIRES: FW_ROUTE
#
# If you are using diald, or automatic dialing via ISDN, if packets need
# to be sent to the internet, you need to turn this on. The script will then
# not turn off routing and masquerading when stopped.
# You *might* also need this if you have got a DMZ.
# Please note that this is *insecure*! If you unload the rules, but are still
# connected, you might your internal network open to attacks!
# The better solution is to remove "/sbin/SuSEfirewall stop" or
# "/sbin/init.d/firewall stop" from the ip-down script!
#
#
# Choices "yes" or "no", defaults to "no"
#
FW_STOP_KEEP_ROUTING_STATE="no"

#
# 19.)
# Allow (or don't) ICMP echo pings on either the firewall or the dmz from
# the internet?
# REQUIRES: FW_ROUTE for FW_ALLOW_PING_DMZ
#
# Choice: "yes" or "no", defaults to "no"
#
FW_ALLOW_PING_FW="yes"
FW_ALLOW_PING_DMZ="no"

##
# END of rc.firewall
##

# #
#-------------------------------------------------------------------------#
# #
# EXPERT OPTIONS - all others please don't change these! #
# #
#-------------------------------------------------------------------------#
# #

#
# 20.)
# Allow (or don't) ICMP time-to-live-exceeded to be send from your firewall.
# This is used for traceroutes to your firewall (or traceroute like tools).
#
# Please note that the unix traceroute only works if you say "yes" to
# FW_ALLOW_INCOMING_HIGHPORTS_UDP, and windows traceroutes only if you say
# "yes" to FW_ALLOW_PING_FW
#
# Choice: "yes" or "no", defaults to "no"
#
FW_ALLOW_FW_TRACEROUTE="no"

#
# 21.)
# Allow ICMP sourcequench from your ISP?
# If set to yes, the firewall will notice when connection is choking, however
# this opens yourself to a denial of service attack. Choose your poison.
#
# Choice: "yes" or "no", defaults to "yes"
#
FW_ALLOW_FW_SOURCEQUENCH="yes"

#
# 22.)
# Which masquerading modules should be loaded?
# REQUIRES: FW_ROUTE, FW_MASQUERADE
#
# (omit the path or "ip_masq_" prefix as well as the ".o" suffix!)
#
FW_MASQ_MODULES="autofw cuseeme ftp irc mfw portfw quake raudio user vdolive"
 

Stingway
Gast





BeitragVerfasst am: 28. Jun 2001 12:36   Titel: Re: Firewall und Router

Achja, Distri: 7.0 , Kernel: 2.2.x
 

Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 28. Jun 2001 13:28   Titel: Re: Firewall und Router

Hast Du auch jede Menge DENY Einträge in der /var/log/messages?
Wenn ja, habe gestern zu gleichem Thema einen Thread unter Software aufgemacht.
Faktum ist, sobald die FW gestopt wird, klappen sämtliche Zugänge.

Aber Du solltest
FW_SERVICES_INTERNAL_TCP="" # Common: ssh smtp domain
FW_SERVICES_INTERNAL_UDP="" # Common: domain
etwas anpassen.
Etwa in Form von
FW_SERVICES_INTERNAL_TCP="21 22 53 80 139 3000 3128 3130 4827" (ftp ftp ssh dns http smb ntop squid squid squid)
FW_SERVICES_INTERNAL_UDP="53" (dns)

Ansonsten macht auch der Eintrag
FW_PROTECT_FROM_INTERNAL="no"
keinen Sinn (wenn Du keinen Zugriff auf die FW erlaubst, brauchst Du dies nicht zu gestatten Smile).
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)
 
Benutzer-Profile anzeigen Private Nachricht senden

Stingway
Gast





BeitragVerfasst am: 28. Jun 2001 14:53   Titel: Re: Firewall und Router

Hm klappt einfach nciht. SO Meldungen bekomme ich auch nicht.

Kann es sein das meine route.conf Datei falsch eingestellt ist ?


Dort sind nur 2 zeilen aktiv:

192.168.17.40 0.0.0.0 255.255.255.0 eth0 #Lokales Netz
1.1.1.1 0.0.0.0 255.255.255.0 eth1 #DSL

Die IP für DSL habe ich wahrlos gewählt, da ich von der Telekom ja eine dynamisch zugewiesen bekomme.
Ist vielleich der Haken in dieser datei ?
 

Boron
Gast





BeitragVerfasst am: 28. Jun 2001 15:04   Titel: Re: Firewall und Router

Hallo Stingway,

vielleicht solltest du unter 6.) in der Datei firewall.rc.config den Punkt "#FW_MASQ_NETS="192.168.17.0/24"" aktivieren, also ohne den Gartenzaun. Schließlich soll deine Firewall auch wissen welche Rechner überhaupt Zugang zum Internet bekommen sollen. Offensichtlich hast du die IP deines internen Rechners eingetragen, unglücklicherweise aber noch ein # davor gemacht.
 

Stingway
Gast





BeitragVerfasst am: 28. Jun 2001 15:49   Titel: Re: Firewall und Router

Hallo, leider funktioniert das auch nciht:(
Ich kann mich zwar ganz normal einwählen, habe aber keinen zugriff vom windows client.

Ich verzweifele noch an diesem Routing. Es geht einfach nichts. Ich habe auch schon probiert ohne die linux firewall und dann mit ipchains masquerading freigeschaltet, aber es ging nicht Sad
 

Stingway
Gast





BeitragVerfasst am: 28. Jun 2001 16:02   Titel: Re: Firewall und Router

Muss ich eventuell noch etwas besonderes bei der Einstellung des Win2000 Clienten beachten ?
 

Sven
Gast





BeitragVerfasst am: 28. Jun 2001 16:06   Titel: Re: Firewall und Router

Hat jeder Win2000 Client seine individuelle IP-Adresse?
 

Boron
Gast





BeitragVerfasst am: 28. Jun 2001 16:19   Titel: Re: Firewall und Router

Da fällt mir noch was ein. Trage bei deinem Windows PC bei den TCP/IP Einstellungen als Standardgateway die IP der Netzwerkkarte des Linux-Rechners ein, da dieser ja jetzt gewissermassen dein Gateway ist.
 

Stingway
Gast





BeitragVerfasst am: 28. Jun 2001 16:27   Titel: Re: Firewall und Router

Jep, genau das war es.

Leider findet mamn diesen hinweis in wirklich keinem TUT. Bitte liebes Pro-Linux Team, ich weiß nciht obe es bei euch drin steht, aber weißt darauf hin:

"Bei TCP/IP in Windows die Linux IP als Gateway angeben."
 

Boron
Gast





BeitragVerfasst am: 28. Jun 2001 16:31   Titel: Re: Firewall und Router

*Triumph*,*Freudentanz*

Jezt prüfe doch bitte mal, ob du von deinem Windows Rechner per ftp auf irgendwas zugreifen kannst, z.B. ftp.kde.org.
Wenn das bei dir klappt, dann bin ich deprimiert, wenn das NICHT klappt, dann hast du das selbe Problem wie ich (bereits seit zwei Wochen, und niemand konnte mir helfen).
 

Stingway
Gast





BeitragVerfasst am: 28. Jun 2001 16:39   Titel: Re: Firewall und Router

Leider funktioniert das nicht. FTP geht nicht. Sad Schon eine Lösung gefunden ?
 

Boron
Gast





BeitragVerfasst am: 28. Jun 2001 16:45   Titel: Re: Firewall und Router

Nein, leider nicht. Genau das ist mein Problem.
 

Stingway
Gast





BeitragVerfasst am: 28. Jun 2001 16:49   Titel: Re: Firewall und Router

Also, bei mir funzt FTP doch.
Aber ich habe folgendes Symtom:

Erst lädet der sehr lange und cih sehe in der Linux Server Log: ".......DENY......".... mein FTP Prog versucht jeodhc immer weiter die Verbindung aufzubauen und nach 30 Sekunden funktioniert es einwandfrei.
Woran liegt sowas ?
 

Boron
Gast





BeitragVerfasst am: 28. Jun 2001 17:00   Titel: Re: Firewall und Router

Jetzt sollte ich mich umbenennen: ab sofort bin ich "Ratlos".
Das hier ist mein Phänomen:

E:\>ftp ftp.kde.org
Verbindung mit max.tat.physik.uni-tuebingen.de wurde hergestellt.
220-Local time is now 17:56 and the load is 0.16.
220 You will be disconnected after 1800 seconds of inactivity.
Benutzer (max.tat.physik.uni-tuebingen.de:(none)): anonymous
230 Anonymous user logged in.
ftp> ls
425 Will not open connection to 192.168.0.20 (only to 141.37.205.39)
ftp> bye
221-Goodbye. You uploaded 0 and downloaded 0 kbytes.
221 CPU time spent on you: 0.020 seconds.
E:\

Die IP 192.168.0.20 hab ich an meinem internen Windows Rechner die 141.... ist die IP mit der mein Router + FW ins Netz geht.
Ich hab keine Chanche per ftp was zu machen.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy