Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Routing-Problem

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Evilsgate
Gast





BeitragVerfasst am: 19. Jul 2001 11:11   Titel: Routing-Problem

Ich hab ein kleines routing Problem und will mal fragen ob jemand mir da weiterhelfen kann.
Immer wenn mein Windowsrechner im Internet ist, kann der Linux-Server der als Router fungiert nicht mehr in ein anderes Netz routen, wo noch ein dritter Rechner vorhanden ist.
Hier eine Kleine Skizze:

Internet<->Windowsrechner(192.168.1.66)<->Linuxrouter(192.168.1.65, 192.168.1.33)<->Linuxrechner(192.168.1.34)
Subnetmaske:255.255.255.224

Im Linuxrouter sind logischerweise 2 Netzwerkkarten drin. Deswegen die 2 IP-Adressen.
Wie gesagt, wenn der Windowsrechner im Internet ist, routet der Linuxrouter nicht mehr in das Subnet 192.168.1.32.
Sobald die Verbindung wieder getrennt ist funktioniert alles wieder wie es soll. Was mache ich da falsch? Aber bitte keine Antworten wie: "Ersetz den Windowsrechner gegen einen Linuxrechner." Das läst sich leider nicht ändern.
 

hugenay
Gast





BeitragVerfasst am: 19. Jul 2001 11:47   Titel: Re: Routing-Problem

Und was passiert mit der route vom linux rechner in das 64er netz? Vielleicht liegts ja am routing des windows rechners ...
btw: Hast du nen vorteil davon, dass class c netzwerk nochmal in subnetze zu unterteilen?
 

Evilsgate
Gast





BeitragVerfasst am: 19. Jul 2001 18:53   Titel: Re: Routing-Problem

Der Windows und der Linuxrechner sind beide mit dem Linuxrouter verbunden. Vom Windowsrechner zum Router besteht eine 100MBit-Verbindung. Vom Linuxrechner zum Router besteht eine 10Mbit-Verbindung.
Wie meinst du das denn mit dem routing vom Windowsrechner? So hier sind die Routingtabellen:
Windowsrechner
Wärend der Internetverbindung
Aktive Routen:

Netzwerkadresse :: Subnet Mask :: Gateway-Adresse :: Schnittstelle:: Anzahl
-------------------------------------------------------------------------------
0.0.0.0 :: 0.0.0.0 :: 192.168.1.33 :: 192.168.1.66 :: 2
0.0.0.0 :: 0.0.0.0 :: 192.168.1.65 :: 192.168.1.66 :: 2
0.0.0.0 :: 0.0.0.0 :: 213.6.3.24 :: 213.6.3.24 :: 1
10.0.0.0 :: 255.0.0.0 :: 10.0.49.53 :: 10.0.49.53 :: 2
10.0.49.53 :: 255.255.255.255 :: 127.0.0.1 :: 127.0.0.1 :: 1
127.0.0.0 :: 255.0.0.0 :: 127.0.0.1 :: 127.0.0.1 :: 1
192.168.1.64 :: 255.255.255.224 :: 192.168.1.66 :: 192.168.1.66 :: 2
192.168.1.66 :: 255.255.255.255 :: 127.0.0.1 :: 127.0.0.1 :: 1
192.168.1.255 :: 255.255.255.255 :: 192.168.1.66 :: 192.168.1.66 :: 1
213.6.3.0 :: 255.255.255.0 :: 213.6.3.24 :: 213.6.3.24 :: 1
213.6.3.24 :: 255.255.255.255 :: 127.0.0.1 :: 127.0.0.1 :: 1
224.0.0.0 :: 224.0.0.0 :: 10.0.49.53 :: 10.0.49.53 :: 1
224.0.0.0 :: 224.0.0.0 :: 213.6.3.24 :: 213.6.3.24 :: 1
224.0.0.0 :: 224.0.0.0 :: 192.168.1.66 :: 192.168.1.66 :: 1
255.255.255.255 :: 255.255.255.255 :: 213.6.3.24 :: 213.6.3.24 :: 1

Ohne Internetverbindung

Netzwerkadresse :: Subnet Mask :: Gateway-Adresse :: Schnittstelle:: Anzahl
-------------------------------------------------------------------------------
0.0.0.0 :: 0.0.0.0 :: 192.168.1.33 :: 192.168.1.66 :: 1
0.0.0.0 :: 0.0.0.0 :: 192.168.1.65 :: 192.168.1.66 :: 1
10.0.0.0 :: 255.0.0.0 :: 10.0.49.53 :: 10.0.49.53 :: 1
10.0.49.53 :: 255.255.255.255 :: 127.0.0.1 :: 127.0.0.1 :: 1
127.0.0.0 :: 255.0.0.0 :: 127.0.0.1 :: 127.0.0.1 :: 1
192.168.1.64 :: 255.255.255.224 :: 192.168.1.66 :: 192.168.1.66 :: 1
192.168.1.66 :: 255.255.255.255 :: 127.0.0.1 :: 127.0.0.1 :: 1
192.168.1.255 :: 255.255.255.255 :: 192.168.1.66 :: 192.168.1.66 :: 1
224.0.0.0 :: 224.0.0.0 :: 10.0.49.53 :: 10.0.49.53 :: 1
224.0.0.0 :: 224.0.0.0 :: 192.168.1.66 :: 192.168.1.66 :: 1
255.255.255.255 :: 255.255.255.255 :: 10.0.49.53 :: 0.0.0.0 :: 1


Vielleicht findest du ja was was da nicht sein sollte. Die IP 10.0.49.53 gehört zu einer DVB-Karte und ist fürs Internet nich wichtig.
 

hugenay
Gast





BeitragVerfasst am: 19. Jul 2001 19:28   Titel: Re: Routing-Problem

das ist der output der win-rechners? sorry, dazu fallen mir nur fragen ein: wo steht das destination netzwerk der routen und was soll der eintrag schnittstelle? Dein problem ist vielleicht sehr winspezifisch.
Der Windowsrechner hat ne direkte verbindung zum internet und nicht der linuxrouter? dann sind ja die routen des win rechners falsch (ok, das ist banal).
tja... vielleicht kennt sich einer mit routing unter win aus?
 

Evilsgate
Gast





BeitragVerfasst am: 19. Jul 2001 20:40   Titel: Re: Routing-Problem

genauso sieht es aus. Der Windowsrechner ist direkt mit dem Internet verbunden.
 

Evilsgate
Gast





BeitragVerfasst am: 19. Jul 2001 22:00   Titel: Re: Routing-Problem

hab das Problem lokalisiert. Das liegt tatsächlich an Windows ist aber auch auf Linux übertragbar. Es ist so, dass das Standardgateway zum Linuxrouter, durch das Standardgateway des ISP überschrieben wird. Dadurch ist auch keine Verbindung in ein anderes Subnet mehr möglich. Wird die Verbindung wieder abgebaut, ist das Standardgatway zum Linuxrouter wiederhergestellt und alles funktioniert wieder. Hat jemand ne Idee wie man das Prob lösen kann?
 

Meinolf
Gast





BeitragVerfasst am: 20. Jul 2001 3:55   Titel: Re: Routing-Problem

Hallo.
Also: Das ist zwar wie gesagt ein Win Problem, aber ich hoffe, das ich helfen kann.
Du müsstest auf dem Win Rechner zwei Netzwerkschnittstellenn haben. Erstens das DFü Netzwerk, und zweitens die Schnittstelle zum Intranet.
Die Netzwerkarte zum Intranet kannst du anders konfigurieren(über Eigenschaften) als das DFÜ Netzwerk.
Bei mir klappt das auf ner Linuxkiste sehr gut, und sollte auch auf einer Winkiste laufen.
Nochwas: Warum hast du die Subnetmask auf 255.255.255.224 stehen. Für die IP Adressen brauchst du doch die Subnetzmasekn 255.255.255.0(was übrigens hugenay schon meinte).
Grüsse
Meinolf
 

hugenay
Gast





BeitragVerfasst am: 20. Jul 2001 7:47   Titel: Re: Routing-Problem

255.255.255.224 ist schon richtig als subnetzmaske, dann hat er 8 moegliche subnetze innerhalb von 192.168.1. Vielleicht ist das routen zwischen subnetzen dann schneller? wer weiss.
@wir das standardgateway ueberschrieben, oder vielleicht setzt windows einfach die subnetzmaske der dfue einstellungen fuer alle netze?
unter www.spotlight.de gibts nen windows forum und auch nen netzwerk forum, da wuerd ich nochmal posten
gruss hug.
 

Evilsgate
Gast





BeitragVerfasst am: 20. Jul 2001 13:59   Titel: Re: Routing-Problem

Das liegt wirklich nur an diesem doofen Standardgateway. Bei den Verbindungseigenschaften steht bei Servertypen was von TCP/IP Einstellungen.
Wenn man das Häkchen bei "Standardgateway im Remotenetzwerk verwenden" wegnimmt läuft alles so wie es soll. Jedenfalls im Privaten Netzwerk. Aber dann spinnt das Internet. Ich werd aber auf allefälle nochmal im Spotlight Forum nachfragen. Erstmal Danke für Eure Hilfe. Ich werd auch mal versuchen meinen ehemaligen Informatiklehrer um Hilfe zu bitten. Bisjetzt ist die einzigste Lösung sich einen Switch zu kaufen. Damit ich aus den 2 Subnetzen wieder ein ganzes machen kann. Und dann klappt das ja auch alles. Aber ich denke das das nicht die Lösung sein kann. In großen Firmen muss das ja schließlich auch gehen.
 

Evilsgate
Gast





BeitragVerfasst am: 20. Jul 2001 16:21   Titel: Re: Routing-Problem

Ich hab das Problem gelöst!!!!!!!!!!!!!!
ich hab Windows einfach gesagt das hinter dem Linuxrouter noch ein Subnet vorhaden ist.
Und das ist der Befehl dazu:
route add 192.168.1.32 mask 255.255.255.224 192.168.1.65
| | |
da ist noch ein Subnet hier die Subnetmask Und das ist die IP vom Linuxrouter, die sowieso vom .1.64 Subnetz erreichbar ist

Ich will mich hiermit nochmal ganz doll bei Eurer Hilfe bedanken.
Gruß Evilsgate
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy