Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Samba oder Hardware Problem ?

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Pit
Gast





BeitragVerfasst am: 24. Jul 2001 15:21   Titel: Samba oder Hardware Problem ?

Hallo

habe seit ca. 6 Tagen ein Problem mit unserem Linux-Server im Büro

System SuSE 7.0, Kernel 2.2.16, Samba 2.07

das system ist ein server der überwiegend für die Ablage von Vorlagen für
Word 7.0 verwendet wird. Bis vor 6 tagen lief alles einwandfrei. Änderungen
am System wurden nicht vorgenommen.

Zwischenzeitlich bricht die Verbindung zum Server aus nicht
nachvollziehbaren Gründen ab, mal nach 10 minuten mal nach 60 Minuten. Der
Server ist dann nicht mehr in der Netzwerkumgebung sichtbar.
Manchmal funktioniert das System nach ein paar sekunden wieder, manchmal
benötigt man für den erneuten Zugriff ein paar minuten.
in der /var/log/messages ist nicht auffälliges festzustellen.
Lediglich in der /var/log/log.smb erscheint folgende Fehlermeldung.

[2001/07/24 13:56:58, 0] lib/util_sock.c:read_socket_data(477)
read_socket_data: recv failure for 4. Error = Connection reset by peer
[2001/07/24 13:56:58, 1] smbd/service.c:close_cnum(583)
pc001121 (172.16.1.121) closed connection to service infos

Kann mir jemand sagen was diese Fehlermeldung bedeutet bzw. was auf meinem
System passiert.
Wie gesagt Änderungen am System wurden nicht vorgenommen.

Gruss Pit
 

MartinHeuser
Gast





BeitragVerfasst am: 25. Jul 2001 14:20   Titel: Re: Samba oder Hardware Problem ?

Poste mal die smb.conf
 

Pit
Gast





BeitragVerfasst am: 26. Jul 2001 9:53   Titel: Re: Samba oder Hardware Problem ?

Hallo,

anbei die smb.conf

# Samba config file created using SWAT
# from 172.16.1.71 (172.16.1.71)
# Date: 2001/07/26 10:17:01

# Global parameters
[global]
workgroup = PERSONALABTLG.
netbios name = SCHWARZ
server string = INFOCENTER
interfaces = 172.16.1.180/255.255.255.0
security = SHARE
map to guest = Bad User
keepalive = 30
os level = 2
guest account = info

[infos]
comment = infos
path = /home/data/
username = info
guest account =
read only = No

Gruss Pit
 

MartinHeuser
Gast





BeitragVerfasst am: 26. Jul 2001 10:06   Titel: Re: Samba oder Hardware Problem ?

Ahja... also zum einen mach mal den Arbeitsgruppennamen kleiner und ohne Sonderzeichen (.)
Dann prüfe, ob der Bad User usw. richtig gesetzt ist. Der Abbruch ist zwar auf Protokoll Ebene, aber wenn
"dumme" Strings mitgesendet werden (z.B. Arbeitsgruppe = bla.sülz.schwall.usw.) dann kommt es auch zu solchen Abbrüchen.

Versuch das erstmal.

Gruß Martin
 

MartinHeuser
Gast





BeitragVerfasst am: 26. Jul 2001 10:08   Titel: Re: Samba oder Hardware Problem ?

Achso.. ich hatte mal nen Ähnlichen Fehler... Letztenendes war das Problem, das der Gast User nicht existierte.
 

Pit
Gast





BeitragVerfasst am: 27. Jul 2001 16:30   Titel: Re: Samba oder Hardware Problem ?

Hallo,

habe alles wie angegegeben ausprobiert. Ergebnis: am Donnerstag lief die Kiste den ganzen Tag ohne Verbindungsabbruch und ohne Fehlermeldungen. Heute, Freitag nur noch Abbrüche im 10 Minuten Rythmus. Geiles Teil echt.

Gruss Pit
 

MartinHeuser
Gast





BeitragVerfasst am: 27. Jul 2001 16:51   Titel: Re: Samba oder Hardware Problem ?

K

Dann erweitere mal die [Globals] mit:
oplocks = no
kerneloplocks = no


dann schau mit "ps -x" nach dem smbd. Dann machste ein kill -9 auf die ID vom smbd (erste spalte). Aber nicht, während einer drauf zugreift!

dann starte mal den smbd per hand neu. also /usr/local/samba/bin/smbd -D -d 1
den pfad kannst du bei ps -x sehen. wenn nicht, dann suche mit "locate smbd" den richtigen pfad

Dann läuft er wieder und schreibt etwas mehr (debug level=1) in /var/log/messages oder /var/log/smb.log
Den Debug Level kannst Du so auch höher schrauben -d 5 oder -d 99 aber probier erstmal mit 1

Dann lass wieder auf der Kiste arbeiten und schau Dir mit "tail -f /var/log/smb.log" die logdatei an. Wenn neue zeilen dazu kommen, wird das vom tail -f automatisch mit eingeblendet. im idealfall sollte die schüssel dann was ausspucken was ihr nicht passt.

Gruß Martin
 

Pit
Gast





BeitragVerfasst am: 15. Aug 2001 14:47   Titel: Re: Samba oder Hardware Problem ?

Hallo alle zusammen,

seit heute funktioniert mein server wieder.Das Problem war so einfach wie blöde. Aus einem nicht nachvollziehbaren Grund wurde die IP-Nummer des Servers für einen weiteren PC vergeben. Datenschrott ohne Ende. Neue IP für den Server vergeben und es funktioniert.

Dank an alle die bei der Problembehebung teilgenommen haben.

Gruss Pit
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy