Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
[Frage] .htaccess unter Mandrake 8.0 funktioniert nicht ...

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Edward Nygma
Gast





BeitragVerfasst am: 13. Sep 2001 12:47   Titel: [Frage] .htaccess unter Mandrake 8.0 funktioniert nicht ...

hallo zusammen,

ich habe versuchsweise einen apache 1.3.x intranetserver unter mandrake 8.0 aufgesetzt. da ich nun einen teil des website nur gegen benutzername und passwort zugänglich machen will, suchte ich nach einer lösung und fand .htaccess. nur wenn ich .htacces und .htpasswd in dem zu schützenden ordner nach den anleitungen die es so im web gibt installiere wird bei einem zugriff auf den geschützten bereich trotzdem nicht nach den zugangsdaten gefragt. ich vermute in der httpd.conf muss noch ein schalter gesetzt werden, nur welcher.

ich habe mir im augenblick nun so geholfen dass ich in die httpd.conf eine <directory> regel im bereich des virtuellen webservers erstellt habe die den zugriff über eine .htpasswd regelt. das funktioniert auch ist in meinen augen aber nicht so elegant und administrationsfreundlich wie eine .htaccess in den betroffenen ordnern.

wer von euch weiss rat ...
danke im vorraus

edward
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 16. Sep 2001 8:41   Titel: Re: [Frage] .htaccess unter Mandrake 8.0 funktioniert nicht ...

Hi,

hier die gesuchte Option:

# This controls which options the .htaccess files in directories can
# override. Can also be "None", or any combination of "Options", "FileInfo",
# "AuthConfig", and "Limit"

AllowOverride All

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Edward Nygma
Gast





BeitragVerfasst am: 17. Sep 2001 9:52   Titel: Danke und Hiiiiiiiiiilllllllllllffffffffeeeeee ....

@hjb

hi,
erstmal danke für die hilfe. da ich am wochenende leider nicht da war kam ich erst heute dazu deinen tip auzuprobieren. da ich mir nicht sicher war wo ich das ALLOWOVERRIDE zu setzen habe bin ich sinngemäß von folgendem ausgegangen: ich habe in der httpd.conf im bereich eines virtuellen host eine directory regel erstellt ...

<Directory /var/www/intranet>
AllowOverride All
</Directory>

nachdem ich dann in dem entsprechenden unterverzeichnis (../intranet/secure) die .htaccess und .htpasswd angelegt habe bekomme ich nun wenigstens eine fehlermeldung wenn ich versuche den geschützten bereich aufzurufen (vorher kam garnichts - also sehe ich zumindest einen fortschritt Wink).

hier die fehlermeldung:
Authorization Required
This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.


--------------------------------------------------------------------------------

Apache-AdvancedExtranetServer/1.3.19 Server at website Port 80


fällt dir dazu vielleicht noch was ein.

edward
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy