Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
NFS zwischen Suse 7.2 und Red Hat 7.1

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Patrick
Gast





BeitragVerfasst am: 08. Nov 2001 0:43   Titel: NFS zwischen Suse 7.2 und Red Hat 7.1

Hallo Leute!

Ich habe folgendes Problem: Habe meinen PC und meinen Laptop vernetzt (Ethernet). Früher nutze ich immer auf beiden Rechnern SuSE, jetzt hab ich mal, weils im Moment so billig ist, für den Laptop Red Hat 7.1 gekauft. Leider kann ich jetzt auf dem Laptop (NFS-Client) keine Verzeichnisse vom PC (NFS-Server) mounten. Das lustige an der Sache ist, dass ich mich per telnet vom Laptop auf dem Server einloggen kann. Andersherum bekomme ich folgendes Ergebnis:

root@cartman:~ > telnet kenny
Trying 192.168.100.98...
telnet: connect to address 192.168.100.98: Connection refused

Es funktioniert also nicht. Bei Verbindung zwisch Suse und Suse war das nie ein Problem.

Ich habe bereits eine Pro-Linux-Anleitung genutzt. Das Ergebnis ist, das er mir bei dem Befehl rpcinfo -p nur den portmapper anzeigt jedoch nfs und mountd nicht.
Bereits während dem booten bekomme ich zwei Fehlermeldungen bzgl. Netzwerkkarte und NFS.

in der Datei /var/log/messages.txt vom Laptop steht folgendes:

insmod: lib/modules/2.4.2-2/kernel/drivers/net/tulip/tulip.o:init_module: No such device
insmod: lib/modules/2.4.2-2/kernel/drivers/net/tulip/tulip.o:insmod eth0 failed
ifup: Delaying eth0 initialization
network: Bringing up interface eth0: failed

und weiter unten:

mount: mount: RPC: Kann nicht senden; errno = Das Netzwerk ist nicht erreichbar
netfs: Mounting NFS filesystem: failed

Wenn ich das jetzt richtig verstehe ist der Treiber für meine PCMCIA-Netzwerkkarte nicht als Module im Kernel einkompiliert, oder?
Leider kenne ich mich mit Red Hat garnicht aus. Kann ich das Problem lösen indem ich mir einen neuen Kernel baue?

Wie baue ich den Kernel am besten für Red Hat um alle anderen Module zu behalten ( make oldconfig) ???

Ich hoffe mir kann jemand helfen der mit Red Hat mehr Erfahrungen hat!

Vielen Dank für eure Hilfe!

MfG

Patrick
 

Rossi
Gast





BeitragVerfasst am: 08. Nov 2001 12:33   Titel: Re: NFS zwischen Suse 7.2 und Red Hat 7.1

Zum Telnet. Es sieht so aus, als ob der telnetd nicht auf dem Laptop läuft. Was mich wundert, ist, das Du telnet ohne (funktionierende) Netzwerkkarte machen kannst.

Also, zum zweiten Thema: nach dem Einloggen, hast Du ein eth0 ? Must Du ja, wenn Du Telnetten kannst. Also muß - warum auch immer, die Netzwerkkarte nach dem NFS initialisiert werden. Schau also Deine Logs nochmal durch, wo und wann die die Karte initialisiert wird.
 

trinity



Anmeldungsdatum: 12.10.2001
Beiträge: 821

BeitragVerfasst am: 08. Nov 2001 13:01   Titel: Re: NFS zwischen Suse 7.2 und Red Hat 7.1

@Patrick
entweder bei dir ist der telnetd nicht aktiviert, oder aber er ist schon gar nicht installiert (oder aber beides)
versuch mal mittels ssh auf den rh rechner zuzugreifen.

was die NFS geschichte angeht, die hat ja erstmal überhaupt nichts mit telnet & Co zu tun.
1.gib mal bitte ifconfig ein und präsentiere uns dein Ergebnis.
2. Problemlösung durch neuen Kernel bauen, sit nur möglich wenn man das Problem auch erkannt hat. dies ist jedoch heier noch nicht der Fall. Da dein Netzwerk anscheinend funktioniert.
3. schaue nochmals unter /var/log/boot.* und schaue nach den aktivierten komponenten

Lutz
_________________
"Korrekt, Freundlich, Kostenfrei", wähle genau zwei. (Lutz Donnerhacke in dcsf)
 
Benutzer-Profile anzeigen Private Nachricht senden

Patrick
Gast





BeitragVerfasst am: 09. Nov 2001 20:38   Titel: Re: NFS zwischen Suse 7.2 und Red Hat 7.1

@Rossi

Hallo Rossi! Wie Du anhand der boot.log (siehe unten) sehen kannst versucht das System zuerst die Ethernetkarte zu initialisieren. Anschließend versucht es das NFS zu mounten. Habe die NFS-Freigabeeinstellungen unter RedHat mit Linuxconf verändert. Anschließend kann das NFS über ein Icon auf dem Desktop gemountet werden! (Teilerfolg )
Da an der Laptop eine PCMCIA-Netzwerkkarte hat kann es evtl. sein, dass das Problem daran liegt das der cardmanager erst zu einem späteren Zeitpunkt als Interface eth0 initialisiert wird?
Kann ich die Reihenfolge der Dienste ändern (z.B. mit SysV-Init-Editor) ???

@Lutz
Als Anlage die Ausgabe von ifconfig. Ich konnte mich von dem Suse-PC (Server) aus nicht über ssh einloggen, also genau wie bei telnet auch! Das lustige ist, vom RedHat aus kann ich mich mittels "ssh -l user -X kenny" auf dem Server einloggen, Programme ausführen und ihn als root sogar neu booten!!!! (Ich weiß, das ist eine schlechte Sicherheiseinstellung !! )
Kann es evtl. an iptables und ipchains von RH liegen, dass ich mich nicht als remote user einloggen kann??

Vielen Dank für eure Hilfe!!

Bis bald,

Patrick



Ausschnitte aus /var/log/boot.log
Nov 9 20:16:58 kenny network: Setting network parameters: succeeded
Nov 9 20:17:00 kenny network: Bringing up interface lo: succeeded
Nov 9 20:17:00 kenny ifup: Delaying eth0 initialization.
Nov 9 20:17:00 kenny network: Bringing up interface eth0: failed
Nov 9 20:17:01 kenny nfslock: rpc.statd startup succeeded

Nov 9 20:17:06 kenny pcmcia: cardmgr.
Nov 9 20:17:06 kenny rc: Starting pcmcia: succeeded

Nov 9 20:17:09 kenny mount: mount: RPC: Kann nicht senden; errno = Das Netzwerk ist nicht erreichbar
Nov 9 20:17:09 kenny netfs: Mounting NFS filesystems: failed
Nov 9 20:17:11 kenny netfs: Mounting other filesystems: succeeded
Nov 9 20:17:11 kenny apmd: apmd startup succeeded
Nov 9 20:17:12 kenny autofs: autofs startup succeeded
 

Patrick
Gast





BeitragVerfasst am: 09. Nov 2001 20:39   Titel: Re: NFS zwischen Suse 7.2 und Red Hat 7.1

@Rossi

Hallo Rossi! Wie Du anhand der boot.log (siehe unten) sehen kannst versucht das System zuerst die Ethernetkarte zu initialisieren. Anschließend versucht es das NFS zu mounten. Habe die NFS-Freigabeeinstellungen unter RedHat mit Linuxconf verändert. Anschließend kann das NFS über ein Icon auf dem Desktop gemountet werden! (Teilerfolg )
Da an der Laptop eine PCMCIA-Netzwerkkarte hat kann es evtl. sein, dass das Problem daran liegt das der cardmanager erst zu einem späteren Zeitpunkt als Interface eth0 initialisiert wird?
Kann ich die Reihenfolge der Dienste ändern (z.B. mit SysV-Init-Editor) ???

@Lutz
Als Anlage die Ausgabe von ifconfig. Ich konnte mich von dem Suse-PC (Server) aus nicht über ssh einloggen, also genau wie bei telnet auch! Das lustige ist, vom RedHat aus kann ich mich mittels "ssh -l user -X kenny" auf dem Server einloggen, Programme ausführen und ihn als root sogar neu booten!!!! (Ich weiß, das ist eine schlechte Sicherheiseinstellung !! )
Kann es evtl. an iptables und ipchains von RH liegen, dass ich mich nicht als remote user einloggen kann??

Vielen Dank für eure Hilfe!!

Bis bald,

Patrick



Ausschnitte aus /var/log/boot.log
Nov 9 20:16:58 kenny network: Setting network parameters: succeeded
Nov 9 20:17:00 kenny network: Bringing up interface lo: succeeded
Nov 9 20:17:00 kenny ifup: Delaying eth0 initialization.
Nov 9 20:17:00 kenny network: Bringing up interface eth0: failed
Nov 9 20:17:01 kenny nfslock: rpc.statd startup succeeded

Nov 9 20:17:06 kenny pcmcia: cardmgr.
Nov 9 20:17:06 kenny rc: Starting pcmcia: succeeded

Nov 9 20:17:09 kenny mount: mount: RPC: Kann nicht senden; errno = Das Netzwerk ist nicht erreichbar
Nov 9 20:17:09 kenny netfs: Mounting NFS filesystems: failed
Nov 9 20:17:11 kenny netfs: Mounting other filesystems: succeeded
Nov 9 20:17:11 kenny apmd: apmd startup succeeded
Nov 9 20:17:12 kenny autofs: autofs startup succeeded

Ausgabe ifconfig:

[root@kenny /root]# ifconfig
eth0 Linkverkapselung:Ethernet HWaddr 00:E0:98:95:B8:16
inet addr:192.168.100.98 Bcast:192.168.100.255 Maske:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Empfangene Pakete:12198 Fehler:0 Weggeworfen:0 Überlauf:0 Rahmen:0
Verschickte Packete:6725 Fehler:4 Weggeworfen:0 Überlauf:4 Rahmen:0
Kollisionen:0 Sendewarteschlangenlänge:100
Interrupt:11 Basisadresse:0x1000

lo Linkverkapselung:Locale Schleife
inet addr:127.0.0.1 Maske:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
Empfangene Pakete:4 Fehler:0 Weggeworfen:0 Überlauf:0 Rahmen:0
Verschickte Packete:4 Fehler:0 Weggeworfen:0 Überlauf:0 Rahmen:0
Kollisionen:0 Sendewarteschlangenlänge:0
 

Patrick
Gast





BeitragVerfasst am: 10. Nov 2001 12:34   Titel: Re: NFS zwischen Suse 7.2 und Red Hat 7.1

@ Alle

Es hat sich erledigt. Hab die Init-reihenfolge geändert, sshd nachinstalliert und telnetd im Runlevel eingefügt.

Jetzt funzt alles!

Patrick
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy