Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
routing startet nicht ( device not found)

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
KRXY
Gast





BeitragVerfasst am: 16. Jan 2002 13:21   Titel: routing startet nicht ( device not found)

Hallo

Ich möchte mir gerne einen Router einrichten um das Modem in meinem kleinen Win98-LAN zu sharen. Soweit habe ich mich auch schon informiert und weiß das das ip_forwarding, Masquerading usw. im Kernel aktiviert werden muss. Jetzt kommen die Probleme: Ich habe das Modem an Com2 angeschlossen und wenn ich mich mit den Rechner der als Router laufen soll einwählen will dann klappt das auch wunderbar! Auch DOD läuft prima. Nur mit route.conf haperts bei mir. was muss da eingetragen werden? Meine Einträge lauten wie folgt: 192.168.0.2 0.0.0.0 255.255.255.0 eth0
default 192.168.0.2 0.0.0.0 ppp1
Das Problem ist nun das er den zweiten Eintrag irgenwie nicht versteht und sag dev ppp1 Device unknown oder so ähnlich. So als ob das modem nicht ansprechbar oder garnicht da wäre. Was kann ich da tun
Danke im vorraus
KRXY
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 16. Jan 2002 14:00   Titel: Re: routing startet nicht ( device not found)

mal ifconfig aufrufen, das gibt auskunft über die konfigurierten devices. wahrscheinlich müsste es ppp0 heissen.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

KRXY
Gast





BeitragVerfasst am: 16. Jan 2002 14:58   Titel: Re: routing startet nicht ( device not found)

Also ppp0 ist meiner Meinung nach für die erste COM-Schnittstelle. Wie sieht es denn aus wenn ich stattdessen /dev/modem angebe? Das wird auch nicht funzen oder? Muss ich da dann eigentlich auch noch rechte setzten?
 

trinity



Anmeldungsdatum: 12.10.2001
Beiträge: 821

BeitragVerfasst am: 16. Jan 2002 15:26   Titel: Re: routing startet nicht ( device not found)

>Also ppp0 ist meiner Meinung nach für die erste COM-Schnittstelle.

Dann wird es Zeit die Meinung zu ändern .
ppp0 ist i.d.R die Schnittstelle fürs Modem. Die "COM"-Ports (Die es def. nur unter DOS/Windows gibt) heissen unter Linux ttyS*

>Wie sieht es denn aus wenn ich stattdessen /dev/modem angebe? Das wird auch nicht funzen oder?

Lies den Beitrag von Thomas nochmals. Folgendes, ist jetzt nicht bös gemeint (aber eine Überlegung Wert): Du stellst eine Frage, bekommst eine Antwort (IMHO eine völlig korrekte) und du bist so freundlich diesen Ratschlag 1. völlig zu ignorieren und 2. Ihn mehr oder weniger als falsch darzustellen. Gegenfrage: Wenn man es besser weiss wieso Fragen?
_________________
"Korrekt, Freundlich, Kostenfrei", wähle genau zwei. (Lutz Donnerhacke in dcsf)


Zuletzt bearbeitet von trinity am 16. Jan 2002 15:26, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

KRXY
Gast





BeitragVerfasst am: 16. Jan 2002 15:33   Titel: Re: routing startet nicht ( device not found)

Tut mir leid wenn da so blöde rüberkam! Hiermit entschuldige ich mich dafür!!
Aber ich habe mein Modem an COM 2 angeschlossen. Dann müsste es doch ppp1 sein oder etwa nicht?
Danke für eure Hilfen und nicht böse sein!
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 16. Jan 2002 15:46   Titel: Re: routing startet nicht ( device not found)

die geräreschnittstelle (dev/ttyS1 oder /dev/modem) hat nichts mit der netzwerkschnittstelle (ppp0) zu tun. die beiden zu verbinden ist auch nicht thema deiner fragen. noch etwas: das routing läuft über die netzwerkschnittstelle
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 16. Jan 2002 15:46   Titel: Re: routing startet nicht ( device not found)

die geräreschnittstelle (dev/ttyS1 oder /dev/modem) hat nichts mit der netzwerkschnittstelle (ppp0) zu tun. die beiden zu verbinden ist auch nicht thema deiner fragen. noch etwas: das routing läuft über die netzwerkschnittstelle

ups


Zuletzt bearbeitet von gewitter am 16. Jan 2002 15:46, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

KRXY
Gast





BeitragVerfasst am: 17. Jan 2002 9:08   Titel: Re: routing startet nicht ( device not found)

Alles Klar! Danke für eure Hilfe. Soweit habe ich das nun auch hinbekommen. Bei einer Anfrage des Clients ins Internet verbindet der Router auch aber er trennt sofort wieder und leitet die Pakete nicht weiter. Ich habe gehört das das irgendwie mit ipchains zusammenhängt oder so. Ich benutzte Linux 7.3. Auch da habe ich gehört das das nicht so gut funktioniert. Vielleicht könnt ihr mir ja nochmal helfen. Ich habe gelesen mit diesem Befehl lässt sich der Fehler beheben: ipchains -A forward -i ppp0 -j MASQ -r 192.168.3.0/24
Bei mir bekomme ich da aber nur die Fehlermeldung, daß die option -r nicht bekannt sei! Was kann ich tun?? Wo ist mein Fehler?
 

trinity



Anmeldungsdatum: 12.10.2001
Beiträge: 821

BeitragVerfasst am: 17. Jan 2002 10:33   Titel: Re: routing startet nicht ( device not found)

AFAIK meinst du den Parameter -s also folgendermaßen: ipchains -A forward -i ppp0 -j MASQ -s 192.168.3.0/24
Wenn du SuSE7.3 verwendest, setzt du vermutlich auch Kernel 2.4 ein. Dort sollte man von ipchains auf iptables wechseln.
_________________
"Korrekt, Freundlich, Kostenfrei", wähle genau zwei. (Lutz Donnerhacke in dcsf)
 
Benutzer-Profile anzeigen Private Nachricht senden

KRXY
Gast





BeitragVerfasst am: 17. Jan 2002 13:02   Titel: Re: routing startet nicht ( device not found)

Ist die Syntax für das iptables den gleich? Muss ich ipchains dafür entfernen? Wo finde ich iptables??
 

trinity



Anmeldungsdatum: 12.10.2001
Beiträge: 821

BeitragVerfasst am: 17. Jan 2002 17:34   Titel: Re: routing startet nicht ( device not found)

Also ich weiss nicht, ob das mit Linux7.3 noch unterstützt wird *SCNR*

Am besten du schaust mal im Paketinstallationsmenü deiner Distribution nach. Dort findest sich das Programm iptables. Das Programm ipchains muss nicht entfernet werden. Solltest du keine Distributionsfirewall benutzen, brauchst du dir um ipchains keine Sorgen machen.
nein die Syntax ist nicht gleich (in vielen Fällen zwar schon, aber eben nicht in allen).
Weitere Hinweise Liefert Dir auch gerne Deine manpage...
_________________
"Korrekt, Freundlich, Kostenfrei", wähle genau zwei. (Lutz Donnerhacke in dcsf)
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy